aboutsummaryrefslogtreecommitdiff
path: root/net/avahi-qt4/Makefile
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2007-10-26 19:58:27 +0000
committerMichael Johnson <ahze@FreeBSD.org>2007-10-26 19:58:27 +0000
commit79294447d7a82e3e3d14a0b2e0434139e4cd8b25 (patch)
treec43c202b53cfdae02a7743ca78f4f64394944e03 /net/avahi-qt4/Makefile
parentebca84c0c76db2038d4df4a695108b04d0f580e6 (diff)
downloadports-79294447d7a82e3e3d14a0b2e0434139e4cd8b25.tar.gz
ports-79294447d7a82e3e3d14a0b2e0434139e4cd8b25.zip
Notes
Diffstat (limited to 'net/avahi-qt4/Makefile')
-rw-r--r--net/avahi-qt4/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/net/avahi-qt4/Makefile b/net/avahi-qt4/Makefile
new file mode 100644
index 000000000000..e11d313c11cb
--- /dev/null
+++ b/net/avahi-qt4/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: avahi-qt4
+# Date created: 26 October 2007
+# Whom: Michael Johnson <ahze@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= net
+PKGNAMESUFFIX= -qt4
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Qt 4 bindings to the Avahi mDNS system
+
+LIB_DEPENDS= avahi-common.3:${PORTSDIR}/net/avahi
+
+MASTERDIR= ${.CURDIR}/../avahi-app
+BUILD_WRKSRC= ${WRKSRC}/avahi-qt
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+
+AVAHI_SLAVE= qt4
+USE_GNOME= gnomehack gnometarget ltverhack
+USE_QT_VER= 4
+QT_COMPONENTS= corelib moc_build
+AVAHI_PKGCONFIG= avahi-qt4.pc
+
+.include "${MASTERDIR}/Makefile"