aboutsummaryrefslogtreecommitdiff
path: root/net/axa/Makefile
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2015-04-05 23:50:04 +0000
committerDon Lewis <truckman@FreeBSD.org>2015-04-05 23:50:04 +0000
commite0926c9f5ab6543fe40f1ee778c667d3add2e1bb (patch)
tree6ee17a0c4a2ed4dbe75d84e0e25f0a10e63c941e /net/axa/Makefile
parent9335531ff37fe0d7b4379e3c91150ef2a0eab788 (diff)
downloadports-e0926c9f5ab6543fe40f1ee778c667d3add2e1bb.tar.gz
ports-e0926c9f5ab6543fe40f1ee778c667d3add2e1bb.zip
Notes
Diffstat (limited to 'net/axa/Makefile')
-rw-r--r--net/axa/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/net/axa/Makefile b/net/axa/Makefile
index 0338f8776604..8c65aac02dc0 100644
--- a/net/axa/Makefile
+++ b/net/axa/Makefile
@@ -2,28 +2,31 @@
PORTNAME= axa
PORTVERSION= 1.0.0
+# Use GH_TAGNAME until USE_GITHUB can cope with / in DISTVERSIONPREFIX
+#DISTVERSIONPREFIX= tags/v
+PORTREVISION= 1
CATEGORIES= net dns
MAINTAINER= truckman@FreeBSD.org
COMMENT= AXA library and tools
LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/copyright
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
sie-nmsg>0:${PORTSDIR}/net/sie-nmsg
LIB_DEPENDS= libprotobuf-c.so:${PORTSDIR}/devel/protobuf-c \
libnmsg.so:${PORTSDIR}/net/nmsg \
libwdns.so:${PORTSDIR}/dns/wdns
+RUN_DEPENDS= sie-nmsg>0:${PORTSDIR}/net/sie-nmsg
USE_GITHUB= yes
GH_ACCOUNT= farsightsec
-GH_COMMIT= bf9c038
-GH_TAGNAME= ${GH_COMMIT}
+GH_TAGNAME= tags/v${PORTVERSION}
GNU_CONFIGURE= yes
USES= autoreconf gmake libtool pathfix pkgconfig
CONFIGURE_SHELL= ${LOCALBASE}/bin/bash
-INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
PORTDOCS= *
@@ -39,6 +42,8 @@ DOXYGEN_ALL_TARGET= html-local
.if ${PORT_OPTIONS:MDOXYGEN}
post-install:
+ # install-strip does not strip libaxa.so
+ ${STRIP_CMD} ${STAGEDIR}/${PREFIX}/lib/libaxa.so.0.0.0
(cd ${WRKSRC}/doc/doxygen && ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR})
.endif