aboutsummaryrefslogtreecommitdiff
path: root/net/axa
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-12-15 22:38:15 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-12-15 22:38:15 +0000
commit2b597801799084d2bb95e3956028cf070d5c67c0 (patch)
tree8e5e8bc3bb34869235d27fdc461a6e158b1db375 /net/axa
parent01a8d21c009ad5627b33f130cc775355d11200fc (diff)
Advanced Exchange Access (AXA) is a suite of tools and library code
that brings the capabilities of the Farsight Security Information Exchange (SIE) right to a remote user's network. WWW: https://github.com/farsightsec/axa PR: 195695 Submitted by: truckman@FreeBSD.org
Notes
Notes: svn path=/head/; revision=374771
Diffstat (limited to 'net/axa')
-rw-r--r--net/axa/Makefile49
-rw-r--r--net/axa/distinfo2
-rw-r--r--net/axa/pkg-descr5
-rw-r--r--net/axa/pkg-plist24
4 files changed, 80 insertions, 0 deletions
diff --git a/net/axa/Makefile b/net/axa/Makefile
new file mode 100644
index 000000000000..87fd6da0016e
--- /dev/null
+++ b/net/axa/Makefile
@@ -0,0 +1,49 @@
+# $FreeBSD$
+
+PORTNAME= axa
+PORTVERSION= 1.0.0
+CATEGORIES= net dns
+
+MAINTAINER= truckman@FreeBSD.org
+COMMENT= AXA library and tools
+
+LICENSE= APACHE20
+
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
+ sie-nmsg>0:${PORTSDIR}/net/sie-nmsg
+LIB_DEPENDS= libprotobuf-c.so:${PORTSDIR}/devel/protobuf-c \
+ libnmsg.so:${PORTSDIR}/net/nmsg \
+ libwdns.so:${PORTSDIR}/dns/wdns
+
+USE_GITHUB= yes
+GH_ACCOUNT= farsightsec
+GH_COMMIT= bf9c038
+GH_TAGNAME= ${GH_COMMIT}
+
+GNU_CONFIGURE= yes
+USES= gmake libtool pathfix pkgconfig
+USE_AUTOTOOLS= aclocal autoconf autoheader automake libtoolize
+AUTOMAKE_ARGS= --add-missing
+CONFIGURE_SHELL= ${LOCALBASE}/bin/bash
+INSTALL_TARGET= install-strip
+USE_LDCONFIG= yes
+
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOXYGEN
+OPTIONS_DEFAULT=DOXYGEN
+
+.include <bsd.port.options.mk>
+
+ALL_TARGET= all
+.if ${PORT_OPTIONS:MDOXYGEN}
+BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
+ALL_TARGET+= html-local
+.endif
+
+.if ${PORT_OPTIONS:MDOXYGEN}
+post-install:
+ (cd ${WRKSRC}/doc/doxygen && ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR})
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/axa/distinfo b/net/axa/distinfo
new file mode 100644
index 000000000000..caa592a459dc
--- /dev/null
+++ b/net/axa/distinfo
@@ -0,0 +1,2 @@
+SHA256 (axa-1.0.0.tar.gz) = fe118b1270a3d39c967070f57873911fc4369927848f8565368afea9e6ea4fde
+SIZE (axa-1.0.0.tar.gz) = 150904
diff --git a/net/axa/pkg-descr b/net/axa/pkg-descr
new file mode 100644
index 000000000000..bf96787726af
--- /dev/null
+++ b/net/axa/pkg-descr
@@ -0,0 +1,5 @@
+Advanced Exchange Access (AXA) is a suite of tools and library code
+that brings the capabilities of the Farsight Security Information
+Exchange (SIE) right to a remote user's network.
+
+WWW: https://github.com/farsightsec/axa
diff --git a/net/axa/pkg-plist b/net/axa/pkg-plist
new file mode 100644
index 000000000000..e6dc0222b158
--- /dev/null
+++ b/net/axa/pkg-plist
@@ -0,0 +1,24 @@
+bin/radtool
+bin/sratool
+bin/sratunnel
+%%ETCDIR%%/fields
+include/axa/axa.h
+include/axa/axa_endian.h
+include/axa/bits.h
+include/axa/client.h
+include/axa/dns_walk.h
+include/axa/fields.h
+include/axa/open_nmsg_out.h
+include/axa/protocol.h
+include/axa/rad_mod.h
+include/axa/socket.h
+include/axa/trie.h
+include/axa/wire.h
+lib/libaxa.a
+lib/libaxa.so
+lib/libaxa.so.0
+lib/libaxa.so.0.0.0
+libdata/pkgconfig/libaxa.pc
+man/man1/radtool.1.gz
+man/man1/sratool.1.gz
+man/man1/sratunnel.1.gz