aboutsummaryrefslogtreecommitdiff
path: root/net/balance
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-11-04 20:11:47 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-11-04 20:11:47 +0000
commitc86559205684ccd660f24eaf85086e8643de4419 (patch)
treec26a68c9271e6441d09ccf6160744b486d95613a /net/balance
parentee823149c3093f52422abdd50a0758646c6792a8 (diff)
downloadports-c86559205684ccd660f24eaf85086e8643de4419.tar.gz
ports-c86559205684ccd660f24eaf85086e8643de4419.zip
- Update to version 3.11
PR: 58936 Submitted by: Joseph Scott <joseph@randomnetworks.com> (maintainer)
Notes
Notes: svn path=/head/; revision=93105
Diffstat (limited to 'net/balance')
-rw-r--r--net/balance/Makefile10
-rw-r--r--net/balance/distinfo2
-rw-r--r--net/balance/files/patch-Makefile17
3 files changed, 7 insertions, 22 deletions
diff --git a/net/balance/Makefile b/net/balance/Makefile
index efe87c8def96..718e1a45f550 100644
--- a/net/balance/Makefile
+++ b/net/balance/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= balance
-PORTVERSION= 3.6
+PORTVERSION= 3.11
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= balance
@@ -15,14 +15,16 @@ MAINTAINER= joseph@randomnetworks.com
COMMENT= Simple but powerful generic tcp proxy with round robin features
ALL_TARGET= balance
+USE_REINPLACE= yes
MAN1= balance.1
+post-patch:
+ ${REINPLACE_CMD} -e 's|^CFLAGS|#CFLAGS|g ; \
+ s|^CC|#CC|g' ${WRKSRC}/Makefile
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/balance ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/balance.1 ${PREFIX}/man/man1
-post-install:
- @${STRIP_CMD} ${PREFIX}/bin/balance
-
.include <bsd.port.mk>
diff --git a/net/balance/distinfo b/net/balance/distinfo
index 8c7ec2c455c3..34ac038267d7 100644
--- a/net/balance/distinfo
+++ b/net/balance/distinfo
@@ -1 +1 @@
-MD5 (balance-3.6.tar.gz) = d3b0729937eea2a76e02c46416bd48ec
+MD5 (balance-3.11.tar.gz) = 69e72ccbcb3d397d569487e85663c01a
diff --git a/net/balance/files/patch-Makefile b/net/balance/files/patch-Makefile
deleted file mode 100644
index 235771157102..000000000000
--- a/net/balance/files/patch-Makefile
+++ /dev/null
@@ -1,17 +0,0 @@
---- Makefile.orig Mon Jan 27 09:26:14 2003
-+++ Makefile Mon Jan 27 09:26:21 2003
-@@ -1,12 +1,12 @@
- # $Id: Makefile,v 1.3 2002/10/11 20:01:12 tommy Exp tommy $
-
- #CFLAGS=-g -I.
--CFLAGS=-O
-+#CFLAGS=-O
-
- # uncomment for Solaris:
- # LIBRARIES=-lsocket -lnsl
-
--CC=gcc
-+#CC=gcc
- RELEASE=3.6
-
- balance: balance.c butils.o balance.h