aboutsummaryrefslogtreecommitdiff
path: root/net/bctoolbox/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
commit707c6bf295fc3955c86c9244533c1524bb7dea15 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /net/bctoolbox/Makefile
parente3b5edc5e789bcd6057c4a01e4c618dbb1509756 (diff)
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=488341
Diffstat (limited to 'net/bctoolbox/Makefile')
-rw-r--r--net/bctoolbox/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/net/bctoolbox/Makefile b/net/bctoolbox/Makefile
index 2feb5f05a4e5..16c32c733981 100644
--- a/net/bctoolbox/Makefile
+++ b/net/bctoolbox/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= mbedtls>=2.3.0_2:security/mbedtls
LIB_DEPENDS= libmbedtls.so:security/mbedtls
-USES= cmake:outsource compiler:c++11-lib
+USES= cmake compiler:c++11-lib
USE_LDCONFIG= yes
CFLAGS+= -DHAVE_ARC4RANDOM