aboutsummaryrefslogtreecommitdiff
path: root/net/beacon
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-09-08 23:26:09 +0000
committerJohn Marino <marino@FreeBSD.org>2014-09-08 23:26:09 +0000
commitb6e0fe2f3c4e2a49fa2856e92bcf4ccd83c444ad (patch)
treecd5da1b378eb8e0484678b459ce4f06a75eb790f /net/beacon
parentd24362f48bbb58f22a69e382bc7b7a65ee5a8e7c (diff)
downloadports-b6e0fe2f3c4e2a49fa2856e92bcf4ccd83c444ad.tar.gz
ports-b6e0fe2f3c4e2a49fa2856e92bcf4ccd83c444ad.zip
Stage net/beacon and assign maintainership to submitter
PR: 193183 Submitted by: Chris Hutchinson Tweaked by: marino
Notes
Notes: svn path=/head/; revision=367710
Diffstat (limited to 'net/beacon')
-rw-r--r--net/beacon/Makefile32
-rw-r--r--net/beacon/pkg-descr11
-rw-r--r--net/beacon/pkg-plist8
3 files changed, 22 insertions, 29 deletions
diff --git a/net/beacon/Makefile b/net/beacon/Makefile
index 1a794160999e..069c09f93b3e 100644
--- a/net/beacon/Makefile
+++ b/net/beacon/Makefile
@@ -3,13 +3,16 @@
PORTNAME= beacon
PORTVERSION= 1.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net perl5 mbone ipv6
MASTER_SITES= SF/multicastbeacon/multicastbeacon/beacon%20v${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= portmaster@bsdforge.com
COMMENT= Beacon active measurement tool to monitor multicast
+LICENSE= BSD4CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= p5-Net>=0:${PORTSDIR}/net/p5-Net
RUN_DEPENDS= p5-Net>=0:${PORTSDIR}/net/p5-Net
@@ -17,27 +20,24 @@ WWW_DIR?= ${PREFIX}/www/
PLIST_SUB+= VERSION=${PORTVERSION}
USES= perl5
+USE_PERL5+= fixpacklist
USE_AUTOTOOLS= autoconf
+PORTDOCS= README
-OPTIONS_DEFINE= IPV6
-OPTIONS_DEFAULT=
+OPTIONS_DEFINE= DOCS IPV6
IPV6_DESC= Enable IPv6 PTR lookups
+IPV6_CONFIGURE_ENABLE= ipv6
+IPV6_BUILD_DEPENDS= p5-Socket6>=0:${PORTSDIR}/net/p5-Socket6
-NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MIPV6}
-BUILD_DEPENDS+= p5-Socket6>=0:${PORTSDIR}/net/p5-Socket6
-CONFIGURE_ARGS+= --enable-ipv6
-.else
-CONFIGURE_ARGS+= --disable-ipv6
-.endif
-
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}/
- @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
-.endif
+ ${STRIP_CMD} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/Net/Multicast/Beacon/Beacon.so
+ cd ${WRKSRC}/src/FreeBSD/ && \
+ ${INSTALL_DATA} beacon ${STAGEDIR}${PREFIX}/etc/rc.d
+ ${RM} ${STAGEDIR}${PREFIX}/lib/perl5/${PERL_VER}/${PERL_ARCH}/perllocal*
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/net/beacon/pkg-descr b/net/beacon/pkg-descr
index 0af1ba7fd740..e91b75711872 100644
--- a/net/beacon/pkg-descr
+++ b/net/beacon/pkg-descr
@@ -1,7 +1,6 @@
-The NLANR/DAST Multicast Beacon is a program written in Perl which uses the
-RTP protocol to provide useful statistics and diagnostic information about
-a given multicast group.
-The Multicast Beacon can be used as a general-purpose active multicast
-measurement tool.
+The NLANR/DAST Multicast Beacon is a program written in Perl which uses
+the RTP protocol to provide useful statistics and diagnostic information
+about a given multicast group. The Multicast Beacon can be used as a
+general-purpose active multicast measurement tool.
-WWW: http://sourceforge.net/projects/multicastbeacon/
+WWW: http://sourceforge.net/projects/multicastbeacon
diff --git a/net/beacon/pkg-plist b/net/beacon/pkg-plist
index 680f1f9fa96b..148c99c28c04 100644
--- a/net/beacon/pkg-plist
+++ b/net/beacon/pkg-plist
@@ -1,16 +1,10 @@
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Multicast/Beacon/Beacon.so
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Multicast/Beacon/.packlist
%%SITE_PERL%%/%%PERL_ARCH%%/Net/Multicast/Beacon.pm
-lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/perllocal.pod
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Multicast/Beacon
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Multicast/
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Net/Multicast/
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Net
bin/beacon
-@unexec if cmp -s %D/etc/beacon.conf.sample %D/etc/beacon.conf; then rm -f %D/etc/beacon.conf; fi
-etc/beacon.conf.sample
-@exec if [ ! -f %D/etc/beacon.conf ] ; then cp -p %D/%F %B/beacon.conf; fi
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@sample etc/beacon.conf.sample
etc/rc.d/beacon