aboutsummaryrefslogtreecommitdiff
path: root/net/beacon
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
commiteee58d187e2c55fca6f53b9e482d33cf5346fe81 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /net/beacon
parent3f1df82a16a1e89db9a69b36ade7342f34095ab4 (diff)
downloadports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.tar.gz
ports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Notes
Notes: svn path=/head/; revision=373448
Diffstat (limited to 'net/beacon')
-rw-r--r--net/beacon/Makefile6
-rw-r--r--net/beacon/pkg-plist9
2 files changed, 4 insertions, 11 deletions
diff --git a/net/beacon/Makefile b/net/beacon/Makefile
index 4d2997dc7d76..f066e151ff4b 100644
--- a/net/beacon/Makefile
+++ b/net/beacon/Makefile
@@ -3,7 +3,7 @@
PORTNAME= beacon
PORTVERSION= 1.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net perl5 mbone ipv6
MASTER_SITES= SF/multicastbeacon/multicastbeacon/beacon%20v${PORTVERSION}
@@ -20,7 +20,6 @@ WWW_DIR?= ${PREFIX}/www/
PLIST_SUB+= VERSION=${PORTVERSION}
USES= perl5
-USE_PERL5+= fixpacklist
USE_AUTOTOOLS= autoconf
PORTDOCS= README
@@ -31,8 +30,7 @@ IPV6_CONFIGURE_ENABLE= ipv6
IPV6_BUILD_DEPENDS= p5-Socket6>=0:${PORTSDIR}/net/p5-Socket6
post-install:
- ${STRIP_CMD} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/Net/Multicast/Beacon/Beacon.so
- ${RM} ${STAGEDIR}${PREFIX}/lib/perl5/${PERL_VER}/${PERL_ARCH}/perllocal*
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Net/Multicast/Beacon/Beacon.so
@${MKDIR} ${STAGEDIR}${DOCSDIR}/
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
diff --git a/net/beacon/pkg-plist b/net/beacon/pkg-plist
index 148c99c28c04..d26f76e8baed 100644
--- a/net/beacon/pkg-plist
+++ b/net/beacon/pkg-plist
@@ -1,10 +1,5 @@
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Multicast/Beacon/Beacon.so
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Multicast/Beacon/.packlist
-%%SITE_PERL%%/%%PERL_ARCH%%/Net/Multicast/Beacon.pm
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Multicast/Beacon
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Multicast/
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Net/Multicast/
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Net
+%%SITE_ARCH%%/auto/Net/Multicast/Beacon/Beacon.so
+%%SITE_ARCH%%/Net/Multicast/Beacon.pm
bin/beacon
@sample etc/beacon.conf.sample
etc/rc.d/beacon