aboutsummaryrefslogtreecommitdiff
path: root/net/beanstalkd
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2012-10-19 12:27:52 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2012-10-19 12:27:52 +0000
commit63761d19796d6a34008eda8dfcd4656c0e38ac43 (patch)
treea326696323c4bbc179d3aa576dde0fe456fd12af /net/beanstalkd
parent46c2c1f3443f4d3bd49059e997edf978723a2414 (diff)
downloadports-63761d19796d6a34008eda8dfcd4656c0e38ac43.tar.gz
ports-63761d19796d6a34008eda8dfcd4656c0e38ac43.zip
- Update to 1.7
- Remove LICENSE_FILE for those listed in bsd.licenses.db.mk - Add test and regression-test targets - Patch integ-test.c so we can run unit tests (#include order, thanks ak!) - New Makefile header convention Changes: http://kr.github.com/beanstalkd/2012/09/11/1.7-release-notes.html PR: 172405 Submitted by: Kubilay Kocak <koobs.freebsd at gmail.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=306116
Diffstat (limited to 'net/beanstalkd')
-rw-r--r--net/beanstalkd/Makefile13
-rw-r--r--net/beanstalkd/distinfo4
-rw-r--r--net/beanstalkd/files/patch-integ-test.c12
3 files changed, 20 insertions, 9 deletions
diff --git a/net/beanstalkd/Makefile b/net/beanstalkd/Makefile
index bb1295d75969..e83593391b50 100644
--- a/net/beanstalkd/Makefile
+++ b/net/beanstalkd/Makefile
@@ -1,12 +1,7 @@
-# New ports collection makefile for: beanstalkd
-# Date created: Apr 11, 2008
-# Whom: Vsevolod Stakhov <vsevolod@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= beanstalkd
-PORTVERSION= 1.6
+PORTVERSION= 1.7
CATEGORIES= net
MASTER_SITES= http://cloud.github.com/downloads/kr/beanstalkd/
@@ -14,7 +9,6 @@ MAINTAINER= vsevolod@FreeBSD.org
COMMENT= Fast, distributed, in-memory workqueue service
LICENSE= MIT
-LICENSE_FILE= ${WRKSRC}/LICENSE
USE_RC_SUBR= beanstalkd
USE_GMAKE= yes
@@ -39,4 +33,9 @@ do-install:
.endfor
.endif
+test: configure
+ @cd ${WRKSRC} && ${GMAKE} ${MAKE_ARGS} check
+
+regression-test: test
+
.include <bsd.port.mk>
diff --git a/net/beanstalkd/distinfo b/net/beanstalkd/distinfo
index 2c2b49576061..c26c6cb1fc0b 100644
--- a/net/beanstalkd/distinfo
+++ b/net/beanstalkd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (beanstalkd-1.6.tar.gz) = f39aa9de0692272b0249134cdf4f0e0c42da7755bad600403ac90e34bac235af
-SIZE (beanstalkd-1.6.tar.gz) = 59880
+SHA256 (beanstalkd-1.7.tar.gz) = 1d851677096d3cee4ee5710ee6cf1cebe8f2b5d9fa05792561ab55b534cbdaf8
+SIZE (beanstalkd-1.7.tar.gz) = 59829
diff --git a/net/beanstalkd/files/patch-integ-test.c b/net/beanstalkd/files/patch-integ-test.c
new file mode 100644
index 000000000000..e7e6d9abfe96
--- /dev/null
+++ b/net/beanstalkd/files/patch-integ-test.c
@@ -0,0 +1,12 @@
+--- ./integ-test.c.orig 2012-10-06 22:38:13.000000000 +1000
++++ ./integ-test.c 2012-10-06 22:38:29.000000000 +1000
+@@ -9,8 +9,8 @@
+ #include <sys/socket.h>
+ #include <sys/select.h>
+ #include <netdb.h>
+-#include <netinet/ip.h>
+ #include <netinet/in.h>
++#include <netinet/ip.h>
+ #include <arpa/inet.h>
+ #include <fcntl.h>
+ #include <sys/wait.h>