aboutsummaryrefslogtreecommitdiff
path: root/net/bmon
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-05 17:07:43 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-05 17:07:43 +0000
commitfb3520254ab73be0aad04c3a63b781750cf26b5b (patch)
tree268d74f9d8738f78b0c895672044611aa6343387 /net/bmon
parent4706739618b79681811e5b336a54032908638160 (diff)
downloadports-fb3520254ab73be0aad04c3a63b781750cf26b5b.tar.gz
ports-fb3520254ab73be0aad04c3a63b781750cf26b5b.zip
- Convert to OptionsNG
- Trim header Reviewed by: beat, bapt, kwm
Notes
Notes: svn path=/head/; revision=313460
Diffstat (limited to 'net/bmon')
-rw-r--r--net/bmon/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/net/bmon/Makefile b/net/bmon/Makefile
index 7aae791a3220..ae7fdf145d72 100644
--- a/net/bmon/Makefile
+++ b/net/bmon/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: bmon
-# Date created: 21 Feb 2003
-# Whom: Jon Nistor <nistor@snickers.org>
-#
+# Created by: Jon Nistor <nistor@snickers.org>
# $FreeBSD$
-#
PORTNAME= bmon
PORTVERSION= 2.1.0
@@ -14,8 +10,10 @@ MASTER_SITES= http://people.suug.ch/~tgr/bmon/files/
MAINTAINER= nistor@snickers.org
COMMENT= Portable bandwidth monitor and rate estimator
-OPTIONS= RRDTOOL "Enable RRD support" Off \
- DBI "Enable DBI support" On
+OPTIONS_DEFINE= DBI RRDTOOL
+OPTIONS_DEFAULT= DBI
+DBI_DESC= LibDBI output module for rsyslog
+RRDTOOL_DESC= Usage graphs support
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -27,15 +25,15 @@ MAKEFILE= GNUmakefile
MAN1= bmon.1
PLIST_FILES= sbin/bmon
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_RRDTOOL)
+.if ${PORT_OPTIONS:MRRDTOOL}
BUILD_DEPENDS= rrdtool:${PORTSDIR}/databases/rrdtool
.else
CONFIGURE_ARGS+=--disable-rrd
.endif
-.if defined(WITH_DBI)
+.if ${PORT_OPTIONS:MDBI}
LIB_DEPENDS= dbi.1:${PORTSDIR}/databases/libdbi
.else
CONFIGURE_ARGS+=--disable-dbi
@@ -45,4 +43,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/bmon ${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/man/bmon.1 ${PREFIX}/man/man1/bmon.1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>