aboutsummaryrefslogtreecommitdiff
path: root/net/bounce
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1998-12-30 04:31:42 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1998-12-30 04:31:42 +0000
commitd699d09cb626c9c3988f98d0130f7f5415e06cdb (patch)
tree7d48cfac70293c70ce5cd04a412540e56aeeede2 /net/bounce
parent99a4b96b356a5b35b7c1b5c68f6ad12de164d879 (diff)
downloadports-d699d09cb626c9c3988f98d0130f7f5415e06cdb.tar.gz
ports-d699d09cb626c9c3988f98d0130f7f5415e06cdb.zip
A little program to bounce tcp connections to another machine/port.
Notes
Notes: svn path=/head/; revision=15722
Diffstat (limited to 'net/bounce')
-rw-r--r--net/bounce/Makefile31
-rw-r--r--net/bounce/distinfo1
-rw-r--r--net/bounce/files/patch-0119
-rw-r--r--net/bounce/pkg-comment1
-rw-r--r--net/bounce/pkg-descr2
-rw-r--r--net/bounce/pkg-plist1
6 files changed, 55 insertions, 0 deletions
diff --git a/net/bounce/Makefile b/net/bounce/Makefile
new file mode 100644
index 000000000000..1cf3b71fdf91
--- /dev/null
+++ b/net/bounce/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection makefile for: bounce
+# Version required: 1.0
+# Date created: Mon Dec 23, 1998
+# Whom: David O'Brien (obrien@NUXI.com)
+#
+# $Id: Makefile,v 1.2 1997/01/25 18:08:40 obrien Exp $
+#
+
+DISTNAME= bounce
+PKGNAME= bounce-1.0
+CATEGORIES= net security
+MASTER_SITES= http://www.eleves.ens.fr:8080/home/espel/ \
+ http://www.freebsd.org/~obrien/Distfiles/
+DISTFILES= ${DISTNAME}.c
+
+MAINTAINER= obrien@FreeBSD.org
+
+NO_WRKSUBDIR= yes
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @${CP} ${DISTDIR}/${DISTFILES} ${WRKDIR}
+
+do-build:
+ (cd ${WRKSRC} && ${CC} ${CFLAGS} -o ${DISTNAME} ${DISTNAME}.c)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${DISTNAME} ${PREFIX}/libexec
+
+.include <bsd.port.mk>
diff --git a/net/bounce/distinfo b/net/bounce/distinfo
new file mode 100644
index 000000000000..6a9b025b983f
--- /dev/null
+++ b/net/bounce/distinfo
@@ -0,0 +1 @@
+MD5 (bounce.c) = 9ec7c53022f4c6a0559c7bbcc08080f1
diff --git a/net/bounce/files/patch-01 b/net/bounce/files/patch-01
new file mode 100644
index 000000000000..adf91f3d6676
--- /dev/null
+++ b/net/bounce/files/patch-01
@@ -0,0 +1,19 @@
+--- bounce.c.orig Sun Sep 20 15:44:41 1998
++++ bounce.c Sun Sep 20 15:46:04 1998
+@@ -20,13 +20,14 @@
+ #include <sys/ioctl.h>
+ #include <signal.h>
+ #include <sys/wait.h>
++#include <unistd.h>
++#include <stdlib.h>
++#include <string.h>
+
+ #define QLEN 5
+ #define DEFAULT_PORT 1523
+
+ char sbuf[16384], cbuf[16384];
+-extern int errno;
+-extern char *sys_errlist[];
+
+ void sigchld() {
+ signal(SIGCHLD, sigchld);
diff --git a/net/bounce/pkg-comment b/net/bounce/pkg-comment
new file mode 100644
index 000000000000..4d89c6d0d4cb
--- /dev/null
+++ b/net/bounce/pkg-comment
@@ -0,0 +1 @@
+bounce tcp connections to another machine/port.
diff --git a/net/bounce/pkg-descr b/net/bounce/pkg-descr
new file mode 100644
index 000000000000..55d2d57511ee
--- /dev/null
+++ b/net/bounce/pkg-descr
@@ -0,0 +1,2 @@
+A little program to bounce tcp connections to another machine/port.
+By default it listens on port 1523.
diff --git a/net/bounce/pkg-plist b/net/bounce/pkg-plist
new file mode 100644
index 000000000000..68d9ef75895b
--- /dev/null
+++ b/net/bounce/pkg-plist
@@ -0,0 +1 @@
+libexec/bounce