aboutsummaryrefslogtreecommitdiff
path: root/net/bwping
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2012-11-01 21:06:32 +0000
committerJason E. Hale <jhale@FreeBSD.org>2012-11-01 21:06:32 +0000
commit40790d5f8765be4c7b9a88bda3a00f8bcc3e6e8c (patch)
tree6ca9058a3f3445c9e10f36ae11cfc5f240f0293b /net/bwping
parent19d79808d3489da3cd7cc87b28e05cffa62a6b59 (diff)
downloadports-40790d5f8765be4c7b9a88bda3a00f8bcc3e6e8c.tar.gz
ports-40790d5f8765be4c7b9a88bda3a00f8bcc3e6e8c.zip
- Fix tinderbox build by adding IPV6 option to explicitly
enable or disable IPV6 support. Previous behavior was auto-detection which wasn't working right on tinderbox and would have caused problems anyways. Reported by: pointyhat Approved by: maintainer via private mail makc, avilla (mentors, implicit) Feature safe: yes
Notes
Notes: svn path=/head/; revision=306821
Diffstat (limited to 'net/bwping')
-rw-r--r--net/bwping/Makefile19
1 files changed, 16 insertions, 3 deletions
diff --git a/net/bwping/Makefile b/net/bwping/Makefile
index 6f9f22e6e591..c2d373efff73 100644
--- a/net/bwping/Makefile
+++ b/net/bwping/Makefile
@@ -12,11 +12,24 @@ LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
-MAN8= bwping.8 bwping6.8
+MAN8= bwping.8
-PLIST_FILES= sbin/bwping sbin/bwping6
+PLIST_FILES= sbin/bwping
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MIPV6}
+CONFIGURE_ENV+= ac_cv_ipv6=yes
+MAN8+= bwping6.8
+PLIST_FILES+= sbin/bwping6
+.else
+CONFIGURE_ENV+= ac_cv_ipv6=no
+.endif
post-install:
- @${CHMOD} 4555 ${PREFIX}/sbin/bwping ${PREFIX}/sbin/bwping6
+ @${CHMOD} 4555 ${PREFIX}/sbin/bwping
+.if ${PORT_OPTIONS:MIPV6}
+ @${CHMOD} 4555 ${PREFIX}/sbin/bwping6
+.endif
.include <bsd.port.mk>