aboutsummaryrefslogtreecommitdiff
path: root/net/cdonkey
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-08-28 21:51:57 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-08-28 21:51:57 +0000
commitaf8476c755b9821c76094d821a13b9da20c008df (patch)
tree3e3e423e63291e101f1f90ca90b394f1d6709ad8 /net/cdonkey
parent22710f5dcb00acbc4816f5cb24add1ebfc26c266 (diff)
downloadports-af8476c755b9821c76094d821a13b9da20c008df.tar.gz
ports-af8476c755b9821c76094d821a13b9da20c008df.zip
Notes
Diffstat (limited to 'net/cdonkey')
-rw-r--r--net/cdonkey/Makefile5
-rw-r--r--net/cdonkey/distinfo4
-rw-r--r--net/cdonkey/files/patch-Makefile.in18
-rw-r--r--net/cdonkey/files/patch-cSocket.cpp11
-rw-r--r--net/cdonkey/files/patch-cZone.cpp10
-rw-r--r--net/cdonkey/files/patch-cygwin.h27
-rw-r--r--net/cdonkey/files/patch-donkey.cpp10
7 files changed, 60 insertions, 25 deletions
diff --git a/net/cdonkey/Makefile b/net/cdonkey/Makefile
index 060e5df3c239..28bbf180a74c 100644
--- a/net/cdonkey/Makefile
+++ b/net/cdonkey/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= cdonkey
-PORTVERSION= 0.8.9
-PORTREVISION= 1
+PORTVERSION= 0.9.0
CATEGORIES= net
MASTER_SITES= http://suche.org/
DISTNAME= cDonkey-${PORTVERSION}
@@ -25,7 +24,7 @@ GNU_CONFIGURE= yes
USE_LIBTOOL_VER=13
CONFIGURE_ARGS= --with-berkeley-db="${LOCALBASE}/include/db3:${LOCALBASE}/lib"
USE_GMAKE= yes
-WRKSRC= ${WRKDIR}/cDonkey
+WRKSRC= ${WRKDIR}/cDonkey-${PORTVERSION}
.include <bsd.port.pre.mk>
diff --git a/net/cdonkey/distinfo b/net/cdonkey/distinfo
index 70bb6764f2a1..db42e73df111 100644
--- a/net/cdonkey/distinfo
+++ b/net/cdonkey/distinfo
@@ -1,2 +1,2 @@
-MD5 (cDonkey-0.8.9.tar.bz2) = a1a5eb43697b8f098f80709f017ab84c
-SIZE (cDonkey-0.8.9.tar.bz2) = 306617
+MD5 (cDonkey-0.9.0.tar.bz2) = 04c7b16e2aeb18a246e9892ba6fe7b7a
+SIZE (cDonkey-0.9.0.tar.bz2) = 334586
diff --git a/net/cdonkey/files/patch-Makefile.in b/net/cdonkey/files/patch-Makefile.in
index eebc484d61f5..cdb53e84cf47 100644
--- a/net/cdonkey/files/patch-Makefile.in
+++ b/net/cdonkey/files/patch-Makefile.in
@@ -1,11 +1,11 @@
---- Makefile.in.orig Wed Mar 26 16:52:39 2003
-+++ Makefile.in Wed Mar 26 16:52:49 2003
-@@ -50,7 +50,7 @@
- CPPFLAGS = @CPPFLAGS@
- CXX = @CXX@
- CXXDEPMODE = @CXXDEPMODE@
--CXXFLAGS = @CXXFLAGS@ -W -Wall -Wunused -Wformat -Wshadow -Wmultichar -Wpointer-arith -Wcast-qual -Wswitch -Werror @SVN_DB_INCLUDES@
-+CXXFLAGS = @CXXFLAGS@ @SVN_DB_INCLUDES@
+--- Makefile.in.orig Wed May 7 20:21:59 2003
++++ Makefile.in Thu Aug 26 18:39:49 2004
+@@ -55,7 +55,7 @@
+ # -fno-for-scope Make the proble with older compiler visible
+ # -pedantic < Zu viele warnings
+ # -Wold-style-cast < Zu viele warnings
+-CXXFLAGS = @CXXFLAGS@ -W -Wall -Wunused -Wformat -Wshadow -Wmultichar -Wpointer-arith -Wcast-qual -Wcast-align -Wswitch -ansi -fno-for-scope -fno-gnu-keywords -fno-rtti @SVN_DB_INCLUDES@
++CXXFLAGS = @CXXFLAGS@ -ansi -fno-for-scope -fno-gnu-keywords -fno-rtti @SVN_DB_INCLUDES@
CYGPATH_W = @CYGPATH_W@
- DEFS = @DEFS@
+ DEFS = @DEFS@ -DCDONKEY=1
DEPDIR = @DEPDIR@
diff --git a/net/cdonkey/files/patch-cSocket.cpp b/net/cdonkey/files/patch-cSocket.cpp
new file mode 100644
index 000000000000..0a2beb1fa6f1
--- /dev/null
+++ b/net/cdonkey/files/patch-cSocket.cpp
@@ -0,0 +1,11 @@
+--- cSocket.cpp.orig Wed May 7 20:21:33 2003
++++ cSocket.cpp Thu Aug 26 18:53:39 2004
+@@ -1180,7 +1180,7 @@
+ }}}
+ // try to set our local externally visible address
+ void cSocket::setLocalExternalIP(struct in_addr new_addr) {{{
+- static struct in_addr last_ip_seen = 0;
++ static struct in_addr last_ip_seen;
+ static int same_ip_count = 0;
+
+ if (new_addr.s_addr != last_ip_seen.s_addr) {
diff --git a/net/cdonkey/files/patch-cZone.cpp b/net/cdonkey/files/patch-cZone.cpp
new file mode 100644
index 000000000000..b7cef8ccdeca
--- /dev/null
+++ b/net/cdonkey/files/patch-cZone.cpp
@@ -0,0 +1,10 @@
+--- cZone.cpp.orig Wed May 7 20:21:34 2003
++++ cZone.cpp Thu Aug 26 18:54:31 2004
+@@ -88,7 +88,6 @@
+ }}}
+
+ cZone:: cZone() {{{
+- mtrace ();
+ uint8_t zero[HASH_LEN];
+ bzero(zero, HASH_LEN);
+ init(NULL, 0, zero);
diff --git a/net/cdonkey/files/patch-cygwin.h b/net/cdonkey/files/patch-cygwin.h
index 61701671d28f..ae15ae2a03e8 100644
--- a/net/cdonkey/files/patch-cygwin.h
+++ b/net/cdonkey/files/patch-cygwin.h
@@ -1,13 +1,18 @@
---- cygwin.h.orig Tue Apr 29 10:32:56 2003
-+++ cygwin.h Tue Apr 29 10:33:16 2003
-@@ -110,8 +110,8 @@
+--- cygwin.h.orig Sat Apr 5 20:06:44 2003
++++ cygwin.h Thu Aug 26 18:50:49 2004
+@@ -36,7 +36,6 @@
+ #include <zlib.h>
+ #include <ctype.h>
+ #include <signal.h>
+-#include <malloc.h>
+
+ #ifdef __cplusplus
+ #include <string> // for stl string
+@@ -166,7 +165,6 @@
+ #include <netinet/in.h>
+ #include <netinet/tcp.h>
+ #include <sys/poll.h>
+- #include <mcheck.h>
+ #define dir_delim '/'
#define HAVE_SIGHUP 1
#define HAVE_SIGINT 1
- #define HAVE_SIGPIPE 1
-- typedef unsigned long long uint64_t;
-- typedef long long int64_t;
-+// typedef unsigned long long uint64_t;
-+// typedef long long int64_t;
- #define closesocket close
- #define ioctlsocket ioctl
- #endif
diff --git a/net/cdonkey/files/patch-donkey.cpp b/net/cdonkey/files/patch-donkey.cpp
new file mode 100644
index 000000000000..29eb08379475
--- /dev/null
+++ b/net/cdonkey/files/patch-donkey.cpp
@@ -0,0 +1,10 @@
+--- donkey.cpp.orig Wed May 7 20:26:57 2003
++++ donkey.cpp Thu Aug 26 18:51:54 2004
+@@ -935,7 +935,6 @@
+
+ int main (int argc, char **argv) {{{
+ bzero (ZERO, 16);
+- mtrace (); // MALLOC_TRACE
+ struct stat dStatBuf;
+ int j = 0;
+