aboutsummaryrefslogtreecommitdiff
path: root/net/ceph14
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-10-25 13:33:40 +0000
committerSteve Wills <swills@FreeBSD.org>2019-10-25 13:33:40 +0000
commit7e926e8b0be52b849a3865f8efa28b17b02f51e0 (patch)
tree4b979348867ca6f944da1bdd3de83cba49f83567 /net/ceph14
parente75a50733ce0ef6bc2ce449da33f098ebfb12a17 (diff)
downloadports-7e926e8b0be52b849a3865f8efa28b17b02f51e0.tar.gz
ports-7e926e8b0be52b849a3865f8efa28b17b02f51e0.zip
net/ceph14: Fix build on 11.2
PR: 239415 Submitted by: Willem Jan Withagen <wjw@digiware.nl> (maintainer)
Notes
Notes: svn path=/head/; revision=515610
Diffstat (limited to 'net/ceph14')
-rw-r--r--net/ceph14/Makefile4
-rw-r--r--net/ceph14/files/patch-src_rgw_rgw__iam__policy.h21
2 files changed, 23 insertions, 2 deletions
diff --git a/net/ceph14/Makefile b/net/ceph14/Makefile
index 7165cdb7ff19..35b1cb2328bd 100644
--- a/net/ceph14/Makefile
+++ b/net/ceph14/Makefile
@@ -94,8 +94,8 @@ GROUPS= ceph
.include <bsd.port.options.mk>
-# 12.0 RELEASE has clang60 and will give versioning errors
-.if ${OSVERSION} >= 1200000 && ${OSVERSION} < 1200099
+# 11.2 and 12.0 RELEASE has clang60 and will give versioning errors
+.if (${OSVERSION} < 1102507) || (${OSVERSION} >= 1200000 && ${OSVERSION} < 1200099)
BUILD_DEPENDS+= ${LOCALBASE}/bin/clang80:devel/llvm80
CC= clang80
CXX= clang++80
diff --git a/net/ceph14/files/patch-src_rgw_rgw__iam__policy.h b/net/ceph14/files/patch-src_rgw_rgw__iam__policy.h
new file mode 100644
index 000000000000..65291d9a1cf6
--- /dev/null
+++ b/net/ceph14/files/patch-src_rgw_rgw__iam__policy.h
@@ -0,0 +1,21 @@
+diff --git a/src/rgw/rgw_iam_policy.h b/src/rgw/rgw_iam_policy.h
+index f6269dbef6ac..00048b4a7af0 100644
+--- src/rgw/rgw_iam_policy.h
++++ src/rgw/rgw_iam_policy.h
+@@ -9,7 +9,6 @@
+ #include <cstdint>
+ #include <iostream>
+ #include <string>
+-#include <bitset>
+
+ #include <boost/algorithm/string/predicate.hpp>
+ #include <boost/container/flat_map.hpp>
+@@ -125,7 +124,7 @@ static constexpr std::uint64_t stsAll = 79;
+ static constexpr std::uint64_t s3Count = s3BypassGovernanceRetention + 1;
+ static constexpr std::uint64_t allCount = stsAll + 1;
+
+-using Action_t = bitset<allCount>;
++using Action_t = std::bitset<allCount>;
+ using NotAction_t = Action_t;
+
+ static const Action_t None(0);