aboutsummaryrefslogtreecommitdiff
path: root/net/chrony
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2016-06-06 16:50:14 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2016-06-06 16:50:14 +0000
commit5093fd902a22e32259a3d0011082b0cd84c8278c (patch)
tree660e7d6fce25b4735f295c3d5badc82134d8381c /net/chrony
parentcca683280904efaeeda2a26e816ecc8b2038c8e6 (diff)
downloadports-5093fd902a22e32259a3d0011082b0cd84c8278c.tar.gz
ports-5093fd902a22e32259a3d0011082b0cd84c8278c.zip
- Remove ONLY_FOR_ARCHS restriction as chronyd(8) runs fine on PowerPC now
- Remove no-op OPTIONS_DEFAULT=IPV6, which was bogusly re-added in r416385 by pi@ after it was previously removed by amdmi3@ in r416447 - Sanitize `post-stage' target recipe (still needs more work to decouple extra docs and examples properly and add them to OPTIONS_DEFINE) Tested on: Mac mini G4 (powerpc)
Notes
Notes: svn path=/head/; revision=416474
Diffstat (limited to 'net/chrony')
-rw-r--r--net/chrony/Makefile16
1 files changed, 5 insertions, 11 deletions
diff --git a/net/chrony/Makefile b/net/chrony/Makefile
index 0cdadd37ed2d..de6caafa9752 100644
--- a/net/chrony/Makefile
+++ b/net/chrony/Makefile
@@ -11,10 +11,6 @@ COMMENT= System clock synchronization client and server
LICENSE= GPLv2
-# XXX: should theoretically work on others, but at least on PowerPC it dies
-# with ``Could not open any NTP socket'' message on startup :(
-ONLY_FOR_ARCHS= i386 amd64
-
USES= cpe gmake makeinfo readline
CPE_VENDOR= tuxfamily
HAS_CONFIGURE= yes
@@ -38,7 +34,6 @@ PORTEXAMPLES= chrony.conf.example1 chrony.conf.example2 \
# --without-tomcrypt Don't use libtomcrypt even if it is available
# --disable-pps Disable PPS API support
OPTIONS_DEFINE= IPV6
-OPTIONS_DEFAULT= IPV6
IPV6_CATEGORIES= ipv6
IPV6_CONFIGURE_OFF= --disable-ipv6
@@ -46,12 +41,11 @@ IPV6_CONFIGURE_OFF= --disable-ipv6
post-stage:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/chronyc
${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/chronyd
- cd ${WRKSRC}/${f} && \
- ${INSTALL_DATA} ${EXTRAPORTDOCS} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${EXTRAPORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- cd ${WRKSRC}/examples && \
- ${INSTALL_DATA} ${PORTEXAMPLES} ${STAGEDIR}${EXAMPLESDIR}
- cd ${WRKSRC}/examples && \
- ${INSTALL_DATA} chrony.conf.example3 ${STAGEDIR}${PREFIX}/etc/chrony.conf.sample
+ ${INSTALL_DATA} ${PORTEXAMPLES:S,^,${WRKSRC}/examples/,} \
+ ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/chrony.conf.example3 \
+ ${STAGEDIR}${PREFIX}/etc/chrony.conf.sample
.include <bsd.port.mk>