aboutsummaryrefslogtreecommitdiff
path: root/net/chrony
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2017-11-18 22:41:34 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2017-11-18 22:41:34 +0000
commitcc3c5867f454671795407a611fddda000c9bb9f9 (patch)
tree6d798c7558a6183fe85c4e31b369924030eb9cba /net/chrony
parente97cec485d1cafa8726ddbcdd7774ab8bd599ad6 (diff)
downloadports-cc3c5867f454671795407a611fddda000c9bb9f9.tar.gz
ports-cc3c5867f454671795407a611fddda000c9bb9f9.zip
Makes the NSS dependency explicit, and perform cleanup
Bump PORTREVISION Before this patch if nss is installed when crony is built, there's a silent lib dependency on nss, and if nss is subsequently uninstalled chrony breaks. NSS is now turned on by default adding support for a number of more modern hashing algorithms than md5. Cleanup: - --infodir is not a valid configure option (since 2.3 I think) - USES=localbase instead of LDFLAGS - add explicit --without-tomcrypt [1] - add support for passing chronyd_flags to chronyd in rc.d script - fix some hard-coded /usr/local in examples PR: 217691 Submitted by: John Hein <z7dr6ut7gs@snkmail.com> Approved by: Yonas Yanfa <yonas@fizk.net> (maintainer)
Notes
Notes: svn path=/head/; revision=454465
Diffstat (limited to 'net/chrony')
-rw-r--r--net/chrony/Makefile15
-rw-r--r--net/chrony/files/chronyd.in1
-rw-r--r--net/chrony/files/patch-examples_chrony.conf.example22
-rw-r--r--net/chrony/files/patch-examples_chrony.conf.example34
4 files changed, 12 insertions, 10 deletions
diff --git a/net/chrony/Makefile b/net/chrony/Makefile
index b890e339ce31..58f7543ac6a1 100644
--- a/net/chrony/Makefile
+++ b/net/chrony/Makefile
@@ -3,7 +3,7 @@
PORTNAME= chrony
PORTVERSION= 3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://download.tuxfamily.org/chrony/
@@ -21,11 +21,9 @@ CPE_VENDOR= tuxfamily
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
--chronyvardir=/var/db/${PORTNAME} \
- --infodir=${PREFIX}/info \
--sysconfdir=${PREFIX}/etc --mandir=${MANPREFIX}/man \
--datarootdir=${DATADIR} --docdir=${DOCSDIR} \
- --with-user=chronyd
-LDFLAGS+= -L${LOCALBASE}/lib
+ --with-user=chronyd --without-tomcrypt
USE_RC_SUBR= chronyd
ALL_TARGET= all
@@ -35,14 +33,17 @@ PORTEXAMPLES= chrony.conf.example1 chrony.conf.example2 \
chrony.conf.example3 chrony.keys.example
# XXX: there are also other potentially useful options worth looking into:
-# --without-nss Don't use NSS even if it is available
-# --without-tomcrypt Don't use libtomcrypt even if it is available
# --disable-pps Disable PPS API support
-OPTIONS_DEFINE= IPV6
+OPTIONS_DEFINE= IPV6 NSS
+OPTIONS_DEFAULT= NSS
IPV6_CATEGORIES= ipv6
IPV6_CONFIGURE_OFF= --disable-ipv6
+NSS_DESC= Add support for more hashing algorithms
+NSS_CONFIGURE_OFF= --without-nss
+NSS_USES= pkgconfig
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/chronyc
${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/chronyd
diff --git a/net/chrony/files/chronyd.in b/net/chrony/files/chronyd.in
index 21e18431747d..55f1053c5f61 100644
--- a/net/chrony/files/chronyd.in
+++ b/net/chrony/files/chronyd.in
@@ -11,6 +11,7 @@
name=chronyd
rcvar=chronyd_enable
command=%%PREFIX%%/sbin/${name}
+rc_flags="${chronyd_flags}"
load_rc_config ${name}
diff --git a/net/chrony/files/patch-examples_chrony.conf.example2 b/net/chrony/files/patch-examples_chrony.conf.example2
index bbb5bb6dbc14..c324fd2ae7d7 100644
--- a/net/chrony/files/patch-examples_chrony.conf.example2
+++ b/net/chrony/files/patch-examples_chrony.conf.example2
@@ -17,7 +17,7 @@
# Specify file containing keys for NTP authentication.
-#keyfile /etc/chrony.keys
-+#keyfile /usr/local/etc/chrony.keys
++#keyfile %%PREFIX%%/etc/chrony.keys
# Specify directory for log files.
logdir /var/log/chrony
diff --git a/net/chrony/files/patch-examples_chrony.conf.example3 b/net/chrony/files/patch-examples_chrony.conf.example3
index 707c03dc3da0..6172095ab0d8 100644
--- a/net/chrony/files/patch-examples_chrony.conf.example3
+++ b/net/chrony/files/patch-examples_chrony.conf.example3
@@ -5,7 +5,7 @@
#
# This is an example chrony configuration file. You should copy it to
-# /etc/chrony.conf after uncommenting and editing the options that you
-+# /usr/local/etc/chrony.conf after uncommenting and editing the options that you
++# %%PREFIX%%/etc/chrony.conf after uncommenting and editing the options that you
# want to enable. The more obscure options are not included. Refer
# to the documentation for these.
#
@@ -31,7 +31,7 @@
# to uncomment the following line and edit the file to set up the keys.
-! keyfile /etc/chrony.keys
-+! keyfile /usr/local/etc/chrony.keys
++! keyfile %%PREFIX%%/etc/chrony.keys
# chronyd can save the measurement history for the servers to files when
# it it exits. This is useful in 2 situations: