aboutsummaryrefslogtreecommitdiff
path: root/net/cloud-init
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2018-08-02 12:05:46 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2018-08-02 12:05:46 +0000
commit16ca8f48fd9dd934e75bafd45093ba2c46044119 (patch)
treeb9a99359c3c6f02e15e1ddea8f11904094403b5d /net/cloud-init
parent3f09c8cde1b2b74ec500335fb6aa87436eec722a (diff)
downloadports-16ca8f48fd9dd934e75bafd45093ba2c46044119.tar.gz
ports-16ca8f48fd9dd934e75bafd45093ba2c46044119.zip
- Bump PORTREVISION
- Fix rc script errors - Fix config file location
Notes
Notes: svn path=/head/; revision=476232
Diffstat (limited to 'net/cloud-init')
-rw-r--r--net/cloud-init/Makefile5
-rw-r--r--net/cloud-init/files/patch-sysvinit_freebsd_cloudconfig10
-rw-r--r--net/cloud-init/files/patch-sysvinit_freebsd_cloudfinal10
-rw-r--r--net/cloud-init/files/patch-sysvinit_freebsd_cloudinit10
-rw-r--r--net/cloud-init/files/patch-sysvinit_freebsd_cloudinitlocal10
-rw-r--r--net/cloud-init/pkg-plist4
6 files changed, 43 insertions, 6 deletions
diff --git a/net/cloud-init/Makefile b/net/cloud-init/Makefile
index 87c152963d78..2f795ff2b940 100644
--- a/net/cloud-init/Makefile
+++ b/net/cloud-init/Makefile
@@ -2,6 +2,7 @@
PORTNAME= cloud-init
PORTVERSION= 18.3
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= http://launchpad.net/${PORTNAME}/trunk/${PORTVERSION}/+download/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -40,7 +41,9 @@ ONLY_FOR_ARCHS= amd64 i386
ONLY_FOR_ARCHS_REASON= currently depends on dmidecode which is x86-only
post-patch:
- @${RM} ${WRKSRC}/sysvinit/freebsd/cloudinit.orig
+ ${REINPLACE_CMD} -e 's|"etc"|"${STAGEDIR}${PREFIX}/etc"|g' ${WRKSRC}/setup.py
+ ${REINPLACE_CMD} -e 's|/etc/|${PREFIX}/etc/|g' ${WRKSRC}/cloudinit/settings.py
+ @${RM} ${WRKSRC}/sysvinit/freebsd/*.orig
post-build:
@cd ${WRKSRC} && ${MV} sysvinit/freebsd/cloudconfig config/cloud.cfg
diff --git a/net/cloud-init/files/patch-sysvinit_freebsd_cloudconfig b/net/cloud-init/files/patch-sysvinit_freebsd_cloudconfig
new file mode 100644
index 000000000000..7c06457e1040
--- /dev/null
+++ b/net/cloud-init/files/patch-sysvinit_freebsd_cloudconfig
@@ -0,0 +1,10 @@
+--- sysvinit/freebsd/cloudconfig.orig 2018-08-01 15:31:13 UTC
++++ sysvinit/freebsd/cloudconfig
+@@ -22,4 +22,7 @@ cloudconfig_start()
+ }
+
+ load_rc_config $name
++
++: ${cloudconfig_enable="NO"}
++
+ run_rc_command "$1"
diff --git a/net/cloud-init/files/patch-sysvinit_freebsd_cloudfinal b/net/cloud-init/files/patch-sysvinit_freebsd_cloudfinal
new file mode 100644
index 000000000000..4f6a70840666
--- /dev/null
+++ b/net/cloud-init/files/patch-sysvinit_freebsd_cloudfinal
@@ -0,0 +1,10 @@
+--- sysvinit/freebsd/cloudfinal.orig 2018-08-01 15:31:17 UTC
++++ sysvinit/freebsd/cloudfinal
+@@ -22,4 +22,7 @@ cloudfinal_start()
+ }
+
+ load_rc_config $name
++
++: ${cloudfinal_enable="NO"}
++
+ run_rc_command "$1"
diff --git a/net/cloud-init/files/patch-sysvinit_freebsd_cloudinit b/net/cloud-init/files/patch-sysvinit_freebsd_cloudinit
index 4e7c85a26735..83f3cd3056f3 100644
--- a/net/cloud-init/files/patch-sysvinit_freebsd_cloudinit
+++ b/net/cloud-init/files/patch-sysvinit_freebsd_cloudinit
@@ -1,4 +1,4 @@
---- sysvinit/freebsd/cloudinit.orig 2018-01-01 11:58:33 UTC
+--- sysvinit/freebsd/cloudinit.orig 2018-08-01 15:31:22 UTC
+++ sysvinit/freebsd/cloudinit
@@ -1,7 +1,7 @@
#!/bin/sh
@@ -9,3 +9,11 @@
# BEFORE: cloudconfig cloudfinal
. /etc/rc.subr
+@@ -22,4 +22,7 @@ cloudinit_start()
+ }
+
+ load_rc_config $name
++
++: ${cloudinit_enable="NO"}
++
+ run_rc_command "$1"
diff --git a/net/cloud-init/files/patch-sysvinit_freebsd_cloudinitlocal b/net/cloud-init/files/patch-sysvinit_freebsd_cloudinitlocal
new file mode 100644
index 000000000000..dcfcf9a0dc5a
--- /dev/null
+++ b/net/cloud-init/files/patch-sysvinit_freebsd_cloudinitlocal
@@ -0,0 +1,10 @@
+--- sysvinit/freebsd/cloudinitlocal.orig 2018-08-01 15:31:29 UTC
++++ sysvinit/freebsd/cloudinitlocal
+@@ -22,4 +22,7 @@ cloudlocal_start()
+ }
+
+ load_rc_config $name
++
++: ${cloudinitlocal_enable="NO"}
++
+ run_rc_command "$1"
diff --git a/net/cloud-init/pkg-plist b/net/cloud-init/pkg-plist
deleted file mode 100644
index 1407c3453c3b..000000000000
--- a/net/cloud-init/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-@comment @dir /etc/bash_completion.d
-@comment @dir /%%ETCDIR%%/cloud.cfg.d
-@comment @dir /%%ETCDIR%%/templates
-@comment @dir /%%ETCDIR%%