aboutsummaryrefslogtreecommitdiff
path: root/net/clusterit
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2011-09-29 14:25:50 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2011-09-29 14:25:50 +0000
commita7923f794e6aacbbf007567b3d4a5dc69c4e052c (patch)
tree6609db2b2e3fa49945ce0c18914b0855a6a4bd04 /net/clusterit
parent6cc6751fd4450ea9904a5784ded7f46b8c361d2e (diff)
downloadports-a7923f794e6aacbbf007567b3d4a5dc69c4e052c.tar.gz
ports-a7923f794e6aacbbf007567b3d4a5dc69c4e052c.zip
Unbreak on 9+ (utmpx).
Seems utmp.h include is not used. PR: 160934 Reported by: "Hartmann, O." <ohartman@zedat.fu-berlin.de>
Notes
Notes: svn path=/head/; revision=282618
Diffstat (limited to 'net/clusterit')
-rw-r--r--net/clusterit/Makefile4
-rw-r--r--net/clusterit/files/patch-rvt-command.c10
-rw-r--r--net/clusterit/files/patch-rvt-ttyinit.c10
3 files changed, 20 insertions, 4 deletions
diff --git a/net/clusterit/Makefile b/net/clusterit/Makefile
index 3c22b9b4bfea..1e1182004884 100644
--- a/net/clusterit/Makefile
+++ b/net/clusterit/Makefile
@@ -20,10 +20,6 @@ MAN1= barrier.1 barrierd.1 clustersed.1 dsh.1 dshbak.1 \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} > 900007
-BROKEN= fails to build with new utmpx
-.endif
-
.if defined (WITHOUT_X11)
PLIST_SUB+= X11='@comment '
.else
diff --git a/net/clusterit/files/patch-rvt-command.c b/net/clusterit/files/patch-rvt-command.c
new file mode 100644
index 000000000000..e5cb861fd0b1
--- /dev/null
+++ b/net/clusterit/files/patch-rvt-command.c
@@ -0,0 +1,10 @@
+--- rvt/command.c.orig 2008-02-27 22:29:48.000000000 +0300
++++ rvt/command.c 2011-09-29 18:18:07.000000000 +0400
+@@ -41,7 +41,6 @@ char xvt_command_c_sccsid[] = "@(#)comma
+ #include <unistd.h>
+ #include <signal.h>
+ #include <fcntl.h>
+-#include <utmp.h>
+ #include <errno.h>
+ #include <string.h>
+ #include "rvt.h"
diff --git a/net/clusterit/files/patch-rvt-ttyinit.c b/net/clusterit/files/patch-rvt-ttyinit.c
new file mode 100644
index 000000000000..dc14b5113e32
--- /dev/null
+++ b/net/clusterit/files/patch-rvt-ttyinit.c
@@ -0,0 +1,10 @@
+--- rvt/ttyinit.c.orig 2007-01-24 22:02:10.000000000 +0300
++++ rvt/ttyinit.c 2011-09-29 18:18:19.000000000 +0400
+@@ -41,7 +41,6 @@ char xvt_ttyinit_c_sccsid[] = "@(#)ttyin
+ #include <unistd.h>
+ #include <signal.h>
+ #include <fcntl.h>
+-#include <utmp.h>
+ #include <grp.h>
+ #include <pwd.h>
+ #include <errno.h>