aboutsummaryrefslogtreecommitdiff
path: root/net/corosync2
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2018-05-24 18:24:50 +0000
committerFlorian Smeets <flo@FreeBSD.org>2018-05-24 18:24:50 +0000
commitce5d6d0b91fa05a02202ed6e88acbea8bcdc1ec0 (patch)
treea793dfc3544527fe94e724352edcf8fe22cf2bdc /net/corosync2
parent3d5f40d19137feed15f2581d00b19a3fdda65da7 (diff)
downloadports-ce5d6d0b91fa05a02202ed6e88acbea8bcdc1ec0.tar.gz
ports-ce5d6d0b91fa05a02202ed6e88acbea8bcdc1ec0.zip
- add net/corosync3 (2.99.2)
- add net/pacemaker2 (2.0.0-rc4) - net/corosync -> net/corosync2 (update to 2.4.4) - net/pacemaker -> net/pacemaker1 (update to 1.1.18) - add USES=corosync to deal with multiple versions PR: 228164, 228165 Submitted by: David Shane Holden <dpejesh@yahoo.com>
Notes
Notes: svn path=/head/; revision=470799
Diffstat (limited to 'net/corosync2')
-rw-r--r--net/corosync2/Makefile11
-rw-r--r--net/corosync2/Makefile.common41
-rw-r--r--net/corosync2/distinfo3
-rw-r--r--net/corosync2/files/corosync-notifyd.in20
-rw-r--r--net/corosync2/files/corosync.in27
-rw-r--r--net/corosync2/pkg-descr16
-rw-r--r--net/corosync2/pkg-message9
-rw-r--r--net/corosync2/pkg-plist253
8 files changed, 380 insertions, 0 deletions
diff --git a/net/corosync2/Makefile b/net/corosync2/Makefile
new file mode 100644
index 000000000000..aa10cc97b6b9
--- /dev/null
+++ b/net/corosync2/Makefile
@@ -0,0 +1,11 @@
+# Created by: David Shane Holden <dpejesh@yahoo.com>
+# $FreeBSD$
+
+PORTVERSION= 2.4.4
+PKGNAMESUFFIX= 2
+
+.include "${.CURDIR}/Makefile.common"
+
+CONFLICTS= corosync3-[0-9]*
+
+.include <bsd.port.mk>
diff --git a/net/corosync2/Makefile.common b/net/corosync2/Makefile.common
new file mode 100644
index 000000000000..ddc71a2b0e78
--- /dev/null
+++ b/net/corosync2/Makefile.common
@@ -0,0 +1,41 @@
+# Created by: David Shane Holden <dpejesh@yahoo.com>
+# $FreeBSD$
+
+PORTNAME= corosync
+CATEGORIES= net
+MASTER_SITES= http://build.clusterlabs.org/corosync/releases/
+
+MAINTAINER= dpejesh@yahoo.com
+COMMENT= Corosync Cluster Engine
+
+LICENSE= BSD3CLAUSE
+
+LIB_DEPENDS= libnspr4.so:devel/nspr \
+ libnss3.so:security/nss \
+ libqb.so.0:devel/libqb
+
+TEST_DEPENDS= augparse:textproc/augeas
+
+USES= gmake groff libtool pathfix pkgconfig
+USE_BINUTILS= yes
+USE_LDCONFIG= yes
+USE_RC_SUBR= ${PORTNAME} ${PORTNAME}-notifyd
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-secure-build
+LDFLAGS+= -B${LOCALBASE}/bin
+INSTALL_TARGET= install-strip
+TEST_TARGET= check
+
+OPTIONS_DEFINE= DBUS SNMP
+OPTIONS_SUB= yes
+
+DBUS_LIB_DEPENDS+= libdbus-1.so:devel/dbus
+DBUS_CONFIGURE_ENABLE= dbus
+
+SNMP_LIB_DEPENDS+= libnetsnmp.so:net-mgmt/net-snmp
+SNMP_CONFIGURE_ENABLE= snmp
+
+post-install:
+ ${RM} ${STAGEDIR}${PREFIX}/etc/init.d/corosync
+ ${RM} ${STAGEDIR}${PREFIX}/etc/init.d/corosync-notifyd
+ ${RMDIR} ${STAGEDIR}${PREFIX}/etc/init.d
diff --git a/net/corosync2/distinfo b/net/corosync2/distinfo
new file mode 100644
index 000000000000..1c322b4ee1ce
--- /dev/null
+++ b/net/corosync2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1523569567
+SHA256 (corosync-2.4.4.tar.gz) = 9bd4707bb271df16f8d543ec782eb4c35ec0330b7be696b797da4bd8f058a25d
+SIZE (corosync-2.4.4.tar.gz) = 1204051
diff --git a/net/corosync2/files/corosync-notifyd.in b/net/corosync2/files/corosync-notifyd.in
new file mode 100644
index 000000000000..22b03ca33b11
--- /dev/null
+++ b/net/corosync2/files/corosync-notifyd.in
@@ -0,0 +1,20 @@
+#!/bin/sh
+# $FreeBSD$
+
+# PROVIDE: corosync-notifyd
+# REQUIRE: LOGIN FILESYSTEMS
+# KEYWORD: shutdown
+
+. /etc/rc.subr
+
+name="corosync_notifyd"
+rcvar="corosync_notifyd_enable"
+
+load_rc_config $name
+
+: ${corosync_notifyd_enable:=NO}
+
+command="%%PREFIX%%/sbin/corosync-notifyd"
+command_args="-l"
+
+run_rc_command "$1"
diff --git a/net/corosync2/files/corosync.in b/net/corosync2/files/corosync.in
new file mode 100644
index 000000000000..58e82ffa08fe
--- /dev/null
+++ b/net/corosync2/files/corosync.in
@@ -0,0 +1,27 @@
+#!/bin/sh
+# $FreeBSD$
+
+# PROVIDE: corosync
+# REQUIRE: LOGIN FILESYSTEMS
+# KEYWORD: shutdown
+
+. /etc/rc.subr
+
+name="corosync"
+rcvar="corosync_enable"
+start_precmd="corosync_precmd"
+
+corosync_precmd()
+{
+ if [ `${SYSCTL_N} kern.ipc.maxsockbuf` -lt 18874368 ]; then
+ err 3 "sysctl:kern.ipc.maxsockbuf must be at least 18874368"
+ fi
+}
+
+load_rc_config $name
+
+: ${corosync_enable:=NO}
+
+command="%%PREFIX%%/sbin/corosync"
+
+run_rc_command "$1"
diff --git a/net/corosync2/pkg-descr b/net/corosync2/pkg-descr
new file mode 100644
index 000000000000..fb42632850f8
--- /dev/null
+++ b/net/corosync2/pkg-descr
@@ -0,0 +1,16 @@
+The Corosync Cluster Engine is a Group Communication System with additional
+features for implementing high availability within applications. The project
+provides four C Application Programming Interface features:
+
+* A closed process group communication model with virtual synchrony guarantees
+ for creating replicated state machines.
+* A simple availability manager that restarts the application process when it
+ has failed.
+* A configuration and statistics in-memory database that provide the ability
+ to set, retrieve, and receive change notifications of information.
+* A quorum system that notifies applications when quorum is achieved or lost.
+
+Corosync is used as a High Availability framework by projects such as Apache
+Qpid and Pacemaker.
+
+WWW: https://corosync.github.io/corosync/
diff --git a/net/corosync2/pkg-message b/net/corosync2/pkg-message
new file mode 100644
index 000000000000..4f22785ea3d9
--- /dev/null
+++ b/net/corosync2/pkg-message
@@ -0,0 +1,9 @@
+For correct operation, maximum socket buffer size must be tuned
+by performing the following command as root :
+
+# sysctl kern.ipc.maxsockbuf=18874368
+
+To preserve this setting across reboots, append the following
+to /etc/sysctl.conf :
+
+kern.ipc.maxsockbuf=18874368
diff --git a/net/corosync2/pkg-plist b/net/corosync2/pkg-plist
new file mode 100644
index 000000000000..a05b79657f5f
--- /dev/null
+++ b/net/corosync2/pkg-plist
@@ -0,0 +1,253 @@
+bin/corosync-blackbox
+%%ETCDIR%%/corosync.conf.example
+%%ETCDIR%%/corosync.conf.example.udpu
+etc/logrotate.d/corosync
+include/corosync/cfg.h
+include/corosync/cmap.h
+include/corosync/corodefs.h
+include/corosync/corotypes.h
+include/corosync/cpg.h
+include/corosync/hdb.h
+include/corosync/quorum.h
+include/corosync/sam.h
+include/corosync/totem/totem.h
+include/corosync/totem/totemip.h
+include/corosync/totem/totempg.h
+include/corosync/votequorum.h
+lib/libcfg.a
+lib/libcfg.so
+lib/libcfg.so.6
+lib/libcfg.so.6.0.0
+lib/libcmap.a
+lib/libcmap.so
+lib/libcmap.so.4
+lib/libcmap.so.4.1.0
+lib/libcorosync_common.a
+lib/libcorosync_common.so
+lib/libcorosync_common.so.4
+lib/libcorosync_common.so.4.0.0
+lib/libcpg.a
+lib/libcpg.so
+lib/libcpg.so.4
+lib/libcpg.so.4.1.0
+lib/libquorum.a
+lib/libquorum.so
+lib/libquorum.so.5
+lib/libquorum.so.5.0.0
+lib/libsam.a
+lib/libsam.so
+lib/libsam.so.4
+lib/libsam.so.4.4.0
+lib/libtotem_pg.a
+lib/libtotem_pg.so
+lib/libtotem_pg.so.5
+lib/libtotem_pg.so.5.0.0
+lib/libvotequorum.a
+lib/libvotequorum.so
+lib/libvotequorum.so.8
+lib/libvotequorum.so.8.0.0
+libdata/pkgconfig/corosync.pc
+libdata/pkgconfig/libcfg.pc
+libdata/pkgconfig/libcmap.pc
+libdata/pkgconfig/libcorosync_common.pc
+libdata/pkgconfig/libcpg.pc
+libdata/pkgconfig/libquorum.pc
+libdata/pkgconfig/libsam.pc
+libdata/pkgconfig/libtotem_pg.pc
+libdata/pkgconfig/libvotequorum.pc
+man/man3/cmap_context_get.3.gz
+man/man3/cmap_context_set.3.gz
+man/man3/cmap_dec.3.gz
+man/man3/cmap_delete.3.gz
+man/man3/cmap_dispatch.3.gz
+man/man3/cmap_fd_get.3.gz
+man/man3/cmap_finalize.3.gz
+man/man3/cmap_get.3.gz
+man/man3/cmap_inc.3.gz
+man/man3/cmap_initialize.3.gz
+man/man3/cmap_iter_finalize.3.gz
+man/man3/cmap_iter_init.3.gz
+man/man3/cmap_iter_next.3.gz
+man/man3/cmap_set.3.gz
+man/man3/cmap_track_add.3.gz
+man/man3/cmap_track_delete.3.gz
+man/man3/cpg_context_get.3.gz
+man/man3/cpg_context_set.3.gz
+man/man3/cpg_dispatch.3.gz
+man/man3/cpg_fd_get.3.gz
+man/man3/cpg_finalize.3.gz
+man/man3/cpg_initialize.3.gz
+man/man3/cpg_iteration_finalize.3.gz
+man/man3/cpg_iteration_initialize.3.gz
+man/man3/cpg_iteration_next.3.gz
+man/man3/cpg_join.3.gz
+man/man3/cpg_leave.3.gz
+man/man3/cpg_local_get.3.gz
+man/man3/cpg_mcast_joined.3.gz
+man/man3/cpg_membership_get.3.gz
+man/man3/cpg_model_initialize.3.gz
+man/man3/cpg_zcb_alloc.3.gz
+man/man3/cpg_zcb_free.3.gz
+man/man3/cpg_zcb_mcast_joined.3.gz
+man/man3/quorum_context_get.3.gz
+man/man3/quorum_context_set.3.gz
+man/man3/quorum_dispatch.3.gz
+man/man3/quorum_fd_get.3.gz
+man/man3/quorum_finalize.3.gz
+man/man3/quorum_getquorate.3.gz
+man/man3/quorum_initialize.3.gz
+man/man3/quorum_trackstart.3.gz
+man/man3/quorum_trackstop.3.gz
+man/man3/sam_data_getsize.3.gz
+man/man3/sam_data_restore.3.gz
+man/man3/sam_data_store.3.gz
+man/man3/sam_finalize.3.gz
+man/man3/sam_hc_callback_register.3.gz
+man/man3/sam_hc_send.3.gz
+man/man3/sam_initialize.3.gz
+man/man3/sam_mark_failed.3.gz
+man/man3/sam_register.3.gz
+man/man3/sam_start.3.gz
+man/man3/sam_stop.3.gz
+man/man3/sam_warn_signal_set.3.gz
+man/man3/votequorum_context_get.3.gz
+man/man3/votequorum_context_set.3.gz
+man/man3/votequorum_dispatch.3.gz
+man/man3/votequorum_fd_get.3.gz
+man/man3/votequorum_finalize.3.gz
+man/man3/votequorum_getinfo.3.gz
+man/man3/votequorum_initialize.3.gz
+man/man3/votequorum_qdevice_master_wins.3.gz
+man/man3/votequorum_qdevice_poll.3.gz
+man/man3/votequorum_qdevice_register.3.gz
+man/man3/votequorum_qdevice_unregister.3.gz
+man/man3/votequorum_qdevice_update.3.gz
+man/man3/votequorum_setexpected.3.gz
+man/man3/votequorum_setvotes.3.gz
+man/man3/votequorum_trackstart.3.gz
+man/man3/votequorum_trackstop.3.gz
+man/man5/corosync.conf.5.gz
+man/man5/votequorum.5.gz
+man/man8/cmap_keys.8.gz
+man/man8/cmap_overview.8.gz
+man/man8/corosync-blackbox.8.gz
+man/man8/corosync-cfgtool.8.gz
+man/man8/corosync-cmapctl.8.gz
+man/man8/corosync-cpgtool.8.gz
+man/man8/corosync-keygen.8.gz
+man/man8/corosync-notifyd.8.gz
+man/man8/corosync-quorumtool.8.gz
+man/man8/corosync.8.gz
+man/man8/corosync_overview.8.gz
+man/man8/cpg_overview.8.gz
+man/man8/quorum_overview.8.gz
+man/man8/sam_overview.8.gz
+man/man8/votequorum_overview.8.gz
+sbin/corosync
+sbin/corosync-cfgtool
+sbin/corosync-cmapctl
+sbin/corosync-cpgtool
+sbin/corosync-keygen
+sbin/corosync-notifyd
+sbin/corosync-quorumtool
+%%SNMP%%share/snmp/mibs/COROSYNC-MIB.txt
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/README.recovery
+%%PORTDOCS%%%%DOCSDIR%%/SECURITY
+%%PORTDOCS%%%%DOCSDIR%%/html/cmap_context_get.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cmap_context_set.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cmap_dec.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cmap_delete.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cmap_dispatch.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cmap_fd_get.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cmap_finalize.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cmap_get.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cmap_inc.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cmap_initialize.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cmap_iter_finalize.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cmap_iter_init.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cmap_iter_next.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cmap_keys.8.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cmap_overview.8.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cmap_set.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cmap_track_add.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cmap_track_delete.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/corosync-blackbox.8.html
+%%PORTDOCS%%%%DOCSDIR%%/html/corosync-cfgtool.8.html
+%%PORTDOCS%%%%DOCSDIR%%/html/corosync-cmapctl.8.html
+%%PORTDOCS%%%%DOCSDIR%%/html/corosync-cpgtool.8.html
+%%PORTDOCS%%%%DOCSDIR%%/html/corosync-keygen.8.html
+%%PORTDOCS%%%%DOCSDIR%%/html/corosync-notifyd.8.html
+%%PORTDOCS%%%%DOCSDIR%%/html/corosync-quorumtool.8.html
+%%PORTDOCS%%%%DOCSDIR%%/html/corosync.8.html
+%%PORTDOCS%%%%DOCSDIR%%/html/corosync.conf.5.html
+%%PORTDOCS%%%%DOCSDIR%%/html/corosync_overview.8.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cpg_context_get.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cpg_context_set.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cpg_dispatch.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cpg_fd_get.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cpg_finalize.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cpg_initialize.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cpg_iteration_finalize.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cpg_iteration_initialize.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cpg_iteration_next.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cpg_join.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cpg_leave.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cpg_local_get.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cpg_mcast_joined.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cpg_membership_get.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cpg_model_initialize.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cpg_overview.8.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cpg_zcb_alloc.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cpg_zcb_free.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cpg_zcb_mcast_joined.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/quorum_context_get.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/quorum_context_set.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/quorum_dispatch.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/quorum_fd_get.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/quorum_finalize.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/quorum_getquorate.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/quorum_initialize.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/quorum_overview.8.html
+%%PORTDOCS%%%%DOCSDIR%%/html/quorum_trackstart.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/quorum_trackstop.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/sam_data_getsize.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/sam_data_restore.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/sam_data_store.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/sam_finalize.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/sam_hc_callback_register.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/sam_hc_send.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/sam_initialize.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/sam_mark_failed.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/sam_overview.8.html
+%%PORTDOCS%%%%DOCSDIR%%/html/sam_register.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/sam_start.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/sam_stop.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/sam_warn_signal_set.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/votequorum.5.html
+%%PORTDOCS%%%%DOCSDIR%%/html/votequorum_context_get.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/votequorum_context_set.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/votequorum_dispatch.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/votequorum_fd_get.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/votequorum_finalize.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/votequorum_getinfo.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/votequorum_initialize.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/votequorum_overview.8.html
+%%PORTDOCS%%%%DOCSDIR%%/html/votequorum_qdevice_master_wins.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/votequorum_qdevice_poll.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/votequorum_qdevice_register.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/votequorum_qdevice_unregister.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/votequorum_qdevice_update.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/votequorum_setexpected.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/votequorum_setvotes.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/votequorum_trackstart.3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/votequorum_trackstop.3.html
+%%DBUS%%etc/dbus-1/system.d/corosync-signals.conf
+@dir %%ETCDIR%%/service.d
+@dir %%ETCDIR%%/uidgid.d
+@dir /var/lib/corosync
+@dir /var/lib
+@dir /var/log/cluster