aboutsummaryrefslogtreecommitdiff
path: root/net/crescendo
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2005-06-02 20:28:41 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2005-06-02 20:28:41 +0000
commit392aa128b51ff968e6db11f38b7ba6f6d0dedd33 (patch)
tree539bd22aa3ba684b6facf9ee9560d8d0cdb7c812 /net/crescendo
parenta210c68356ff0dded5c7b63ac4b2d501473a84e2 (diff)
downloadports-392aa128b51ff968e6db11f38b7ba6f6d0dedd33.tar.gz
ports-392aa128b51ff968e6db11f38b7ba6f6d0dedd33.zip
Notes
Diffstat (limited to 'net/crescendo')
-rw-r--r--net/crescendo/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/net/crescendo/Makefile b/net/crescendo/Makefile
index 17f35b734e45..a8be9b74b797 100644
--- a/net/crescendo/Makefile
+++ b/net/crescendo/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= tf:${PORTSDIR}/net/tinyfugue
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_REINPLACE= yes
+USE_LIBTOOL_VER=15
CONFIGURE_ARGS+= --enable-compile-warnings=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
@@ -31,6 +32,10 @@ MODIFY= Makefile.in data/Makefile.in
USE_X_PREFIX= yes
USE_GNOME= gnomelibs
+post-patch:
+ @${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
+ ${WRKSRC}/configure
+
pre-patch:
.for i in ${MODIFY}
@${MV} ${WRKSRC}/${i} ${WRKSRC}/${i}.sed