aboutsummaryrefslogtreecommitdiff
path: root/net/dante
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2005-02-20 11:16:03 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2005-02-20 11:16:03 +0000
commitd459a9c59c3ac652890ac68092b47ff11c2dd956 (patch)
treee644ec5e9890216c17adbc20bb63fba3ac369e9a /net/dante
parent3c74fb363f3596dd68ca0807b804a56caf35ca6d (diff)
downloadports-d459a9c59c3ac652890ac68092b47ff11c2dd956.tar.gz
ports-d459a9c59c3ac652890ac68092b47ff11c2dd956.zip
Honour threads.
Bump PORTREVISION. Reported by: Valentin Nechayev <netch at segfault dot kiev.ua>
Notes
Notes: svn path=/head/; revision=129356
Diffstat (limited to 'net/dante')
-rw-r--r--net/dante/Makefile4
-rw-r--r--net/dante/files/patch-ltmain.sh56
-rw-r--r--net/dante/pkg-plist2
3 files changed, 60 insertions, 2 deletions
diff --git a/net/dante/Makefile b/net/dante/Makefile
index 7344a347e89e..fe4222f9f594 100644
--- a/net/dante/Makefile
+++ b/net/dante/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dante
PORTVERSION= 1.1.14
+PORTREVISION= 1
CATEGORIES= net security
MASTER_SITES= ftp://ftp.inet.no/pub/socks/ \
ftp://ftp.nuug.no/pub/anders/distfiles/ \
@@ -16,8 +17,11 @@ MAINTAINER= anders@FreeBSD.org
COMMENT= A circuit-level firewall/proxy
GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-socks-conf=${PREFIX}/etc/socks.conf \
--with-sockd-conf=${PREFIX}/etc/sockd.conf
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
INSTALLS_SHLIB= yes
diff --git a/net/dante/files/patch-ltmain.sh b/net/dante/files/patch-ltmain.sh
new file mode 100644
index 000000000000..d740de004aed
--- /dev/null
+++ b/net/dante/files/patch-ltmain.sh
@@ -0,0 +1,56 @@
+--- ltmain.sh.orig Sun Feb 20 11:57:03 2005
++++ ltmain.sh Sun Feb 20 12:04:33 2005
+@@ -1052,14 +1052,14 @@
+ # These systems don't actually have a C library (as such)
+ test "X$arg" = "X-lc" && continue
+ ;;
+- *-*-openbsd*)
++ *-*-openbsd* | *-*-freebsd4*)
+ # Do not include libc due to us having libc/libc_r.
+ test "X$arg" = "X-lc" && continue
+ ;;
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd*)
++ *-*-openbsd* | *-*-freebsd4*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -1069,6 +1069,13 @@
+ continue
+ ;;
+
++ -pthread)
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
++
+ -module)
+ module=yes
+ continue
+@@ -2453,6 +2460,9 @@
+ *-*-openbsd*)
+ # Do not include libc due to us having libc/libc_r.
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ # Add libc to deplibs on all other systems if necessary.
+ if test $build_libtool_need_lc = "yes"; then
+@@ -4219,10 +4229,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/net/dante/pkg-plist b/net/dante/pkg-plist
index 4eeaf24b7b27..9eee0b6a8e07 100644
--- a/net/dante/pkg-plist
+++ b/net/dante/pkg-plist
@@ -3,11 +3,9 @@ etc/sockd.conf.example
etc/socks.conf.example
etc/rc.d/sockd.sh-dist
include/socks.h
-lib/libdsocks.la
lib/libdsocks.so
lib/libdsocks.so.1
lib/libsocks.a
-lib/libsocks.la
lib/libsocks.so
lib/libsocks.so.1
sbin/sockd