aboutsummaryrefslogtreecommitdiff
path: root/net/dbeacon
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2016-03-17 21:04:58 +0000
committerMark Felder <feld@FreeBSD.org>2016-03-17 21:04:58 +0000
commit5b6efbe76a7cc21ffb5060bb0a8ce3f10786c995 (patch)
tree5a98d8c3584d937aa205704ca53275602b63658d /net/dbeacon
parent9b0f5c26aad14c31c419fdd43d33e68dfa6a2099 (diff)
downloadports-5b6efbe76a7cc21ffb5060bb0a8ce3f10786c995.tar.gz
ports-5b6efbe76a7cc21ffb5060bb0a8ce3f10786c995.zip
net/dbeacon: Unbreak port
- New MAINTAINER - New MASTER_SITE - Add patch to clean up some build errors - Cleaned up pkg-descr PR: 208048 MFH: 2016Q1
Notes
Notes: svn path=/head/; revision=411315
Diffstat (limited to 'net/dbeacon')
-rw-r--r--net/dbeacon/Makefile6
-rw-r--r--net/dbeacon/files/patch-dbeacon.cpp34
-rw-r--r--net/dbeacon/pkg-descr10
3 files changed, 41 insertions, 9 deletions
diff --git a/net/dbeacon/Makefile b/net/dbeacon/Makefile
index b8aad92541a2..3345255ea0d3 100644
--- a/net/dbeacon/Makefile
+++ b/net/dbeacon/Makefile
@@ -4,13 +4,11 @@
PORTNAME= dbeacon
PORTVERSION= 0.3.9.1
CATEGORIES= net
-MASTER_SITES= http://fivebits.net/files/dbeacon/
+MASTER_SITES= http://BSDforge.com/projects/source/net/dbeacon/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= portmaster@BSDforge.com
COMMENT= Distributed multicast beacon server
-BROKEN= unfetchable
-
LICENSE= GPLv2+
USES= gmake
diff --git a/net/dbeacon/files/patch-dbeacon.cpp b/net/dbeacon/files/patch-dbeacon.cpp
new file mode 100644
index 000000000000..089588052e2e
--- /dev/null
+++ b/net/dbeacon/files/patch-dbeacon.cpp
@@ -0,0 +1,34 @@
+--- dbeacon.cpp.orig 2016-03-15 16:06:23.135551000 -0700
++++ dbeacon.cpp 2016-03-15 16:08:13.104873000 -0700
+@@ -1498,7 +1498,7 @@
+ fprintf(fp, " contact=\"%s\"", adminContact.c_str());
+ if (!twoLetterCC.empty())
+ fprintf(fp, " country=\"%s\"", twoLetterCC.c_str());
+- fprintf(fp, " age=\"%llu\" lastupdate=\"0\" rxlocal=\"true\">\n", (now - startTime) / 1000);
++ fprintf(fp, " age=\"%lu\" lastupdate=\"0\" rxlocal=\"true\">\n", (now - startTime) / 1000);
+
+ for (uint32_t k = 0; k < KnownFlags; k++) {
+ if (flags & (1 << k)) {
+@@ -1526,8 +1526,8 @@
+ if (!i->second.CC.empty())
+ fprintf(fp, " country=\"%s\"", i->second.CC.c_str());
+
+- fprintf(fp, " age=\"%llu\"", (now - i->second.creation) / 1000);
+- fprintf(fp, " lastupdate=\"%llu\">\n", (now - i->second.lastevent) / 1000);
++ fprintf(fp, " age=\"%lu\"", (now - i->second.creation) / 1000);
++ fprintf(fp, " lastupdate=\"%lu\">\n", (now - i->second.lastevent) / 1000);
+
+ if (i->second.ASM.s.valid)
+ dumpStats(fp, "asm", i->second.ASM.s, now, i->second.sttl, true);
+@@ -1552,9 +1552,9 @@
+ }
+ i->first.print(tmp, sizeof(tmp));
+ fprintf(fp, " addr=\"%s\"", tmp);
+- fprintf(fp, " age=\"%llu\"", (now - i->second.creation) / 1000);
++ fprintf(fp, " age=\"%lu\"", (now - i->second.creation) / 1000);
+ fprintf(fp, " rxlocal=\"%s\"", i->second.rxlocal(now) ? "true" : "false");
+- fprintf(fp, " lastupdate=\"%llu\">\n", (now - i->second.lastevent) / 1000);
++ fprintf(fp, " lastupdate=\"%lu\">\n", (now - i->second.lastevent) / 1000);
+
+ for (uint32_t k = 0; k < KnownFlags; k++) {
+ if (i->second.Flags & (1 << k)) {
diff --git a/net/dbeacon/pkg-descr b/net/dbeacon/pkg-descr
index b1ba58ab1895..6c6747e420e0 100644
--- a/net/dbeacon/pkg-descr
+++ b/net/dbeacon/pkg-descr
@@ -1,7 +1,7 @@
-Dbeacon is a distributed multicast monitoring tool. The main purpose of a
-beacon is to monitor other beacons' reachability and to collect statistics
-such as loss, delay, and jitter between beacons. Dbeacon supports both
-IPv4 and IPv6 multicast and supports collecting information using both Any
-Source Multicast (ASM) and Source-Specific Multicast (SSM).
+Dbeacon is a distributed multicast monitoring tool. The main purpose of a
+beacon is to monitor other beacons' reachability and to collect statistics
+such as loss, delay, and jitter between beacons. Dbeacon supports both
+IPv4, and IPv6 multicast, and supports collecting information using both
+Any Source Multicast (ASM) and Source-Specific Multicast (SSM).
WWW: http://fivebits.net/proj/dbeacon