aboutsummaryrefslogtreecommitdiff
path: root/net/delegate
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-07-22 19:01:20 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-07-22 19:01:20 +0000
commitb6f659f6cbf600d8b09f49a6c5abd41ebe7f4e6b (patch)
treeeb9c47b1a471dcdb18b3ae5a0e783e9e38b98077 /net/delegate
parentbc7d8ba28233b94cdf9f749a71e55e73f3dea47c (diff)
downloadports-b6f659f6cbf600d8b09f49a6c5abd41ebe7f4e6b.tar.gz
ports-b6f659f6cbf600d8b09f49a6c5abd41ebe7f4e6b.zip
- Don't strip the binary. This breaks the binary checksumming
- Introduce ADMIN variable PR: ports/192039 Submitted by: Martin Birgmeier <la5lbtyi@aon.at>
Notes
Notes: svn path=/head/; revision=362568
Diffstat (limited to 'net/delegate')
-rw-r--r--net/delegate/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/net/delegate/Makefile b/net/delegate/Makefile
index 004febfc1990..868358dfea2a 100644
--- a/net/delegate/Makefile
+++ b/net/delegate/Makefile
@@ -3,6 +3,7 @@
PORTNAME= delegate
PORTVERSION= 9.9.10
+PORTREVISION= 1
CATEGORIES= net www
MASTER_SITES= ftp://ftp.delegate.org/pub/DeleGate/
DISTNAME= ${PORTNAME}${PORTVERSION}
@@ -13,21 +14,21 @@ COMMENT= General purpose TCP/IP proxy system
USES= gmake
SUB_FILES= pkg-message
+ADMIN?= admin@example.com
+
PLIST_FILES= sbin/delegated etc/rc.d/delegated.sh-dist
PORTDOCS= CHANGES COPYRIGHT DG9note.html HowToDG.html IPv6NOTE.txt \
Manual.htm jpconv.htm tutor-en.htm tutor-jp.htm
+# Strip breaks binary checksumming
+STRIP=
+
post-extract:
@${LN} ${WRKSRC}/CHANGES ${WRKSRC}/COPYRIGHT ${WRKSRC}/DG9note.html \
${WRKSRC}/IPv6NOTE.txt ${WRKSRC}/doc
post-patch:
-# Prevent "filesystem was touched prior to 'make install' phase" warning;
-# allow unattended (non-interactive) builds
- @${REINPLACE_CMD} -e 's,"$$(XDG)",& DGROOT=${WRKDIR},' \
- ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -E '/ADMIN/s,undef,admin@example.com, ; \
- s,-F(esign|ver),& DGROOT=${WRKDIR},' ${WRKSRC}/src/Makefile
+ @${REINPLACE_CMD} -E "/ADMIN/s,undef,${ADMIN}," ${WRKSRC}/src/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/delegated ${STAGEDIR}${PREFIX}/sbin