aboutsummaryrefslogtreecommitdiff
path: root/net/dgd-lpmud
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2010-03-24 05:09:17 +0000
committerGreg Lewis <glewis@FreeBSD.org>2010-03-24 05:09:17 +0000
commitf9d17722aef3ed22ade42d607948f67d92372a6e (patch)
treebdbb46574a27c861fe347bdfe35552c6a7f199b8 /net/dgd-lpmud
parent902a50851a0e41eb31736516797eb23319dd69e7 (diff)
downloadports-f9d17722aef3ed22ade42d607948f67d92372a6e.tar.gz
ports-f9d17722aef3ed22ade42d607948f67d92372a6e.zip
. Use the official distribution for DGD 1.4, reducing the amount of
patching needed to get 2.4.5 working with it.
Notes
Notes: svn path=/head/; revision=251425
Diffstat (limited to 'net/dgd-lpmud')
-rw-r--r--net/dgd-lpmud/Makefile8
-rw-r--r--net/dgd-lpmud/distinfo6
-rw-r--r--net/dgd-lpmud/files/patch-2.4.5-dgd-sys-driver.c105
-rw-r--r--net/dgd-lpmud/files/patch-lpmud.dgd8
4 files changed, 10 insertions, 117 deletions
diff --git a/net/dgd-lpmud/Makefile b/net/dgd-lpmud/Makefile
index c3749be6dd16..9d65199c4c82 100644
--- a/net/dgd-lpmud/Makefile
+++ b/net/dgd-lpmud/Makefile
@@ -7,11 +7,11 @@
PORTNAME= dgd-lpmud
PORTVERSION= 2.4.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net games
-MASTER_SITES= ftp://ftp.lysator.liu.se/pub/lpmud/drivers/dgd/lpc/ \
- ${MASTER_SITE_LOCAL:S|%SUBDIR%|glewis/dgd|}
-DISTNAME= 2.4.5-for-1.1
+MASTER_SITES= ${MASTER_SITE_LOCAL:S|%SUBDIR%|glewis/dgd|} \
+ http://ftp.dworkin.nl/dgd/lib/
+DISTNAME= 2.4.5-for-1.4
EXTRACT_SUFX= .tgz
MAINTAINER= glewis@FreeBSD.org
diff --git a/net/dgd-lpmud/distinfo b/net/dgd-lpmud/distinfo
index fef60133a588..07bf1692b48a 100644
--- a/net/dgd-lpmud/distinfo
+++ b/net/dgd-lpmud/distinfo
@@ -1,3 +1,3 @@
-MD5 (dgd/2.4.5-for-1.1.tgz) = 01bd86d5b50b06c404a40f1bb9761c59
-SHA256 (dgd/2.4.5-for-1.1.tgz) = 73e3b1d3846ad11db0f73953057553784f36e62d34d75104151f1376523e8d5f
-SIZE (dgd/2.4.5-for-1.1.tgz) = 198001
+MD5 (dgd/2.4.5-for-1.4.tgz) = 3bf916aa4a5d0adf6ab20648a28aa10b
+SHA256 (dgd/2.4.5-for-1.4.tgz) = 173013af24a949db3aee2f7d45ed6b609800335b50c4c3dcd379b3575ce24fb7
+SIZE (dgd/2.4.5-for-1.4.tgz) = 194906
diff --git a/net/dgd-lpmud/files/patch-2.4.5-dgd-sys-driver.c b/net/dgd-lpmud/files/patch-2.4.5-dgd-sys-driver.c
index c5373db15317..c69dbd257d14 100644
--- a/net/dgd-lpmud/files/patch-2.4.5-dgd-sys-driver.c
+++ b/net/dgd-lpmud/files/patch-2.4.5-dgd-sys-driver.c
@@ -1,7 +1,7 @@
$FreeBSD$
---- 2.4.5/dgd/sys/driver.c.orig 1996-11-28 14:23:11.000000000 -0800
-+++ 2.4.5/dgd/sys/driver.c 2009-07-05 19:04:50.000000000 -0700
+--- 2.4.5/dgd/sys/driver.c.orig 2010-03-21 10:39:41.000000000 -0700
++++ 2.4.5/dgd/sys/driver.c 2010-03-23 21:53:25.000000000 -0700
@@ -3,6 +3,10 @@
# include <status.h>
# include "/dgd/lib/privilege.h"
@@ -23,77 +23,7 @@ $FreeBSD$
}
/*
-@@ -143,12 +147,40 @@
- }
-
- /*
-+ * NAME: touch()
-+ * DESCRIPTION: determine whether to preserve untouched status.
-+ */
-+static int touch(object obj, string function)
-+{
-+ return 0;
-+}
-+
-+/*
- * NAME: inherit_program()
- * DESCRIPTION: get an object to inherit
- */
--static object inherit_program(string file, string path)
-+static object inherit_program(string file, string path, int priv)
-+{
-+ object obj;
-+
-+ file = path_object(path);
-+ obj = find_object(file);
-+ if (obj == 0) {
-+ obj = compile_object(file);
-+ }
-+ return obj;
-+}
-+
-+/*
-+ * NAME: include_file()
-+ * DESCRIPTION: translate an include path
-+ */
-+static mixed include_file(string file, string path)
- {
-- return call_object(path);
-+ if (path[0] != '/') {
-+ return file + "/../" + path;
-+ }
-+ return path;
- }
-
- /*
-@@ -183,7 +215,7 @@
- * NAME: telnet_connect()
- * DESCRIPTION: return a player object
- */
--static object telnet_connect()
-+static object telnet_connect(int port)
- {
- object user, player;
-
-@@ -204,7 +236,7 @@
- * NAME: binary_connect()
- * DESCRIPTION: return another player object (just to test)
- */
--static object binary_connect()
-+static object binary_connect(int port)
- {
- object user, player;
-
-@@ -225,7 +257,7 @@
- * NAME: runtime_error()
- * DESCRIPTION: log a runtime error
- */
--static void runtime_error(string error, int caught)
-+static void runtime_error(string error, int caught, int ticks)
- {
- mixed **trace;
- string progname, objname, function, str;
-@@ -249,6 +281,16 @@
+@@ -249,6 +256,16 @@
return user;
}
@@ -110,32 +40,3 @@ $FreeBSD$
/*
* NAME: runtime_error()
* DESCRIPTION: log a runtime error
-@@ -315,6 +357,15 @@
- }
-
- /*
-+ * NAME: atomic_error()
-+ * DESCRIPTION: deal with an atomic error
-+ */
-+static void atomic_error(string error, int atom, int ticks)
-+{
-+ send_message(error + "\n");
-+}
-+
-+/*
- * NAME: interrupt()
- * DESCRIPTION: deal with a kill signal
- */
-@@ -377,3 +428,12 @@
- {
- return 0; /* No. */
- }
-+
-+/*
-+ * NAME: object_type()
-+ * DESCRIPTION: translate the object path used in a type declaration
-+ */
-+static string object_type(string file, string type)
-+{
-+ return type;
-+}
diff --git a/net/dgd-lpmud/files/patch-lpmud.dgd b/net/dgd-lpmud/files/patch-lpmud.dgd
index a8b4f1d6447c..4092ac713f10 100644
--- a/net/dgd-lpmud/files/patch-lpmud.dgd
+++ b/net/dgd-lpmud/files/patch-lpmud.dgd
@@ -16,11 +16,3 @@ $FreeBSD$
swap_size = 20960; /* # sectors in swap file */
cache_size = 100; /* # sectors in swap cache */
sector_size = 1024; /* swap sector size */
-@@ -12,6 +13,7 @@
- static_chunk = 64512; /* static memory chunk */
- dynamic_chunk = 261120; /* dynamic memory chunk */
- dump_file = "../dump"; /* state dump file */
-+dump_interval = 3600; /* dump interval in seconds */
-
- typechecking = 0; /* global typechecking */
- include_file = "/dgd/include/auto.h"; /* standard include file */