aboutsummaryrefslogtreecommitdiff
path: root/net/dhcp6/Makefile
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2004-07-31 20:27:38 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2004-07-31 20:27:38 +0000
commit2feee32f65c64873364997016a9aa8794fc9f5e0 (patch)
tree068f61f4ffdb052491f3f543cd6615d1f92f6f77 /net/dhcp6/Makefile
parent423da2c5dd2af53c59fe7f45149ed7ed327ad054 (diff)
downloadports-2feee32f65c64873364997016a9aa8794fc9f5e0.tar.gz
ports-2feee32f65c64873364997016a9aa8794fc9f5e0.zip
Notes
Diffstat (limited to 'net/dhcp6/Makefile')
-rw-r--r--net/dhcp6/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/net/dhcp6/Makefile b/net/dhcp6/Makefile
new file mode 100644
index 000000000000..a42a60a020b4
--- /dev/null
+++ b/net/dhcp6/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: dhcp6
+# Date created: 30 July 2004
+# Whom: sumikawa
+#
+# $FreeBSD$
+#
+
+PORTNAME= dhcp6
+PORTVERSION= 20040731a
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.kame.net/pub/kame/misc/
+DISTNAME= kame-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= sumikawa@FreeBSD.org
+COMMENT= KAME DHCP6 client and server
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --sysconfdir=${LOCALBASE}/etc --with-localdbdir=/var/db
+USE_REINPLACE= yes
+
+MAN5= dhcp6c.conf.5 dhcp6s.conf.5
+MAN8= dhcp6c.8 dhcp6s.8 dhcp6relay.8 dhcp6sctl.8
+
+post-patch:
+.for file in ${MAN5} ${MAN8}
+ ${REINPLACE_CMD} -e 's|/usr/local/v6/etc|${LOCALBASE}/etc|' \
+ ${WRKSRC}/${file}
+.endfor
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/COPYRIGHT ${DOCSDIR}
+.endif
+ ${INSTALL_DATA} ${WRKSRC}/dhcp6c.conf.sample ${PREFIX}/etc
+ ${INSTALL_DATA} ${WRKSRC}/dhcp6s.conf.sample ${PREFIX}/etc
+
+.include <bsd.port.mk>