aboutsummaryrefslogtreecommitdiff
path: root/net/dictd/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-12-08 09:12:03 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-12-08 09:12:03 +0000
commit8e41174ddb1f015aeb1b748775a46c1f078ce5d7 (patch)
treed4da13aa9edb9103bd8a2b932c146e2376949ba9 /net/dictd/Makefile
parentc2c774de7742c368473812b431d641054cdee4a5 (diff)
downloadports-8e41174ddb1f015aeb1b748775a46c1f078ce5d7.tar.gz
ports-8e41174ddb1f015aeb1b748775a46c1f078ce5d7.zip
Notes
Diffstat (limited to 'net/dictd/Makefile')
-rw-r--r--net/dictd/Makefile25
1 files changed, 10 insertions, 15 deletions
diff --git a/net/dictd/Makefile b/net/dictd/Makefile
index 70312ddffe6a..715845fb5746 100644
--- a/net/dictd/Makefile
+++ b/net/dictd/Makefile
@@ -6,34 +6,29 @@ PORTVERSION= 1.12.1
CATEGORIES+= net textproc
MASTER_SITES= SF/dict/${PORTNAME}/${PORTNAME}-${PORTVERSION}
-MAINTAINER?= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Dict protocol (RFC 2229) server
LICENSE= GPLv2
LIB_DEPENDS= libmaa.so:${PORTSDIR}/devel/libmaa
-USE_RC_SUBR= ${PORTNAME}
-USES= bison gmake libtool:build
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-etcdir=${PREFIX}/etc --with-cflags="${CFLAGS}" \
- --without-local-zlib
+ALL_TARGET= dictd dictzip
CPPFLAGS+= -I${LOCALBASE}/include
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install.dictd install.dictzip
LIBS+= -L${LOCALBASE}/lib
+USES= bison gmake libtool:build
-SUB_FILES+= dictd.conf pkg-message
-SUB_LIST+= PORTSDIR=${PORTSDIR}
-
-ALL_TARGET= dictd dictzip
-INSTALL_TARGET= install.dictd install.dictzip
+SUB_FILES= dictd.conf pkg-message
+SUB_LIST= PORTSDIR=${PORTSDIR}
+USE_RC_SUBR= ${PORTNAME}
post-patch:
-.for i in Makefile.in dict.1.in dictd.8.in
- @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/$i
-.endfor
+ @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/Makefile.in ${WRKSRC}/dict.1.in ${WRKSRC}/dictd.8.in
@${REINPLACE_CMD} -e "s|\([\ \t(]\)T_USER|\1T_USERNAME|g" ${WRKSRC}/*.[chly]
post-install:
- @${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.conf ${STAGEDIR}${PREFIX}/etc/${PORTNAME}.conf.sample
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.conf ${STAGEDIR}${PREFIX}/etc/${PORTNAME}.conf.sample
.include <bsd.port.mk>