aboutsummaryrefslogtreecommitdiff
path: root/net/ecal/Makefile
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-14 16:25:02 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-14 17:03:07 +0000
commit16567d7044fd151e4aac9e8adc6edde0ee7540d9 (patch)
tree2943fd1a48f44b0dbf4bdb03a0bea898d41d5590 /net/ecal/Makefile
parent8ab79171c59b509d0c9adab31144c02a0d5f2041 (diff)
downloadports-16567d7044fd151e4aac9e8adc6edde0ee7540d9.tar.gz
ports-16567d7044fd151e4aac9e8adc6edde0ee7540d9.zip
net/ecal: Fix build with protobuf 22+
Diffstat (limited to 'net/ecal/Makefile')
-rw-r--r--net/ecal/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/net/ecal/Makefile b/net/ecal/Makefile
index 0c75e1a170e6..8e69c866d1e8 100644
--- a/net/ecal/Makefile
+++ b/net/ecal/Makefile
@@ -25,7 +25,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libyaml-cpp.so:devel/yaml-cpp
# binaries aren't linked with libfineftp-server.so, see https://github.com/continental/ecal/issues/381; same with libcurl.so
-USES= cmake desktop-file-utils localbase:ldflags qt:5 shared-mime-info
+USES= cmake compiler:c++17-lang desktop-file-utils localbase:ldflags qt:5 shared-mime-info
USE_QT= core gui widgets buildtools:build qmake:build
USE_LDCONFIG= yes
@@ -50,6 +50,8 @@ CMAKE_ARGS= -DGIT_REVISION_MAJOR=${DISTVERSION:R:R} \
-Dqwt_LIBRARY=${LOCALBASE}/lib/qt5/libqwt6.so
CXXFLAGS+= -pthread # see https://github.com/eclipse-ecal/ecal/issues/933
+LDFLAGS+= -labsl_hash -labsl_log_internal_message -labsl_log_internal_nullguard -labsl_spinlock_wait
+USE_CXXSTD= c++17
PLIST_SUB= VERSION=${DISTVERSION}