aboutsummaryrefslogtreecommitdiff
path: root/net/ecore-con
diff options
context:
space:
mode:
authorGrzegorz Blach <gblach@FreeBSD.org>2013-10-05 21:12:23 +0000
committerGrzegorz Blach <gblach@FreeBSD.org>2013-10-05 21:12:23 +0000
commit3ad36ac4a8a056bb7b5098553d2a6b723b8a8e68 (patch)
tree4b8e808422aab37b1338c8626126e9d4351f819f /net/ecore-con
parent3b70ffa8de2963afeebb8a68b27a1824608dc302 (diff)
Notes
Diffstat (limited to 'net/ecore-con')
-rw-r--r--net/ecore-con/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/net/ecore-con/Makefile b/net/ecore-con/Makefile
index 8daa80983cea..10b188aa1332 100644
--- a/net/ecore-con/Makefile
+++ b/net/ecore-con/Makefile
@@ -17,14 +17,12 @@ LICENSE= BSD
DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_EFL= ecore libtool_hack
-USES= pkgconfig
+USES= gmake pkgconfig
USE_LDCONFIG= yes
BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_con
INSTALL_WRKSRC= ${BUILD_WRKSRC}
-NO_STAGE= yes
.include "../../devel/ecore-main/Makefile.inc"
CONFIGURE_ARGS+= --enable-ecore-con
@@ -36,14 +34,14 @@ OPTIONS_DEFAULT=CARES CURL SSL
.if ${PORT_OPTIONS:MCARES}
CONFIGURE_ARGS+= --enable-cares
-LIB_DEPENDS+= cares:${PORTSDIR}/dns/c-ares
+LIB_DEPENDS+= libcares.so:${PORTSDIR}/dns/c-ares
.else
CONFIGURE_ARGS+= --disable-cares
.endif
.if ${PORT_OPTIONS:MCURL}
CONFIGURE_ARGS+= --enable-curl
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
.else
CONFIGURE_ARGS+= --disable-curl
.endif
@@ -64,6 +62,6 @@ post-patch:
post-install:
@${REINPLACE_CMD} 's/ openssl//' ${WRKSRC}/ecore-con.pc
${INSTALL_DATA} ${WRKSRC}/ecore-con.pc \
- ${PREFIX}/libdata/pkgconfig/
+ ${STAGEDIR}${PREFIX}/libdata/pkgconfig/
.include <bsd.port.mk>