aboutsummaryrefslogtreecommitdiff
path: root/net/fonulator
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-03-20 10:53:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-03-20 10:53:08 +0000
commit654ccc6aac9c7681ed39c2cd2d10d8360ec7a9bc (patch)
treec30aa05ffe4be67ca3bb38317073b7e6603daa7c /net/fonulator
parent3dc362ac88ab73d6f0b3635628a59d9597e6da4e (diff)
downloadports-654ccc6aac9c7681ed39c2cd2d10d8360ec7a9bc.tar.gz
ports-654ccc6aac9c7681ed39c2cd2d10d8360ec7a9bc.zip
Notes
Diffstat (limited to 'net/fonulator')
-rw-r--r--net/fonulator/Makefile17
1 files changed, 3 insertions, 14 deletions
diff --git a/net/fonulator/Makefile b/net/fonulator/Makefile
index 01f00d9c99b7..92e383164f7b 100644
--- a/net/fonulator/Makefile
+++ b/net/fonulator/Makefile
@@ -15,30 +15,19 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libargtable2.a:${PORTSDIR}/devel/argtable\
LIB_DEPENDS= libnet.so:${PORTSDIR}/net/libnet
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include ${LIBNET_CPPFLAGS}
-LDFLAGS+= ${LIBNET_LIBS:N-l*}
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --disable-shared
-LIBNET_CONFIG= ${LOCALBASE}/bin/libnet11-config
-
PLIST_FILES= bin/fonulator \
man/man1/fonulator.1.gz
post-patch:
@${REINPLACE_CMD}\
-e 's,/usr/lib/libargtable2.a,${LOCALBASE}/lib/libargtable2.a,'\
- -e 's,/usr/lib/libnet.a,${LIBNET_LIBS:N-l*:S,-L,,}/libnet.a,'\
+ -e 's,/usr/lib/libnet.a,${LOCALBASE}/lib/libnet.a,'\
${WRKSRC}/Makefile.in ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's,/etc/redfone.conf,${LOCALBASE}/etc/redfone.conf,'\
${WRKSRC}/fonulator.c ${WRKSRC}/fonulator.1
-.if 0
-# this does not work when LIBNET_CONFIG does not exist prior to building this port
-LIBNET_CPPFLAGS!= ${LIBNET_CONFIG} --cflags --defines
-LIBNET_LIBS!= ${LIBNET_CONFIG} --libs
-.else
-LIBNET_CPPFLAGS= -I${LOCALBASE}/include/libnet11
-LIBNET_LIBS= -L${LOCALBASE}/lib/libnet11
-.endif
-
.include <bsd.port.mk>