aboutsummaryrefslogtreecommitdiff
path: root/net/foreman-proxy
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2014-02-08 11:40:34 +0000
committerMartin Matuska <mm@FreeBSD.org>2014-02-08 11:40:34 +0000
commit7d7d631b924ced0db5c8b5699d46b37aa538d413 (patch)
treef2e77eb7ccf89aa68864a1c115d95486ebb2dc5e /net/foreman-proxy
parentdaf73d263de05f98d609c2f41b2fcc2128f82bc3 (diff)
downloadports-7d7d631b924ced0db5c8b5699d46b37aa538d413.tar.gz
ports-7d7d631b924ced0db5c8b5699d46b37aa538d413.zip
Update foreman-proxy to 1.4.0
Notes
Notes: svn path=/head/; revision=343322
Diffstat (limited to 'net/foreman-proxy')
-rw-r--r--net/foreman-proxy/Makefile5
-rw-r--r--net/foreman-proxy/distinfo4
-rw-r--r--net/foreman-proxy/files/patch-lib-proxy-tftp.rb13
3 files changed, 12 insertions, 10 deletions
diff --git a/net/foreman-proxy/Makefile b/net/foreman-proxy/Makefile
index 564eb7d31963..5c2d0f2a14f1 100644
--- a/net/foreman-proxy/Makefile
+++ b/net/foreman-proxy/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= foreman-proxy
-DISTVERSION= 1.4.0-RC2
-PORTREVISION= 1
+PORTVERSION= 1.4.0
CATEGORIES= net
MASTER_SITES= GH
@@ -22,7 +21,7 @@ PUPPET_DESC= Depend on Puppet
USE_GITHUB= yes
GH_ACCOUNT= theforeman
GH_PROJECT= smart-proxy
-GH_COMMIT= 255c9bf
+GH_COMMIT= ae165b9
USE_RUBY= yes
USE_RAKE= yes
USE_RC_SUBR= foreman-proxy
diff --git a/net/foreman-proxy/distinfo b/net/foreman-proxy/distinfo
index ecf184f9cdf1..7ffeb4b1ec49 100644
--- a/net/foreman-proxy/distinfo
+++ b/net/foreman-proxy/distinfo
@@ -1,2 +1,2 @@
-SHA256 (foreman-proxy-1.4.0-RC2.tar.gz) = bbe0f3be114b8fb406e79fdd845690ad69d83915ccd1513fbc3deb71b894343a
-SIZE (foreman-proxy-1.4.0-RC2.tar.gz) = 84992
+SHA256 (foreman-proxy-1.4.0.tar.gz) = 082a6800eaafa38647b5b849be1c96602ec8cd1f1d3c00aa46db6d1f917481df
+SIZE (foreman-proxy-1.4.0.tar.gz) = 85030
diff --git a/net/foreman-proxy/files/patch-lib-proxy-tftp.rb b/net/foreman-proxy/files/patch-lib-proxy-tftp.rb
index f3c18dd53063..d2c32dcd70a9 100644
--- a/net/foreman-proxy/files/patch-lib-proxy-tftp.rb
+++ b/net/foreman-proxy/files/patch-lib-proxy-tftp.rb
@@ -1,11 +1,14 @@
---- lib/proxy/tftp.rb.orig 2014-01-29 00:26:35.629061321 +0100
-+++ lib/proxy/tftp.rb 2014-01-29 00:28:05.669054835 +0100
-@@ -104,7 +104,7 @@
+--- lib/proxy/tftp.rb.orig 2014-01-29 11:01:36.000000000 +0100
++++ lib/proxy/tftp.rb 2014-02-08 12:38:15.087475784 +0100
+@@ -105,8 +105,9 @@
# as the dst might contain another sub directory
FileUtils.mkdir_p destination.parent
-- cmd = "wget --timeout=10 --tries=3 --no-check-certificate -nv -c #{src} -O \"#{destination}\""
+- wget = which("wget")
+- cmd = "#{wget} --timeout=10 --tries=3 --no-check-certificate -nv -c #{src} -O \"#{destination}\""
++ # wget = which("wget")
++ # cmd = "#{wget} --timeout=10 --tries=3 --no-check-certificate -nv -c #{src} -O \"#{destination}\""
+ cmd = "/usr/bin/fetch --timeout=10 --no-verify-hostname --no-verify-peer -a -m -q -o \"#{destination}\" #{src}"
- Proxy::Util::CommandTask.new(cmd)
+ CommandTask.new(cmd)
end
end