aboutsummaryrefslogtreecommitdiff
path: root/net/foreman-proxy
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2020-07-03 16:55:58 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2020-07-03 16:55:58 +0000
commitb476e222143ee970b422a0bbef19021acecdce8c (patch)
tree2ad3447f476e4c4ab773aa6fdb44ea4e4b7eb5b9 /net/foreman-proxy
parent20bd24b1c261e75182b7785c770d58e126f0bd22 (diff)
downloadports-b476e222143ee970b422a0bbef19021acecdce8c.tar.gz
ports-b476e222143ee970b422a0bbef19021acecdce8c.zip
Notes
Diffstat (limited to 'net/foreman-proxy')
-rw-r--r--net/foreman-proxy/Makefile13
-rw-r--r--net/foreman-proxy/distinfo6
-rw-r--r--net/foreman-proxy/files/patch-config-settings.d-puppet_proxy_legacy.yml.example24
-rw-r--r--net/foreman-proxy/files/patch-config-settings.d-puppet_proxy_puppet_api.yml.example15
-rw-r--r--net/foreman-proxy/files/patch-config-settings.d-puppetca.yml.example13
-rw-r--r--net/foreman-proxy/files/patch-config-settings.d-realm_freeipa.yml.example4
-rw-r--r--net/foreman-proxy/files/patch-config-settings.d-tftp.yml.example7
-rw-r--r--net/foreman-proxy/files/patch-config-settings.yml.example6
-rw-r--r--net/foreman-proxy/files/patch-lib_proxy_http__download.rb14
-rw-r--r--net/foreman-proxy/pkg-plist33
10 files changed, 93 insertions, 42 deletions
diff --git a/net/foreman-proxy/Makefile b/net/foreman-proxy/Makefile
index f3b3da05402d..cef318fca85d 100644
--- a/net/foreman-proxy/Makefile
+++ b/net/foreman-proxy/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= foreman-proxy
-PORTVERSION= 1.15.1
-PORTREVISION= 1
+PORTVERSION= 1.21.2
CATEGORIES= net
MASTER_SITES= https://downloads.theforeman.org/foreman-proxy/
@@ -17,18 +16,20 @@ RUN_DEPENDS= rubygem-bundler_ext>=0.4:sysutils/rubygem-bundler_ext \
rubygem-json>=1.8.1:devel/rubygem-json \
rubygem-rack>=2.0:www/rubygem-rack \
rubygem-rb-kqueue>=0.2.2:devel/rubygem-rb-kqueue \
+ rubygem-rsec>=0.4.3:devel/rubygem-rsec \
rubygem-sinatra>=2.0:www/rubygem-sinatra \
wget:ftp/wget
-OPTIONS_DEFINE= BMC PUPPET5
+USES= shebangfix tar:bzip2
+
+OPTIONS_DEFINE= BMC PUPPET6
BMC_DESC= Depend on rubyipmi for BMC support
-PUPPET5_DESC= Depend on Puppet 5
+PUPPET6_DESC= Depend on Puppet 6
NO_ARCH= yes
NO_BUILD= yes
USE_RC_SUBR= foreman-proxy
USE_RUBY= yes
-USES= shebangfix tar:bzip2
FOREMAN_PROXY_USER?= foreman_proxy
FOREMAN_PROXY_GROUP?= foreman_proxy
@@ -49,7 +50,7 @@ PLIST_SUB= ${SUB_LIST} MKDIR="${MKDIR}"
SHEBANG_FILES= extra/foreman-debug-proxy
BMC_RUN_DEPENDS= rubygem-rubyipmi>=0.10.0:sysutils/rubygem-rubyipmi
-PUPPET5_RUN_DEPENDS= puppet:sysutils/puppet5 \
+PUPPET6_RUN_DEPENDS= puppet:sysutils/puppet6 \
rubygem-ruby-augeas>=0.5:textproc/rubygem-ruby-augeas
post-patch:
diff --git a/net/foreman-proxy/distinfo b/net/foreman-proxy/distinfo
index cf8118efc594..581509743483 100644
--- a/net/foreman-proxy/distinfo
+++ b/net/foreman-proxy/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1498243016
-SHA256 (foreman-proxy-1.15.1.tar.bz2) = d667ee649fe9422b636a7ba45550626002a37ba53454d4495279758508ac2ede
-SIZE (foreman-proxy-1.15.1.tar.bz2) = 158948
+TIMESTAMP = 1555274078
+SHA256 (foreman-proxy-1.21.2.tar.bz2) = bc5590f13de8e37cfb52c9a898642ae595b91d498b0384da28602e5505245a6a
+SIZE (foreman-proxy-1.21.2.tar.bz2) = 210802
diff --git a/net/foreman-proxy/files/patch-config-settings.d-puppet_proxy_legacy.yml.example b/net/foreman-proxy/files/patch-config-settings.d-puppet_proxy_legacy.yml.example
new file mode 100644
index 000000000000..9acd043d62ec
--- /dev/null
+++ b/net/foreman-proxy/files/patch-config-settings.d-puppet_proxy_legacy.yml.example
@@ -0,0 +1,24 @@
+--- config/settings.d/puppet_proxy_legacy.yml.example 2018-12-06 13:30:25.000000000 +0100
++++ config/settings.d/puppet_proxy_legacy.yml.example 2019-02-11 22:22:20.750500000 +0100
+@@ -5,7 +5,7 @@
+ # :puppet_version setting in smart-proxy's puppet.yml configuration file.
+ #
+ ---
+-#:puppet_conf: /etc/puppet/puppet.conf
++#:puppet_conf: %%LOCALBASE%%/etc/puppet/puppet.conf
+ #
+ # Override use of Puppet's API to list environments, by default it will use only if
+ # environmentpath is given in puppet.conf, else will look for environments in puppet.conf
+@@ -16,9 +16,9 @@
+ #:puppet_url: https://puppet.example.com:8140
+ #
+ # SSL certificates used to access the environment API. Required if puppet_use_environment_api is set to true.
+-#:puppet_ssl_ca: /var/lib/puppet/ssl/certs/ca.pem
+-#:puppet_ssl_cert: /var/lib/puppet/ssl/certs/puppet.example.com.pem
+-#:puppet_ssl_key: /var/lib/puppet/ssl/private_keys/puppet.example.com.pem
++#:puppet_ssl_ca: /var/puppet/ssl/certs/ca.pem
++#:puppet_ssl_cert: /var/puppet/ssl/certs/puppet.example.com.pem
++#:puppet_ssl_key: /var/puppet/ssl/private_keys/puppet.example.com.pem
+ #
+ # Enable/disable puppet class cache
+ #:use_cache: true
diff --git a/net/foreman-proxy/files/patch-config-settings.d-puppet_proxy_puppet_api.yml.example b/net/foreman-proxy/files/patch-config-settings.d-puppet_proxy_puppet_api.yml.example
new file mode 100644
index 000000000000..84cff78da77f
--- /dev/null
+++ b/net/foreman-proxy/files/patch-config-settings.d-puppet_proxy_puppet_api.yml.example
@@ -0,0 +1,15 @@
+--- config/settings.d/puppet_proxy_puppet_api.yml.example.orig 2018-12-06 13:30:25.000000000 +0100
++++ config/settings.d/puppet_proxy_puppet_api.yml.example 2019-02-11 22:22:53.410247000 +0100
+@@ -9,9 +9,9 @@
+ #:puppet_url: https://puppet.example.com:8140
+ #
+ # SSL certificates used to access the puppet API
+-#:puppet_ssl_ca: /var/lib/puppet/ssl/certs/ca.pem
+-#:puppet_ssl_cert: /var/lib/puppet/ssl/certs/puppet.example.com.pem
+-#:puppet_ssl_key: /var/lib/puppet/ssl/private_keys/puppet.example.com.pem
++#:puppet_ssl_ca: /var/puppet/ssl/certs/ca.pem
++#:puppet_ssl_cert: /var/puppet/ssl/certs/puppet.example.com.pem
++#:puppet_ssl_key: /var/puppet/ssl/private_keys/puppet.example.com.pem
+ #
+ # Smart Proxy api timeout when Puppet's environment classes api is used and classes cache is disabled
+ #:api_timeout: 30
diff --git a/net/foreman-proxy/files/patch-config-settings.d-puppetca.yml.example b/net/foreman-proxy/files/patch-config-settings.d-puppetca.yml.example
deleted file mode 100644
index 78544b2d4bf3..000000000000
--- a/net/foreman-proxy/files/patch-config-settings.d-puppetca.yml.example
+++ /dev/null
@@ -1,13 +0,0 @@
---- config/settings.d/puppetca.yml.example.orig 2017-05-08 15:18:42 UTC
-+++ config/settings.d/puppetca.yml.example
-@@ -2,7 +2,7 @@
- # Can be true, false, or http/https to enable just one of the protocols
- :enabled: false
-
--#:ssldir: /var/lib/puppet/ssl
--#:puppetdir: /etc/puppet
-+#:ssldir: /var/puppet/ssl
-+#:puppetdir: %%LOCALBASE%%/etc/puppet
- #:puppetca_use_sudo: true
--#:sudo_command: /usr/bin/sudo
-+#:sudo_command: %%LOCALBASE%%/bin/sudo
diff --git a/net/foreman-proxy/files/patch-config-settings.d-realm_freeipa.yml.example b/net/foreman-proxy/files/patch-config-settings.d-realm_freeipa.yml.example
index 2fe5f1da9cd5..52f93d135b18 100644
--- a/net/foreman-proxy/files/patch-config-settings.d-realm_freeipa.yml.example
+++ b/net/foreman-proxy/files/patch-config-settings.d-realm_freeipa.yml.example
@@ -1,5 +1,5 @@
---- config/settings.d/realm_freeipa.yml.example.orig 2017-05-08 15:18:42 UTC
-+++ config/settings.d/realm_freeipa.yml.example
+--- config/settings.d/realm_freeipa.yml.example.orig 2018-12-06 13:30:25.000000000 +0100
++++ config/settings.d/realm_freeipa.yml.example 2019-02-11 22:24:18.091737000 +0100
@@ -1,8 +1,8 @@
---
# Authentication for Kerberos-based Realms
diff --git a/net/foreman-proxy/files/patch-config-settings.d-tftp.yml.example b/net/foreman-proxy/files/patch-config-settings.d-tftp.yml.example
index 350598f0599c..5aae4bfc8a6a 100644
--- a/net/foreman-proxy/files/patch-config-settings.d-tftp.yml.example
+++ b/net/foreman-proxy/files/patch-config-settings.d-tftp.yml.example
@@ -1,6 +1,6 @@
---- config/settings.d/tftp.yml.example.orig 2017-05-08 15:18:42 UTC
-+++ config/settings.d/tftp.yml.example
-@@ -2,6 +2,6 @@
+--- config/settings.d/tftp.yml.example.orig 2018-12-06 13:30:25.000000000 +0100
++++ config/settings.d/tftp.yml.example 2019-02-11 22:24:46.060855000 +0100
+@@ -2,7 +2,7 @@
# Can be true, false, or http/https to enable just one of the protocols
:enabled: false
@@ -8,3 +8,4 @@
+#:tftproot: /tftpboot
# Defines the TFTP Servername to use, overrides the name in the subnet declaration
#:tftp_servername: tftp.domain.com
+
diff --git a/net/foreman-proxy/files/patch-config-settings.yml.example b/net/foreman-proxy/files/patch-config-settings.yml.example
index bf15c6366d0e..ff3ac32eedde 100644
--- a/net/foreman-proxy/files/patch-config-settings.yml.example
+++ b/net/foreman-proxy/files/patch-config-settings.yml.example
@@ -1,6 +1,6 @@
---- config/settings.yml.example.orig 2017-05-08 15:18:42 UTC
-+++ config/settings.yml.example
-@@ -38,7 +38,7 @@
+--- config/settings.yml.example.orig 2018-12-06 13:30:25.000000000 +0100
++++ config/settings.yml.example 2019-02-11 22:25:42.626500000 +0100
+@@ -43,7 +43,7 @@
#:foreman_ssl_key: ssl/private_keys/fqdn.pem
# by default smart_proxy runs in the foreground. To enable running as a daemon, uncomment 'daemon' setting
diff --git a/net/foreman-proxy/files/patch-lib_proxy_http__download.rb b/net/foreman-proxy/files/patch-lib_proxy_http__download.rb
index 6c44f49c45a8..81c97ff8734e 100644
--- a/net/foreman-proxy/files/patch-lib_proxy_http__download.rb
+++ b/net/foreman-proxy/files/patch-lib_proxy_http__download.rb
@@ -1,11 +1,11 @@
---- lib/proxy/http_download.rb.orig 2017-05-08 15:18:42 UTC
-+++ lib/proxy/http_download.rb
-@@ -6,7 +6,7 @@ module Proxy
+--- lib/proxy/http_download.rb.orig 2018-12-06 13:30:25.000000000 +0100
++++ lib/proxy/http_download.rb 2019-02-11 22:33:58.455890000 +0100
+@@ -9,7 +9,7 @@
- def initialize(src, dst)
+ def initialize(src, dst, read_timeout = nil, connect_timeout = nil, dns_timeout = nil)
@dst = dst
- wget = which("wget")
+ wget = "%%LOCALBASE%%/bin/wget"
- super("#{wget} --timeout=10 --tries=3 --no-check-certificate -nv -c \"#{escape_for_shell(src.to_s)}\" -O \"#{escape_for_shell(dst.to_s)}\"")
- end
-
+ read_timeout ||= DEFAULT_READ_TIMEOUT
+ dns_timeout ||= DEFAULT_CONNECT_TIMEOUT
+ connect_timeout ||= DEFAULT_DNS_TIMEOUT
diff --git a/net/foreman-proxy/pkg-plist b/net/foreman-proxy/pkg-plist
index 564d5645e32e..4ade110f67cd 100644
--- a/net/foreman-proxy/pkg-plist
+++ b/net/foreman-proxy/pkg-plist
@@ -34,9 +34,11 @@ sbin/smart-proxy
%%DATADIR%%/bundler.d/bmc.rb
%%DATADIR%%/bundler.d/development.rb
%%DATADIR%%/bundler.d/dhcp_isc.rb
+%%DATADIR%%/bundler.d/journald.rb
%%DATADIR%%/bundler.d/krb5.rb
%%DATADIR%%/bundler.d/libvirt.rb
%%DATADIR%%/bundler.d/puppet.rb
+%%DATADIR%%/bundler.d/puppetca_token_whitelisting.rb
%%DATADIR%%/bundler.d/realm_freeipa.rb
%%DATADIR%%/bundler.d/test.rb
%%DATADIR%%/bundler.d/windows.rb
@@ -50,6 +52,8 @@ sbin/smart-proxy
%%DATADIR%%/extra/migrations/20160411000000_migrate_libvirt_settings.rb
%%DATADIR%%/extra/migrations/20160413000000_migrate_puppet_settings.rb
%%DATADIR%%/extra/migrations/20161209000000_migrate_realm_settings.rb
+%%DATADIR%%/extra/migrations/20170523000000_migrate_autosign_setting.rb
+%%DATADIR%%/extra/migrations/2018062000000_migrate_puppetca_settings.rb
%%DATADIR%%/extra/query.rb
%%DATADIR%%/extra/register-service.rb
%%DATADIR%%/lib/bundler_helper.rb
@@ -63,11 +67,14 @@ sbin/smart-proxy
%%DATADIR%%/lib/proxy/file_lock.rb
%%DATADIR%%/lib/proxy/helpers.rb
%%DATADIR%%/lib/proxy/http_download.rb
+%%DATADIR%%/lib/proxy/http_download.rb.bak
+%%DATADIR%%/lib/proxy/http_download.rb.orig
%%DATADIR%%/lib/proxy/kerberos.rb
%%DATADIR%%/lib/proxy/log.rb
%%DATADIR%%/lib/proxy/log_buffer/buffer.rb
%%DATADIR%%/lib/proxy/log_buffer/decorator.rb
%%DATADIR%%/lib/proxy/log_buffer/ring_buffer.rb
+%%DATADIR%%/lib/proxy/log_buffer/trace_decorator.rb
%%DATADIR%%/lib/proxy/memory_store.rb
%%DATADIR%%/lib/proxy/pluggable.rb
%%DATADIR%%/lib/proxy/plugin.rb
@@ -78,6 +85,7 @@ sbin/smart-proxy
%%DATADIR%%/lib/proxy/provider_factory.rb
%%DATADIR%%/lib/proxy/request.rb
%%DATADIR%%/lib/proxy/request_id_middleware.rb
+%%DATADIR%%/lib/proxy/sd_notify.rb
%%DATADIR%%/lib/proxy/settings.rb
%%DATADIR%%/lib/proxy/settings/global.rb
%%DATADIR%%/lib/proxy/settings/plugin.rb
@@ -85,7 +93,6 @@ sbin/smart-proxy
%%DATADIR%%/lib/proxy/util.rb
%%DATADIR%%/lib/proxy/validations.rb
%%DATADIR%%/lib/rack-patch.rb
-%%DATADIR%%/lib/sinatra-patch.rb
%%DATADIR%%/lib/sinatra/authorization.rb
%%DATADIR%%/lib/sinatra/default_not_found_page.rb
%%DATADIR%%/lib/smart_proxy.rb
@@ -107,12 +114,13 @@ sbin/smart-proxy
%%DATADIR%%/modules/dhcp/dhcp_plugin.rb
%%DATADIR%%/modules/dhcp/http_config.ru
%%DATADIR%%/modules/dhcp_common/dhcp_common.rb
-%%DATADIR%%/modules/dhcp_common/isc/configuration_file.rb
-%%DATADIR%%/modules/dhcp_common/isc/file_parser.rb
+%%DATADIR%%/modules/dhcp_common/free_ips.rb
+%%DATADIR%%/modules/dhcp_common/isc/configuration_parser.rb
%%DATADIR%%/modules/dhcp_common/isc/omapi_provider.rb
%%DATADIR%%/modules/dhcp_common/isc/subnet_service_initialization.rb
%%DATADIR%%/modules/dhcp_common/monkey_patch_subnet.rb
%%DATADIR%%/modules/dhcp_common/monkey_patches.rb
+%%DATADIR%%/modules/dhcp_common/pingable.rb
%%DATADIR%%/modules/dhcp_common/record.rb
%%DATADIR%%/modules/dhcp_common/record/deleted_reservation.rb
%%DATADIR%%/modules/dhcp_common/record/lease.rb
@@ -126,7 +134,6 @@ sbin/smart-proxy
%%DATADIR%%/modules/dhcp_isc/inotify_leases_file_observer.rb
%%DATADIR%%/modules/dhcp_isc/isc_state_changes_observer.rb
%%DATADIR%%/modules/dhcp_isc/kqueue_leases_file_observer.rb
-%%DATADIR%%/modules/dhcp_isc/leases_file.rb
%%DATADIR%%/modules/dhcp_libvirt/configuration_loader.rb
%%DATADIR%%/modules/dhcp_libvirt/dhcp_libvirt.rb
%%DATADIR%%/modules/dhcp_libvirt/dhcp_libvirt_main.rb
@@ -166,6 +173,10 @@ sbin/smart-proxy
%%DATADIR%%/modules/facts/facts_api.rb
%%DATADIR%%/modules/facts/facts_plugin.rb
%%DATADIR%%/modules/facts/http_config.ru
+%%DATADIR%%/modules/httpboot/http_config.ru
+%%DATADIR%%/modules/httpboot/httpboot.rb
+%%DATADIR%%/modules/httpboot/httpboot_api.rb
+%%DATADIR%%/modules/httpboot/httpboot_plugin.rb
%%DATADIR%%/modules/libvirt_common/libvirt_network.rb
%%DATADIR%%/modules/logs/http_config.ru
%%DATADIR%%/modules/logs/logs.rb
@@ -223,11 +234,23 @@ sbin/smart-proxy
%%DATADIR%%/modules/puppet_proxy_ssh/puppet_proxy_ssh.rb
%%DATADIR%%/modules/puppet_proxy_ssh/puppet_proxy_ssh_main.rb
%%DATADIR%%/modules/puppet_proxy_ssh/puppet_proxy_ssh_plugin.rb
+%%DATADIR%%/modules/puppetca/dependency_injection.rb
%%DATADIR%%/modules/puppetca/http_config.ru
+%%DATADIR%%/modules/puppetca/plugin_configuration.rb
%%DATADIR%%/modules/puppetca/puppetca.rb
%%DATADIR%%/modules/puppetca/puppetca_api.rb
-%%DATADIR%%/modules/puppetca/puppetca_main.rb
%%DATADIR%%/modules/puppetca/puppetca_plugin.rb
+%%DATADIR%%/modules/puppetca/puppetca_puppet_cert.rb
+%%DATADIR%%/modules/puppetca_hostname_whitelisting/plugin_configuration.rb
+%%DATADIR%%/modules/puppetca_hostname_whitelisting/puppetca_hostname_whitelisting.rb
+%%DATADIR%%/modules/puppetca_hostname_whitelisting/puppetca_hostname_whitelisting_autosigner.rb
+%%DATADIR%%/modules/puppetca_hostname_whitelisting/puppetca_hostname_whitelisting_plugin.rb
+%%DATADIR%%/modules/puppetca_token_whitelisting/plugin_configuration.rb
+%%DATADIR%%/modules/puppetca_token_whitelisting/puppetca_token_whitelisting.rb
+%%DATADIR%%/modules/puppetca_token_whitelisting/puppetca_token_whitelisting_autosigner.rb
+%%DATADIR%%/modules/puppetca_token_whitelisting/puppetca_token_whitelisting_csr.rb
+%%DATADIR%%/modules/puppetca_token_whitelisting/puppetca_token_whitelisting_plugin.rb
+%%DATADIR%%/modules/puppetca_token_whitelisting/puppetca_token_whitelisting_token_storage.rb
%%DATADIR%%/modules/realm/configuration_loader.rb
%%DATADIR%%/modules/realm/dependency_injection.rb
%%DATADIR%%/modules/realm/http_config.ru