aboutsummaryrefslogtreecommitdiff
path: root/net/foreman-proxy
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2014-12-04 10:45:24 +0000
committerMartin Matuska <mm@FreeBSD.org>2014-12-04 10:45:24 +0000
commitf9660f7fba8cecfeb1b3ab7c45cfba48be361e95 (patch)
tree5ae06c90c6a61ada10bf8d0d352779ffe6c16276 /net/foreman-proxy
parent7b2c89c91c6ee16c4fa11ce647dc56d2ec021570 (diff)
downloadports-f9660f7fba8cecfeb1b3ab7c45cfba48be361e95.tar.gz
ports-f9660f7fba8cecfeb1b3ab7c45cfba48be361e95.zip
Update foreman-proxy to 1.7.0
Notes
Notes: svn path=/head/; revision=373877
Diffstat (limited to 'net/foreman-proxy')
-rw-r--r--net/foreman-proxy/Makefile8
-rw-r--r--net/foreman-proxy/distinfo4
-rw-r--r--net/foreman-proxy/files/patch-bin-smart-proxy12
-rw-r--r--net/foreman-proxy/files/patch-config-settings.d-chef.yml.example8
-rw-r--r--net/foreman-proxy/files/patch-config-settings.d-puppet.yml.example12
-rw-r--r--net/foreman-proxy/files/patch-config-settings.yml.example11
-rw-r--r--net/foreman-proxy/pkg-plist43
7 files changed, 53 insertions, 45 deletions
diff --git a/net/foreman-proxy/Makefile b/net/foreman-proxy/Makefile
index 0edd7b85d67d..3357fcbefef8 100644
--- a/net/foreman-proxy/Makefile
+++ b/net/foreman-proxy/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= foreman-proxy
-PORTVERSION= 1.6.2
+PORTVERSION= 1.7.0
CATEGORIES= net
MASTER_SITES= GH
@@ -13,7 +13,7 @@ LICENSE= GPLv3
RUN_DEPENDS= rubygem-bundler_ext>=0.4:${PORTSDIR}/sysutils/rubygem-bundler_ext \
rubygem-json>=1.8.1:${PORTSDIR}/devel/rubygem-json \
- rubygem-rack>=1.1:${PORTSDIR}/www/rubygem-rack \
+ rubygem-rack>=1.4:${PORTSDIR}/www/rubygem-rack \
rubygem-sinatra>=1.4.3:${PORTSDIR}/www/rubygem-sinatra \
${LOCALBASE}/bin/wget:${PORTSDIR}/ftp/wget
@@ -24,7 +24,7 @@ PUPPET_DESC= Depend on Puppet
USE_GITHUB= yes
GH_ACCOUNT= theforeman
GH_PROJECT= smart-proxy
-GH_COMMIT= b53b4d0
+GH_COMMIT= eaa557d
USE_RUBY= yes
USE_RAKE= yes
USE_RC_SUBR= foreman-proxy
@@ -82,7 +82,7 @@ do-install:
.endfor
${INSTALL_DATA} ${WRKSRC}/config/settings.yml.example \
${STAGEDIR}${PREFIX}/etc/foreman-proxy/settings.yml.sample
-.for cfg in bmc chef dhcp dns puppet puppetca realm tftp
+.for cfg in bmc dhcp dns facts puppet puppetca realm templates tftp
${INSTALL_DATA} ${WRKSRC}/config/settings.d/${cfg}.yml.example \
${STAGEDIR}${PREFIX}/etc/foreman-proxy/settings.d/${cfg}.yml.sample
.endfor
diff --git a/net/foreman-proxy/distinfo b/net/foreman-proxy/distinfo
index 8da2c50dfa48..d20dee224a4f 100644
--- a/net/foreman-proxy/distinfo
+++ b/net/foreman-proxy/distinfo
@@ -1,2 +1,2 @@
-SHA256 (foreman-proxy-1.6.2.tar.gz) = 5dac214d0a3e1c5dda9d82ffb48a3c05efbb780f82fd35ee8a5f2c8335be3771
-SIZE (foreman-proxy-1.6.2.tar.gz) = 107543
+SHA256 (foreman-proxy-1.7.0.tar.gz) = d27c834e024c64672ab8363100abce963e89d87e1e27f172d6798bc7f98983e7
+SIZE (foreman-proxy-1.7.0.tar.gz) = 112923
diff --git a/net/foreman-proxy/files/patch-bin-smart-proxy b/net/foreman-proxy/files/patch-bin-smart-proxy
index d0f879569bad..167ba1b59a3f 100644
--- a/net/foreman-proxy/files/patch-bin-smart-proxy
+++ b/net/foreman-proxy/files/patch-bin-smart-proxy
@@ -1,10 +1,10 @@
---- bin/smart-proxy.orig 2014-09-27 09:46:43.550292207 +0200
-+++ bin/smart-proxy 2014-09-27 09:46:48.536355156 +0200
-@@ -1,6 +1,6 @@
+--- bin/smart-proxy.orig 2014-12-04 11:24:23.964747068 +0100
++++ bin/smart-proxy 2014-12-04 11:24:26.244762141 +0100
+@@ -1,6 +1,7 @@
#!/usr/bin/env ruby
--$LOAD_PATH.unshift *Dir[File.expand_path("../../lib", __FILE__), File.expand_path("../../modules", __FILE__)]
-+$LOAD_PATH.unshift *Dir["%%DATADIR%%/lib", "%%DATADIR%%/modules"]
+ $LOAD_PATH.unshift(*Dir[File.expand_path("../../lib", __FILE__), File.expand_path("../../modules", __FILE__)])
++$LOAD_PATH.unshift(*Dir["%%DATADIR%%/lib", "%%DATADIR%%/modules"])
require 'smart_proxy'
- Proxy::Launcher.launch
+ Proxy::Launcher.new.launch
diff --git a/net/foreman-proxy/files/patch-config-settings.d-chef.yml.example b/net/foreman-proxy/files/patch-config-settings.d-chef.yml.example
deleted file mode 100644
index 36cb129b4480..000000000000
--- a/net/foreman-proxy/files/patch-config-settings.d-chef.yml.example
+++ /dev/null
@@ -1,8 +0,0 @@
---- config/settings.d/chef.yml.example.orig 2014-09-27 09:04:18.593468858 +0200
-+++ config/settings.d/chef.yml.example 2014-09-27 09:04:57.195544853 +0200
-@@ -5,4 +5,4 @@
- # smart-proxy client node needs to have some admin right on chef-server
- # in order to retrive all nodes public keys
- # :chef_smartproxy_clientname: 'host.example.net'
--# :chef_smartproxy_privatekey: '/etc/chef/client.pem'
-+# :chef_smartproxy_privatekey: '%%LOCALBASE%%/etc/chef/client.pem'
diff --git a/net/foreman-proxy/files/patch-config-settings.d-puppet.yml.example b/net/foreman-proxy/files/patch-config-settings.d-puppet.yml.example
index b4d36256201d..c9a9e87ef22f 100644
--- a/net/foreman-proxy/files/patch-config-settings.d-puppet.yml.example
+++ b/net/foreman-proxy/files/patch-config-settings.d-puppet.yml.example
@@ -1,6 +1,6 @@
---- config/settings.d/puppet.yml.example.orig 2014-09-27 09:04:06.613473296 +0200
-+++ config/settings.d/puppet.yml.example 2014-09-27 09:13:36.804706968 +0200
-@@ -10,19 +10,19 @@
+--- config/settings.d/puppet.yml.example.orig 2014-12-02 11:27:28.000000000 +0100
++++ config/settings.d/puppet.yml.example 2014-12-04 11:27:31.399941182 +0100
+@@ -10,23 +10,23 @@
# Customrun command details
# Set :customrun_cmd to the full path of the script you want to run, instead of /bin/false
@@ -17,6 +17,10 @@
# the command which will be sent to the host
-:puppetssh_command: /usr/bin/puppet agent --onetime --no-usecacheonfailure
+:puppetssh_command: %%LOCALBASE%%/bin/puppet agent --onetime --no-usecacheonfailure
+ # wait for the command to finish (and capture exit code), or detach process and return 0
+ # Note: enabling this option causes the Foreman web UI to be blocked when executing puppetrun,
+ # with timeout from the Browser and/or Foreman's REST client after 60 seconds.
+ :puppetssh_wait: false
# With which user should the proxy connect
#:puppetssh_user: root
-#:puppetssh_keyfile: /etc/foreman-proxy/id_rsa
@@ -24,7 +28,7 @@
# Which user to invoke sudo as to run puppet commands
#:puppet_user: root
-@@ -30,9 +30,9 @@
+@@ -34,9 +34,9 @@
# URL of the puppet master itself for API requests
#:puppet_url: https://puppet.example.com:8140
# SSL certificates used to access the puppet master API
diff --git a/net/foreman-proxy/files/patch-config-settings.yml.example b/net/foreman-proxy/files/patch-config-settings.yml.example
new file mode 100644
index 000000000000..7b44082317de
--- /dev/null
+++ b/net/foreman-proxy/files/patch-config-settings.yml.example
@@ -0,0 +1,11 @@
+--- config/settings.yml.example.orig 2014-12-04 11:41:56.011675735 +0100
++++ config/settings.yml.example 2014-12-04 11:42:13.978674196 +0100
+@@ -25,7 +25,7 @@
+ #:foreman_ssl_key: ssl/private_keys/fqdn.pem
+
+ # by default smart_proxy runs in the foreground. To enable running as a daemon, uncomment 'daemon' setting
+-#:daemon: true
++:daemon: true
+ # Only used when 'daemon' is set to true.
+ # Uncomment and modify if you want to change the default pid file '/var/run/foreman-proxy/foreman-proxy.pid'
+ #:daemon_pid: /var/run/foreman-proxy/foreman-proxy.pid
diff --git a/net/foreman-proxy/pkg-plist b/net/foreman-proxy/pkg-plist
index 4e05284c2ecd..af9521d5d579 100644
--- a/net/foreman-proxy/pkg-plist
+++ b/net/foreman-proxy/pkg-plist
@@ -1,12 +1,13 @@
sbin/smart-proxy
@sample etc/foreman-proxy/settings.yml.sample
@sample etc/foreman-proxy/settings.d/bmc.yml.sample
-@sample etc/foreman-proxy/settings.d/chef.yml.sample
@sample etc/foreman-proxy/settings.d/dhcp.yml.sample
@sample etc/foreman-proxy/settings.d/dns.yml.sample
+@sample etc/foreman-proxy/settings.d/facts.yml.sample
@sample etc/foreman-proxy/settings.d/puppet.yml.sample
@sample etc/foreman-proxy/settings.d/puppetca.yml.sample
@sample etc/foreman-proxy/settings.d/realm.yml.sample
+@sample etc/foreman-proxy/settings.d/templates.yml.sample
@sample etc/foreman-proxy/settings.d/tftp.yml.sample
%%DATADIR%%/CHANGELOG
%%DATADIR%%/Contributors
@@ -17,7 +18,6 @@ sbin/smart-proxy
%%DATADIR%%/Rakefile
%%DATADIR%%/VERSION
%%DATADIR%%/bundler.d/bmc.rb
-%%DATADIR%%/bundler.d/chef.rb
%%DATADIR%%/bundler.d/development.rb
%%DATADIR%%/bundler.d/krb5.rb
%%DATADIR%%/bundler.d/puppet.rb
@@ -29,6 +29,7 @@ sbin/smart-proxy
%%DATADIR%%/lib/bundler_helper.rb
%%DATADIR%%/lib/checks.rb
%%DATADIR%%/lib/daemon.rb
+%%DATADIR%%/lib/poodles-fix.rb
%%DATADIR%%/lib/proxy/error.rb
%%DATADIR%%/lib/proxy/helpers.rb
%%DATADIR%%/lib/proxy/http_downloads.rb
@@ -56,25 +57,20 @@ sbin/smart-proxy
%%DATADIR%%/modules/bmc/http_config.ru
%%DATADIR%%/modules/bmc/ipmi.rb
%%DATADIR%%/modules/bmc/shell.rb
-%%DATADIR%%/modules/chef_proxy/authentication.rb
-%%DATADIR%%/modules/chef_proxy/chef.rb
-%%DATADIR%%/modules/chef_proxy/chef_api.rb
-%%DATADIR%%/modules/chef_proxy/chef_plugin.rb
-%%DATADIR%%/modules/chef_proxy/http_config.ru
-%%DATADIR%%/modules/dhcp/dhcp/dhcp_api.rb
-%%DATADIR%%/modules/dhcp/dhcp/dhcp_plugin.rb
-%%DATADIR%%/modules/dhcp/dhcp/http_config.ru
-%%DATADIR%%/modules/dhcp/dhcp/monkey_patch_subnet.rb
-%%DATADIR%%/modules/dhcp/dhcp/monkey_patches.rb
-%%DATADIR%%/modules/dhcp/dhcp/providers/server/isc.rb
-%%DATADIR%%/modules/dhcp/dhcp/providers/server/ms.rb
-%%DATADIR%%/modules/dhcp/dhcp/providers/server/native_ms.rb
-%%DATADIR%%/modules/dhcp/dhcp/providers/server/virsh.rb
-%%DATADIR%%/modules/dhcp/dhcp/record/lease.rb
-%%DATADIR%%/modules/dhcp/dhcp/record/reservation.rb
-%%DATADIR%%/modules/dhcp/dhcp/record.rb
-%%DATADIR%%/modules/dhcp/dhcp/server.rb
-%%DATADIR%%/modules/dhcp/dhcp/subnet.rb
+%%DATADIR%%/modules/dhcp/dhcp_api.rb
+%%DATADIR%%/modules/dhcp/dhcp_plugin.rb
+%%DATADIR%%/modules/dhcp/http_config.ru
+%%DATADIR%%/modules/dhcp/monkey_patch_subnet.rb
+%%DATADIR%%/modules/dhcp/monkey_patches.rb
+%%DATADIR%%/modules/dhcp/providers/server/isc.rb
+%%DATADIR%%/modules/dhcp/providers/server/ms.rb
+%%DATADIR%%/modules/dhcp/providers/server/native_ms.rb
+%%DATADIR%%/modules/dhcp/providers/server/virsh.rb
+%%DATADIR%%/modules/dhcp/record/lease.rb
+%%DATADIR%%/modules/dhcp/record/reservation.rb
+%%DATADIR%%/modules/dhcp/record.rb
+%%DATADIR%%/modules/dhcp/server.rb
+%%DATADIR%%/modules/dhcp/subnet.rb
%%DATADIR%%/modules/dhcp/dhcp.rb
%%DATADIR%%/modules/dns/dns.rb
%%DATADIR%%/modules/dns/dns_api.rb
@@ -120,6 +116,11 @@ sbin/smart-proxy
%%DATADIR%%/modules/root/root.rb
%%DATADIR%%/modules/root/root_api.rb
%%DATADIR%%/modules/root/root_plugin.rb
+%%DATADIR%%/modules/templates/handler.rb
+%%DATADIR%%/modules/templates/http_config.ru
+%%DATADIR%%/modules/templates/templates.rb
+%%DATADIR%%/modules/templates/templates_api.rb
+%%DATADIR%%/modules/templates/templates_plugin.rb
%%DATADIR%%/modules/tftp/http_config.ru
%%DATADIR%%/modules/tftp/server.rb
%%DATADIR%%/modules/tftp/tftp.rb