aboutsummaryrefslogtreecommitdiff
path: root/net/freeradius3
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2018-05-17 14:35:53 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2018-05-17 14:35:53 +0000
commit81f2958180cd1ab4f914ffc7200455f8c51e5fcf (patch)
tree85cb6e574f1e63321087562f72811db37a538b20 /net/freeradius3
parent2752c0f4c4ba6371b39fd8a2f17edd2f442a0549 (diff)
downloadports-81f2958180cd1ab4f914ffc7200455f8c51e5fcf.tar.gz
ports-81f2958180cd1ab4f914ffc7200455f8c51e5fcf.zip
- Add OPTION for native winbind support for the rlm_mschap module
Notes
Notes: svn path=/head/; revision=470220
Diffstat (limited to 'net/freeradius3')
-rw-r--r--net/freeradius3/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/net/freeradius3/Makefile b/net/freeradius3/Makefile
index 602abad9e91a..9d89619c3695 100644
--- a/net/freeradius3/Makefile
+++ b/net/freeradius3/Makefile
@@ -45,7 +45,8 @@ _REQUIRE= NETWORKING SERVERS
OPTIONS_SUB= yes
OPTIONS_DEFINE= USER LDAP MYSQL PGSQL UNIXODBC FIREBIRD REDIS \
EXPERIMENTAL UDPFROMTO DEVELOPER EDIR PERL REST \
- FREETDS IDN DOCS SQLITE3 PYTHON RUBY UNBOUND PCRE
+ FREETDS IDN DOCS SQLITE3 PYTHON RUBY UNBOUND PCRE \
+ WINBIND
OPTIONS_DEFAULT=USER PERL HEIMDAL UDPFROMTO
OPTIONS_SINGLE= KRB
OPTIONS_SINGLE_KRB= NOKRB HEIMDAL HEIMDAL_PORT MITKRB_PORT
@@ -64,6 +65,7 @@ UDPFROMTO_DESC= Compile in UDPFROMTO support
DEVELOPER_DESC= Enable developer options
EDIR_DESC= Enable eDirectory support (implies LDAP)
REST_DESC= Enable RESTful API support
+WINBIND_DESC= Enable native winbind support in rlm_mschap
EDIR_CONFIGURE_WITH= edir
EDIR_IMPLIES= LDAP
@@ -122,6 +124,9 @@ UNBOUND_CONFIGURE_WITH= rlm_unbound
UNBOUND_LIB_DEPENDS= libunbound.so:dns/unbound
UNIXODBC_CONFIGURE_WITH= rlm_sql_unixodbc
UNIXODBC_LIB_DEPENDS= libodbc.so:databases/unixODBC
+WINBIND_USES= samba:build,lib
+WINBIND_CONFIGURE_ON= --with-winbind-include-dir=${LOCALBASE}/include/samba4 \
+ --with-winbind-lib-dir=${LOCALBASE}/lib/samba4
.include <bsd.port.options.mk>