aboutsummaryrefslogtreecommitdiff
path: root/net/freeradius3
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2020-09-24 22:20:29 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2020-09-24 22:20:29 +0000
commitaae2e4b6606b5a6e03e8bc1eb46f4902eeb2a4ee (patch)
treea51ef1c999fbf60623483bc541bc1be3830f06d3 /net/freeradius3
parenta91e41a00ab6c44374a434cee38b21e5dc5b0e68 (diff)
downloadports-aae2e4b6606b5a6e03e8bc1eb46f4902eeb2a4ee.tar.gz
ports-aae2e4b6606b5a6e03e8bc1eb46f4902eeb2a4ee.zip
- Convert PYTHON support to use python 3.x
- Add note to UPDATING PR: 249743 Submitted by: Steve Wills <swills@FreeBSD.org>
Notes
Notes: svn path=/head/; revision=549967
Diffstat (limited to 'net/freeradius3')
-rw-r--r--net/freeradius3/Makefile14
-rw-r--r--net/freeradius3/pkg-plist10
2 files changed, 13 insertions, 11 deletions
diff --git a/net/freeradius3/Makefile b/net/freeradius3/Makefile
index dacb4d467b11..bbebcb6f1bf7 100644
--- a/net/freeradius3/Makefile
+++ b/net/freeradius3/Makefile
@@ -3,7 +3,7 @@
PORTNAME= freeradius
DISTVERSION= 3.0.21
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ftp://ftp.freeradius.org/pub/freeradius/%SUBDIR%/ \
ftp://ftp.ntua.gr/pub/net/radius/freeradius/%SUBDIR%/ \
@@ -32,6 +32,7 @@ USE_RC_SUBR= radiusd
SHEBANG_FILES= src/modules/rlm_counter/rad_counter scripts/sql/radsqlrelay
GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--without-rlm_python
# Prevent /root/.rnd leftover
MAKE_ARGS+= HOME=/dev/null
CPPFLAGS+= -I${LOCALBASE}/include
@@ -102,11 +103,12 @@ PERL_USES= perl5
PGSQL_USES= pgsql
PGSQL_VARS= _REQUIRE+=postgresql
PGSQL_CONFIGURE_WITH= rlm_sql_postgresql
-PYTHON_CONFIGURE_WITH= rlm_python
-PYTHON_CONFIGURE_ON= --with-rlm-python-lib-dir=${PYTHON_LIBDIR} \
- --with-rlm-python-include-dir=${PYTHON_INCLUDEDIR}
-PYTHON_USES= python:2.7 gettext-runtime
-PYTHON_VARS= SHEBANG_FILES+=src/modules/rlm_python/*.py
+PYTHON_CONFIGURE_WITH= rlm_python3
+PYTHON_CONFIGURE_ON= --with-rlm-python3-lib-dir=${PYTHON_LIBDIR} \
+ --with-rlm-python3-config-bin=${PYTHON_CMD}-config \
+ --with-rlm-python3-include-dir=${PYTHON_INCLUDEDIR}
+PYTHON_USES= python gettext-runtime
+PYTHON_VARS= SHEBANG_FILES+=src/modules/rlm_python3/*.py
REDIS_CONFIGURE_WITH= rlm_redis rlm_rediswho
REDIS_LIB_DEPENDS= libhiredis.so:databases/hiredis
REST_CONFIGURE_WITH= rlm_rest
diff --git a/net/freeradius3/pkg-plist b/net/freeradius3/pkg-plist
index 5491ee308f94..ae3bdcd85b20 100644
--- a/net/freeradius3/pkg-plist
+++ b/net/freeradius3/pkg-plist
@@ -226,9 +226,9 @@ include/freeradius/vqp.h
%%LIBDIR%%/rlm_preprocess.a
%%LIBDIR%%/rlm_preprocess.la
%%LIBDIR%%/rlm_preprocess.so
-%%PYTHON%%%%LIBDIR%%/rlm_python.a
-%%PYTHON%%%%LIBDIR%%/rlm_python.la
-%%PYTHON%%%%LIBDIR%%/rlm_python.so
+%%PYTHON%%%%LIBDIR%%/rlm_python3.a
+%%PYTHON%%%%LIBDIR%%/rlm_python3.la
+%%PYTHON%%%%LIBDIR%%/rlm_python3.so
%%LIBDIR%%/rlm_radutmp.a
%%LIBDIR%%/rlm_radutmp.la
%%LIBDIR%%/rlm_radutmp.so
@@ -612,8 +612,8 @@ sbin/radmin
%%PERL%%%%EXAMPLESDIR%%/raddb/mods-config/perl/example.pl
%%EXAMPLESDIR%%/raddb/mods-config/preprocess/hints
%%EXAMPLESDIR%%/raddb/mods-config/preprocess/huntgroups
-%%PYTHON%%%%EXAMPLESDIR%%/raddb/mods-config/python/example.py
-%%PYTHON%%%%EXAMPLESDIR%%/raddb/mods-config/python/radiusd.py
+%%PYTHON%%%%EXAMPLESDIR%%/raddb/mods-config/python3/example.py
+%%PYTHON%%%%EXAMPLESDIR%%/raddb/mods-config/python3/radiusd.py
%%EXAMPLESDIR%%/raddb/mods-config/sql/counter/mysql/dailycounter.conf
%%EXAMPLESDIR%%/raddb/mods-config/sql/counter/mysql/expire_on_login.conf
%%EXAMPLESDIR%%/raddb/mods-config/sql/counter/mysql/monthlycounter.conf