aboutsummaryrefslogtreecommitdiff
path: root/net/freeradius
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-15 14:55:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-15 14:55:38 +0000
commitedd5b378404de2dc5a6a91483d88f8ebdb1cd8fa (patch)
treeab79cf1fb4ef1e37b908972a9d373f18f62901de /net/freeradius
parent42ed8c136edaedec0b7c8b4d0c55690561c44cb3 (diff)
downloadports-edd5b378404de2dc5a6a91483d88f8ebdb1cd8fa.tar.gz
ports-edd5b378404de2dc5a6a91483d88f8ebdb1cd8fa.zip
Notes
Diffstat (limited to 'net/freeradius')
-rw-r--r--net/freeradius/Makefile48
-rw-r--r--net/freeradius/distinfo6
-rw-r--r--net/freeradius/files/patch-raddb-Makefile-1.1.4_bug11
-rw-r--r--net/freeradius/pkg-descr38
-rw-r--r--net/freeradius/pkg-plist6
5 files changed, 67 insertions, 42 deletions
diff --git a/net/freeradius/Makefile b/net/freeradius/Makefile
index 1ee3593bc015..f11514b8c0bc 100644
--- a/net/freeradius/Makefile
+++ b/net/freeradius/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= freeradius
-PORTVERSION= 1.1.3
-PORTREVISION= 1
+PORTVERSION= 1.1.4
CATEGORIES= net
MASTER_SITES= ftp://ftp.freeradius.org/pub/radius/ \
ftp://ftp.ntua.gr/pub/net/radius/freeradius/ \
@@ -27,10 +26,9 @@ CONFLICTS= gnu-radius-1.* openradius-0.* radiusd-cistron-1.*
USE_RC_SUBR= radiusd.sh
USE_AUTOTOOLS= libltdl:15 libtool:15
USE_GMAKE= yes
-USE_PERL5= yes
USE_OPENSSL= yes
MAKE_ARGS+= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-CFLAGS+= "-I${LOCALBASE}/include"
+CFLAGS+= -I${LOCALBASE}/include
PLIST_SUB= PORTVERSION=${PORTVERSION}
@@ -40,6 +38,8 @@ OPTIONS= KERBEROS "With Kerberos support" off \
MYSQL "With MySQL user database" off \
PGSQL "With PostgreSQL use database" off \
SNMP "With SNMP support" off \
+ EDIR "With Novell eDirectory support" off \
+ NOPERL "Do not require perl (use only if necessary)" off \
EXPERIMENTAL "Build experimental modules" off
.include <bsd.port.pre.mk>
@@ -49,6 +49,7 @@ CONFIGURE_ARGS= --prefix=${PREFIX} --quiet --with-logdir=${LOGDIR} \
--with-system-libtool \
--disable-ltdl-install \
--with-docdir=${DOCSDIR} \
+ --mandir=${PREFIX}/man \
--with-large-files --without-rlm_sql_unixodbc \
--without-rlm_sql_oracle --without-rlm_sql_iodbc \
--without-rlm_sql_db2 \
@@ -84,6 +85,10 @@ CONFIGURE_ARGS+=--without-rlm_krb5
PLIST_SUB+= KRB5="@comment "
.endif
+.if defined(WITH_EDIR) && !defined(WITH_LDAP)
+WITH_LDAP= yes
+.endif
+
.ifdef(WITH_LDAP)
USE_OPENLDAP= YES
PLIST_SUB+= LDAP=""
@@ -92,6 +97,10 @@ CONFIGURE_ARGS+=--without-rlm_ldap
PLIST_SUB+= LDAP="@comment "
.endif
+.ifdef(WITH_EDIR)
+CONFIGURE_ARGS+=--with-edir
+.endif
+
.ifdef(WITH_MYSQL)
USE_MYSQL= YES
PLIST_SUB+= MYSQL=""
@@ -124,21 +133,23 @@ PLIST_SUB+= EXPM=""
PLIST_SUB+= EXPM="@comment "
.endif
-.if defined(NOPORTDOCS)
-MAKE_ENV+= NOPORTDOCS=yes
+.ifndef(WITH_NOPERL)
+USE_PERL5= yes
.endif
-# rlm_x99_token seems broken
-#CONFIGURE_ARGS+=--without-rlm_x99_token
-PLIST_SUB+= TOKEN=""
-
# rlm_perl does not build on 4.x
-.if ${OSVERSION} < 500000
+.if ${OSVERSION} < 500000 || defined(WITH_NOPERL)
+CONFIGURE_ARGS+=--without-rlm_perl
PLIST_SUB+= RLMPERL="@comment "
.else
+CONFIGURE_ARGS+=--with-rlm_perl
PLIST_SUB+= RLMPERL=""
.endif
+.if defined(NOPORTDOCS)
+MAKE_ENV+= NOPORTDOCS=yes
+.endif
+
USE_LDCONFIG= yes
MAN1= radclient.1 radeapclient.1 radlast.1 radtest.1 radwho.1 \
@@ -152,13 +163,13 @@ MAN8= radiusd.8 radrelay.8 radsqlrelay.8 radwatch.8 rlm_ippool_tool.8
DICTS= dictionary.3com dictionary.3gpp dictionary.3gpp2 dictionary.acc \
dictionary.airespace dictionary.alcatel dictionary.alteon \
- dictionary.alvarion dictionary.altiga dictionary.aptis \
+ dictionary.altiga dictionary.alvarion dictionary.aptis \
dictionary.aruba dictionary.ascend dictionary.avaya \
dictionary.bay dictionary.bintec dictionary.bristol \
dictionary.cablelabs dictionary.cabletron dictionary.cisco \
dictionary.cisco.bbsm dictionary.cisco.vpn3000 dictionary.cisco.vpn5000 \
dictionary.colubris dictionary.columbia_university dictionary.compat \
- dictionary.cosine dictionary.digest dictionary.digium dictionary.epygi \
+ dictionary.cosine dictionary.digium dictionary.epygi \
dictionary.ericsson dictionary.erx dictionary.extreme \
dictionary.fortinet dictionary.foundry dictionary.freeradius \
dictionary.freeradius.internal dictionary.gandalf dictionary.garderos \
@@ -168,12 +179,15 @@ DICTS= dictionary.3com dictionary.3gpp dictionary.3gpp2 dictionary.acc \
dictionary.merit dictionary.microsoft dictionary.mikrotik \
dictionary.motorola dictionary.navini dictionary.netscreen \
dictionary.nokia dictionary.nomadix dictionary.nortel dictionary.ntua \
- dictionary.packeteer dictionary.propel dictionary.quintum \
- dictionary.redback dictionary.redcreek dictionary.riverstone \
+ dictionary.packeteer dictionary.patton \
+ dictionary.propel dictionary.quintum \
+ dictionary.redback dictionary.redcreek \
dictionary.rfc2865 dictionary.rfc2866 dictionary.rfc2867 \
dictionary.rfc2868 dictionary.rfc2869 dictionary.rfc3162 \
- dictionary.rfc3576 dictionary.rfc3580 dictionary.roaringpenguin \
- dictionary.shasta dictionary.shiva dictionary.sonicwall \
+ dictionary.rfc3576 dictionary.rfc3580 dictionary.rfc4590 \
+ dictionary.riverstone dictionary.roaringpenguin \
+ dictionary.schulzrinne-sipping dictionary.shasta dictionary.shiva \
+ dictionary.sofaware dictionary.sonicwall \
dictionary.springtide dictionary.starent dictionary.t_systems_nova \
dictionary.telebit dictionary.trapeze dictionary.tropos \
dictionary.unix dictionary.usr dictionary.valemount \
diff --git a/net/freeradius/distinfo b/net/freeradius/distinfo
index 9df573c78b73..70c72e4a3f74 100644
--- a/net/freeradius/distinfo
+++ b/net/freeradius/distinfo
@@ -1,3 +1,3 @@
-MD5 (freeradius-1.1.3.tar.gz) = d8724cdc15bc23c330a7d3a2080829bd
-SHA256 (freeradius-1.1.3.tar.gz) = f615f67fb807494892015e671593801fe3ac30c04740cd1dc8d2f18fc218da35
-SIZE (freeradius-1.1.3.tar.gz) = 3068204
+MD5 (freeradius-1.1.4.tar.gz) = 0027d4cf8882bbafee30755a16632c6a
+SHA256 (freeradius-1.1.4.tar.gz) = 017fe27b59c8d16c61739cd8aec123150365f2885dfdf04d289bf3039f26f7e3
+SIZE (freeradius-1.1.4.tar.gz) = 3088835
diff --git a/net/freeradius/files/patch-raddb-Makefile-1.1.4_bug b/net/freeradius/files/patch-raddb-Makefile-1.1.4_bug
new file mode 100644
index 000000000000..b5e12cff72a3
--- /dev/null
+++ b/net/freeradius/files/patch-raddb-Makefile-1.1.4_bug
@@ -0,0 +1,11 @@
+--- raddb/Makefile.orig Mon Apr 10 19:53:20 2006
++++ raddb/Makefile Sun Jan 14 23:10:15 2007
+@@ -7,7 +7,7 @@
+ experimental.conf hints huntgroups ldap.attrmap \
+ mssql.conf naslist naspasswd oraclesql.conf postgresql.conf \
+ preproxy_users proxy.conf radiusd.conf realms snmp.conf \
+- sql.conf sqlippool.conf users otp.conf otppasswd.sample
++ sql.conf sqlippool.conf users otp.conf
+
+ all:
+
diff --git a/net/freeradius/pkg-descr b/net/freeradius/pkg-descr
index 044d72cbf88d..95f994c97924 100644
--- a/net/freeradius/pkg-descr
+++ b/net/freeradius/pkg-descr
@@ -1,24 +1,22 @@
- All code in this server was written from scratch.
- The server is mostly compatible with livingston radiusd-2.01
- (no menus or s/key support though) but with more feautures, such as:
+FreeRADIUS is the premiere open source RADIUS server. Based on current
+statistics, there are over 50,000 deployments of the software. These
+deployments include small sites with 10 users, large-scale enterprises with
+tens of thousands of users, and carrier-class deployments with over 10 million
+users. In total, the sites that we know are using FreeRADIUS support nearly
+100 million users. The only other servers that come close in terms of market
+share and/or number of sites are ACS and IAS.
- o Can limit max. number of simultaneous logins on a per-user basis!
- o Multiple DEFAULT entries, that can optionally fall-through.
- o In fact, every entry can fall-through
- o Deny/permit access based on huntgroup users dials into
- o Set certain parameters (such as static IP address) based on huntgroup
- o Extra "hints" file that can select SLIP/PPP/rlogin based on
- username pattern (Puser or user.ppp is PPP, plain "user" is rlogin etc).
- o Can execute an external program when user has authenticated (for example
- to run a sendmail queue).
- o Can use `$INCLUDE filename' in radiusd.conf, users, and dictionary files
- o Can act as a proxy server, relaying requests to a remote server
- o Supports Vendor-Specific attributes
- o No good documentation at all, just like the original radiusd 1.16!
+The server scales easily from embedded systems with small amounts of memory to
+systems with millions of users. It is fast, flexible, configurable, and
+supports more authentication protocols than most commercial servers. It
+includes support for SQL, LDAP, RADIUS Proxying, failover, load balancing, and
+nearly 100 vendor dictionary files. It can perform authentications via the
+PAP, CHAP, MS-CHAP, EAP-MD5, EAP-GTC, EAP-TLS, EAP-TTLS, PEAPv0, LEAP,
+EAP-SIM, and Digest authentication protocols. It has reached a stable 1.1
+version, with incremental improvements added in each release.
+
+The server is released under the GNU General Public License (GPL), which means
+that it is free to download and install.
- Then of course for general RADIUS questions, especially if you are using
- Livingston / Lucent RABU equipment, there is the portmaster-radius mailing
- list. Send mail to portmaster-radius-request@livingston.com to find
- out how to subscribe.
WWW: http://www.freeradius.org/
diff --git a/net/freeradius/pkg-plist b/net/freeradius/pkg-plist
index b6eb295a1bc1..a2af4a0847f1 100644
--- a/net/freeradius/pkg-plist
+++ b/net/freeradius/pkg-plist
@@ -47,7 +47,6 @@ etc/raddb/naslist.sample
etc/raddb/naspasswd.sample
etc/raddb/oraclesql.conf.sample
etc/raddb/otp.conf.sample
-etc/raddb/otppasswd.sample.sample
etc/raddb/postgresql.conf.sample
etc/raddb/preproxy_users.sample
etc/raddb/proxy.conf.sample
@@ -424,7 +423,6 @@ sbin/rc.radiusd
%%DATADIR%%/dictionary.columbia_university
%%DATADIR%%/dictionary.compat
%%DATADIR%%/dictionary.cosine
-%%DATADIR%%/dictionary.digest
%%DATADIR%%/dictionary.digium
%%DATADIR%%/dictionary.epygi
%%DATADIR%%/dictionary.ericsson
@@ -457,6 +455,7 @@ sbin/rc.radiusd
%%DATADIR%%/dictionary.nortel
%%DATADIR%%/dictionary.ntua
%%DATADIR%%/dictionary.packeteer
+%%DATADIR%%/dictionary.patton
%%DATADIR%%/dictionary.propel
%%DATADIR%%/dictionary.quintum
%%DATADIR%%/dictionary.redback
@@ -469,10 +468,13 @@ sbin/rc.radiusd
%%DATADIR%%/dictionary.rfc3162
%%DATADIR%%/dictionary.rfc3576
%%DATADIR%%/dictionary.rfc3580
+%%DATADIR%%/dictionary.rfc4590
%%DATADIR%%/dictionary.riverstone
%%DATADIR%%/dictionary.roaringpenguin
+%%DATADIR%%/dictionary.schulzrinne-sipping
%%DATADIR%%/dictionary.shasta
%%DATADIR%%/dictionary.shiva
+%%DATADIR%%/dictionary.sofaware
%%DATADIR%%/dictionary.sonicwall
%%DATADIR%%/dictionary.springtide
%%DATADIR%%/dictionary.starent