aboutsummaryrefslogtreecommitdiff
path: root/net/gkrellmmultiping2/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-08 07:25:51 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-08 07:25:51 +0000
commit3f17e38ea9dbd5a60aff8c3ffa5be6d95c8a28cc (patch)
treef6de804cc3feb4b1c48463bfef3b859731c63c84 /net/gkrellmmultiping2/Makefile
parentea162d38174c24a659b22f02aa69a6e2c8cc2992 (diff)
downloadports-3f17e38ea9dbd5a60aff8c3ffa5be6d95c8a28cc.tar.gz
ports-3f17e38ea9dbd5a60aff8c3ffa5be6d95c8a28cc.zip
Notes
Diffstat (limited to 'net/gkrellmmultiping2/Makefile')
-rw-r--r--net/gkrellmmultiping2/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/net/gkrellmmultiping2/Makefile b/net/gkrellmmultiping2/Makefile
new file mode 100644
index 000000000000..3d67579c45d9
--- /dev/null
+++ b/net/gkrellmmultiping2/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: gkrellmmultiping2
+# Date Created: 24 Nov 2002
+# Whom: Jean-Yves Lefort <jylefort@brutele.be>
+#
+# $FreeBSD$
+# $Id: Makefile,v 1.1.1.1 2002/11/24 23:19:28 jylefort Exp $
+#
+
+PORTNAME= gkrellmmultiping
+PORTVERSION= 2.0.3
+CATEGORIES= net
+MASTER_SITES= http://kmlinux.fjfi.cvut.cz/~makovick/gkrellm/
+DISTNAME= gkrellm-multiping-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= jylefort@brutele.be
+COMMENT= GKrellM multiping plugin
+
+BUILD_DEPENDS= ${X11BASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
+RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
+
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+
+MAKE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}" \
+ MKDIR="${MKDIR}" \
+ CHMOD="${CHMOD}" \
+ INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
+ INSTALL_DATA="${INSTALL_DATA}"
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ ${REINPLACE_CMD} -e \
+ "s,@COMMAND@,${PREFIX}/libexec/gkrellm2/plugins/pinger," \
+ ${WRKSRC}/multiping.c
+
+.include <bsd.port.post.mk>