aboutsummaryrefslogtreecommitdiff
path: root/net/gnome-netstatus
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-02-13 22:19:23 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-02-13 22:19:23 +0000
commitece2e2c2011abbbda47c065043cb2830e3c5b82d (patch)
treea11599352d6ef0a6efbd5ebdd17c44f1b6522319 /net/gnome-netstatus
parentf5de0573d49a06ad6ae04620367f35abb0630523 (diff)
downloadports-ece2e2c2011abbbda47c065043cb2830e3c5b82d.tar.gz
ports-ece2e2c2011abbbda47c065043cb2830e3c5b82d.zip
Notes
Diffstat (limited to 'net/gnome-netstatus')
-rw-r--r--net/gnome-netstatus/Makefile3
-rw-r--r--net/gnome-netstatus/distinfo6
-rw-r--r--net/gnome-netstatus/files/patch-src_netstatus-sysdeps.c37
-rw-r--r--net/gnome-netstatus/pkg-plist53
4 files changed, 75 insertions, 24 deletions
diff --git a/net/gnome-netstatus/Makefile b/net/gnome-netstatus/Makefile
index 79076bb715fd..78997b013267 100644
--- a/net/gnome-netstatus/Makefile
+++ b/net/gnome-netstatus/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= gnome-netstatus
-PORTVERSION= 2.12.0
-PORTREVISION= 3
+PORTVERSION= 2.12.1
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-netstatus/2.12
diff --git a/net/gnome-netstatus/distinfo b/net/gnome-netstatus/distinfo
index e35e5f4c0ae4..8297e98a7824 100644
--- a/net/gnome-netstatus/distinfo
+++ b/net/gnome-netstatus/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-netstatus-2.12.0.tar.bz2) = a5f23731a3bf232969e82afef8792a36
-SHA256 (gnome2/gnome-netstatus-2.12.0.tar.bz2) = 14118e71b852a77b9cb8cfe290598afb4d267cac4f6606c99b16b0b2fa807dc9
-SIZE (gnome2/gnome-netstatus-2.12.0.tar.bz2) = 473226
+MD5 (gnome2/gnome-netstatus-2.12.1.tar.bz2) = 8651ca1694a6c222ae5cad6e21814d24
+SHA256 (gnome2/gnome-netstatus-2.12.1.tar.bz2) = 4648439f0327963dcbbf2d07d2de1cf1ef74a7430bcbe175717efd0e7f7824ed
+SIZE (gnome2/gnome-netstatus-2.12.1.tar.bz2) = 500536
diff --git a/net/gnome-netstatus/files/patch-src_netstatus-sysdeps.c b/net/gnome-netstatus/files/patch-src_netstatus-sysdeps.c
index b674048d5ef2..de7d713c7bab 100644
--- a/net/gnome-netstatus/files/patch-src_netstatus-sysdeps.c
+++ b/net/gnome-netstatus/files/patch-src_netstatus-sysdeps.c
@@ -1,5 +1,5 @@
---- src/netstatus-sysdeps.c.orig Mon Mar 14 09:34:06 2005
-+++ src/netstatus-sysdeps.c Mon Jan 30 21:44:49 2006
+--- src/netstatus-sysdeps.c.orig Tue Feb 13 04:39:19 2007
++++ src/netstatus-sysdeps.c Tue Feb 13 17:16:29 2007
@@ -430,11 +430,11 @@ static inline char *
get_an_data (const char *iface,
int *signal_strength)
@@ -14,6 +14,39 @@
int level;
char *error = NULL;
gboolean rssimap_valid = FALSE;
+@@ -486,11 +486,11 @@ get_wi_data (const char *iface,
+ level = (int) wreq.wi_val[1];
+
+ #ifdef WI_RID_READ_APS
+- if (signal_strength <= 0)
++ if (*signal_strength <= 0)
+ {
+ /* we fail to get signal strength by usual means, try another way */
+ static time_t last_scan;
+- static long int cached;
++ static int cached;
+ time_t now;
+
+ now = time (NULL);
+@@ -510,15 +510,15 @@ get_wi_data (const char *iface,
+ if (nstations > 0)
+ {
+ w = (struct wi_apinfo *)(((char *) &wreq.wi_val) + sizeof (int));
+- signal_strength = (long int) w->signal;
++ level = w->signal;
+ }
+
+- cached = signal_strength;
++ cached = level;
+ last_scan = now;
+ }
+ else
+ {
+- signal_strength = cached;
++ level = cached;
+ }
+ }
+ #endif
@@ -548,6 +548,8 @@ netstatus_sysdeps_read_iface_wireless_de
g_strncasecmp (iface, "wi", 2) &&
g_strncasecmp (iface, "ath", 3) &&
diff --git a/net/gnome-netstatus/pkg-plist b/net/gnome-netstatus/pkg-plist
index e7d18bad3d1a..7096347702e0 100644
--- a/net/gnome-netstatus/pkg-plist
+++ b/net/gnome-netstatus/pkg-plist
@@ -4,6 +4,7 @@ share/gnome/gnome-2.0/ui/GNOME_NetstatusApplet.xml
share/gnome/gnome-netstatus/gnome-netstatus.glade
share/gnome/help/gnome-netstatus/C/gnome-netstatus.xml
share/gnome/help/gnome-netstatus/C/legal.xml
+share/gnome/help/gnome-netstatus/bg/gnome-netstatus.xml
share/gnome/help/gnome-netstatus/de/figures/gnome-netstatus-disconn.png
share/gnome/help/gnome-netstatus/de/figures/gnome-netstatus-error.png
share/gnome/help/gnome-netstatus/de/figures/gnome-netstatus-idle.png
@@ -13,14 +14,7 @@ share/gnome/help/gnome-netstatus/de/figures/gnome-netstatus-txrx.png
share/gnome/help/gnome-netstatus/de/gnome-netstatus.xml
share/gnome/help/gnome-netstatus/de/legal.xml
share/gnome/help/gnome-netstatus/es/gnome-netstatus.xml
-share/gnome/help/gnome-netstatus/fr/figures/gnome-netstatus-disconn.png
-share/gnome/help/gnome-netstatus/fr/figures/gnome-netstatus-error.png
-share/gnome/help/gnome-netstatus/fr/figures/gnome-netstatus-idle.png
-share/gnome/help/gnome-netstatus/fr/figures/gnome-netstatus-rx.png
-share/gnome/help/gnome-netstatus/fr/figures/gnome-netstatus-tx.png
-share/gnome/help/gnome-netstatus/fr/figures/gnome-netstatus-txrx.png
share/gnome/help/gnome-netstatus/fr/gnome-netstatus.xml
-share/gnome/help/gnome-netstatus/fr/legal.xml
share/gnome/help/gnome-netstatus/it/figures/gnome-netstatus-disconn.png
share/gnome/help/gnome-netstatus/it/figures/gnome-netstatus-error.png
share/gnome/help/gnome-netstatus/it/figures/gnome-netstatus-idle.png
@@ -45,14 +39,10 @@ share/gnome/help/gnome-netstatus/ko/figures/gnome-netstatus-tx.png
share/gnome/help/gnome-netstatus/ko/figures/gnome-netstatus-txrx.png
share/gnome/help/gnome-netstatus/ko/gnome-netstatus.xml
share/gnome/help/gnome-netstatus/ko/legal.xml
-share/gnome/help/gnome-netstatus/sv/figures/gnome-netstatus-disconn.png
-share/gnome/help/gnome-netstatus/sv/figures/gnome-netstatus-error.png
-share/gnome/help/gnome-netstatus/sv/figures/gnome-netstatus-idle.png
-share/gnome/help/gnome-netstatus/sv/figures/gnome-netstatus-rx.png
-share/gnome/help/gnome-netstatus/sv/figures/gnome-netstatus-tx.png
-share/gnome/help/gnome-netstatus/sv/figures/gnome-netstatus-txrx.png
+share/gnome/help/gnome-netstatus/nl/gnome-netstatus.xml
+share/gnome/help/gnome-netstatus/pa/gnome-netstatus.xml
+share/gnome/help/gnome-netstatus/ru/gnome-netstatus.xml
share/gnome/help/gnome-netstatus/sv/gnome-netstatus.xml
-share/gnome/help/gnome-netstatus/sv/legal.xml
share/gnome/help/gnome-netstatus/uk/gnome-netstatus.xml
share/gnome/help/gnome-netstatus/zh_CN/figures/gnome-netstatus-disconn.png
share/gnome/help/gnome-netstatus/zh_CN/figures/gnome-netstatus-error.png
@@ -79,12 +69,16 @@ share/gnome/help/gnome-netstatus/zh_TW/figures/gnome-netstatus-txrx.png
share/gnome/help/gnome-netstatus/zh_TW/gnome-netstatus.xml
share/gnome/help/gnome-netstatus/zh_TW/legal.xml
share/gnome/omf/gnome-netstatus/gnome-netstatus-C.omf
+share/gnome/omf/gnome-netstatus/gnome-netstatus-bg.omf
share/gnome/omf/gnome-netstatus/gnome-netstatus-de.omf
share/gnome/omf/gnome-netstatus/gnome-netstatus-es.omf
share/gnome/omf/gnome-netstatus/gnome-netstatus-fr.omf
share/gnome/omf/gnome-netstatus/gnome-netstatus-it.omf
share/gnome/omf/gnome-netstatus/gnome-netstatus-ja.omf
share/gnome/omf/gnome-netstatus/gnome-netstatus-ko.omf
+share/gnome/omf/gnome-netstatus/gnome-netstatus-nl.omf
+share/gnome/omf/gnome-netstatus/gnome-netstatus-pa.omf
+share/gnome/omf/gnome-netstatus/gnome-netstatus-ru.omf
share/gnome/omf/gnome-netstatus/gnome-netstatus-sv.omf
share/gnome/omf/gnome-netstatus/gnome-netstatus-uk.omf
share/gnome/omf/gnome-netstatus/gnome-netstatus-zh_CN.omf
@@ -105,12 +99,14 @@ share/locale/ar/LC_MESSAGES/gnome-netstatus.mo
share/locale/az/LC_MESSAGES/gnome-netstatus.mo
share/locale/bg/LC_MESSAGES/gnome-netstatus.mo
share/locale/bn/LC_MESSAGES/gnome-netstatus.mo
+share/locale/bn_IN/LC_MESSAGES/gnome-netstatus.mo
share/locale/bs/LC_MESSAGES/gnome-netstatus.mo
share/locale/ca/LC_MESSAGES/gnome-netstatus.mo
share/locale/cs/LC_MESSAGES/gnome-netstatus.mo
share/locale/cy/LC_MESSAGES/gnome-netstatus.mo
share/locale/da/LC_MESSAGES/gnome-netstatus.mo
share/locale/de/LC_MESSAGES/gnome-netstatus.mo
+share/locale/dz/LC_MESSAGES/gnome-netstatus.mo
share/locale/el/LC_MESSAGES/gnome-netstatus.mo
share/locale/en_CA/LC_MESSAGES/gnome-netstatus.mo
share/locale/en_GB/LC_MESSAGES/gnome-netstatus.mo
@@ -123,21 +119,28 @@ share/locale/fr/LC_MESSAGES/gnome-netstatus.mo
share/locale/ga/LC_MESSAGES/gnome-netstatus.mo
share/locale/gl/LC_MESSAGES/gnome-netstatus.mo
share/locale/gu/LC_MESSAGES/gnome-netstatus.mo
+share/locale/he/LC_MESSAGES/gnome-netstatus.mo
share/locale/hi/LC_MESSAGES/gnome-netstatus.mo
share/locale/hr/LC_MESSAGES/gnome-netstatus.mo
share/locale/hu/LC_MESSAGES/gnome-netstatus.mo
share/locale/id/LC_MESSAGES/gnome-netstatus.mo
share/locale/it/LC_MESSAGES/gnome-netstatus.mo
share/locale/ja/LC_MESSAGES/gnome-netstatus.mo
+share/locale/ka/LC_MESSAGES/gnome-netstatus.mo
share/locale/ko/LC_MESSAGES/gnome-netstatus.mo
share/locale/lt/LC_MESSAGES/gnome-netstatus.mo
+share/locale/lv/LC_MESSAGES/gnome-netstatus.mo
+share/locale/mg/LC_MESSAGES/gnome-netstatus.mo
+share/locale/mk/LC_MESSAGES/gnome-netstatus.mo
+share/locale/ml/LC_MESSAGES/gnome-netstatus.mo
share/locale/mn/LC_MESSAGES/gnome-netstatus.mo
+share/locale/mr/LC_MESSAGES/gnome-netstatus.mo
share/locale/ms/LC_MESSAGES/gnome-netstatus.mo
share/locale/nb/LC_MESSAGES/gnome-netstatus.mo
share/locale/ne/LC_MESSAGES/gnome-netstatus.mo
share/locale/nl/LC_MESSAGES/gnome-netstatus.mo
share/locale/nn/LC_MESSAGES/gnome-netstatus.mo
-share/locale/no/LC_MESSAGES/gnome-netstatus.mo
+share/locale/or/LC_MESSAGES/gnome-netstatus.mo
share/locale/pa/LC_MESSAGES/gnome-netstatus.mo
share/locale/pl/LC_MESSAGES/gnome-netstatus.mo
share/locale/pt/LC_MESSAGES/gnome-netstatus.mo
@@ -146,6 +149,7 @@ share/locale/ro/LC_MESSAGES/gnome-netstatus.mo
share/locale/ru/LC_MESSAGES/gnome-netstatus.mo
share/locale/rw/LC_MESSAGES/gnome-netstatus.mo
share/locale/sk/LC_MESSAGES/gnome-netstatus.mo
+share/locale/sl/LC_MESSAGES/gnome-netstatus.mo
share/locale/sq/LC_MESSAGES/gnome-netstatus.mo
share/locale/sr/LC_MESSAGES/gnome-netstatus.mo
share/locale/sr@Latn/LC_MESSAGES/gnome-netstatus.mo
@@ -158,6 +162,7 @@ share/locale/vi/LC_MESSAGES/gnome-netstatus.mo
share/locale/wa/LC_MESSAGES/gnome-netstatus.mo
share/locale/xh/LC_MESSAGES/gnome-netstatus.mo
share/locale/zh_CN/LC_MESSAGES/gnome-netstatus.mo
+share/locale/zh_HK/LC_MESSAGES/gnome-netstatus.mo
share/locale/zh_TW/LC_MESSAGES/gnome-netstatus.mo
@dirrm share/gnome/omf/gnome-netstatus
@dirrm share/gnome/help/gnome-netstatus/zh_TW/figures
@@ -167,24 +172,28 @@ share/locale/zh_TW/LC_MESSAGES/gnome-netstatus.mo
@dirrm share/gnome/help/gnome-netstatus/zh_CN/figures
@dirrm share/gnome/help/gnome-netstatus/zh_CN
@dirrm share/gnome/help/gnome-netstatus/uk
-@dirrm share/gnome/help/gnome-netstatus/sv/figures
@dirrm share/gnome/help/gnome-netstatus/sv
+@dirrm share/gnome/help/gnome-netstatus/ru
+@dirrm share/gnome/help/gnome-netstatus/pa
+@dirrm share/gnome/help/gnome-netstatus/nl
@dirrm share/gnome/help/gnome-netstatus/ko/figures
@dirrm share/gnome/help/gnome-netstatus/ko
@dirrm share/gnome/help/gnome-netstatus/ja/figures
@dirrm share/gnome/help/gnome-netstatus/ja
@dirrm share/gnome/help/gnome-netstatus/it/figures
@dirrm share/gnome/help/gnome-netstatus/it
-@dirrm share/gnome/help/gnome-netstatus/fr/figures
@dirrm share/gnome/help/gnome-netstatus/fr
@dirrm share/gnome/help/gnome-netstatus/es
@dirrm share/gnome/help/gnome-netstatus/de/figures
@dirrm share/gnome/help/gnome-netstatus/de
+@dirrm share/gnome/help/gnome-netstatus/bg
@dirrm share/gnome/help/gnome-netstatus/C
@dirrm share/gnome/help/gnome-netstatus
@dirrm share/gnome/gnome-netstatus
@dirrmtry share/locale/zh_TW/LC_MESSAGES
@dirrmtry share/locale/zh_TW
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/zh_CN/LC_MESSAGES
@dirrmtry share/locale/zh_CN
@dirrmtry share/locale/xh/LC_MESSAGES
@@ -193,6 +202,8 @@ share/locale/zh_TW/LC_MESSAGES/gnome-netstatus.mo
@dirrmtry share/locale/uk
@dirrmtry share/locale/sr/LC_MESSAGES
@dirrmtry share/locale/sr
+@dirrmtry share/locale/sl/LC_MESSAGES
+@dirrmtry share/locale/sl
@dirrmtry share/locale/sk/LC_MESSAGES
@dirrmtry share/locale/sk
@dirrmtry share/locale/rw/LC_MESSAGES
@@ -209,6 +220,10 @@ share/locale/zh_TW/LC_MESSAGES/gnome-netstatus.mo
@dirrmtry share/locale/nn
@dirrmtry share/locale/ne/LC_MESSAGES
@dirrmtry share/locale/ne
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/mg/LC_MESSAGES
+@dirrmtry share/locale/mg
@dirrmtry share/locale/ko/LC_MESSAGES
@dirrmtry share/locale/ko
@dirrmtry share/locale/gl/LC_MESSAGES
@@ -217,7 +232,11 @@ share/locale/zh_TW/LC_MESSAGES/gnome-netstatus.mo
@dirrmtry share/locale/fi
@dirrmtry share/locale/el/LC_MESSAGES
@dirrmtry share/locale/el
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
@dirrmtry share/locale/cs/LC_MESSAGES
@dirrmtry share/locale/cs
@dirrmtry share/locale/ca/LC_MESSAGES
@dirrmtry share/locale/ca
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN