aboutsummaryrefslogtreecommitdiff
path: root/net/gnome-nettool
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 04:53:48 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 04:53:48 +0000
commite18151212d3326dbf04797c6d5300fb1211ee875 (patch)
tree1ca56d6a4227efdb653cc8e2b2cbedbbc8de3d88 /net/gnome-nettool
parentcc0f3248a2eb77d7e3df88333fd25eb8594223dc (diff)
downloadports-e18151212d3326dbf04797c6d5300fb1211ee875.tar.gz
ports-e18151212d3326dbf04797c6d5300fb1211ee875.zip
Presenting GNOME 2.12 for FreeBSD. The release is chock full of bug fixes
and new features. Don't believe me? Then see for yourself at http://www.gnome.org/start/2.12/notes/en/. DO NOT USE portupgrade by itself to upgrade to GNOME 2.12. Instead, use the gnome_upgrade.sh script from http://www.marcuscom.com/downloads/gnome_upgrade212.sh. This script will circumvent some potential pitfalls users can see if they use portupgrade by itself. In keeping with tradition, GNOME 2.12 for FreeBSD comes with a special splash screen. The winner of this release's contest is Dominique Goncalves <dominique.goncalves@gmail.com>. His splash screen was inspired by http://art.gnome.org/contests/2.12-splash/83. The FreeBSD GNOME Team would lank to thank the following users for their contributions to this release: Matthew Luckie <mjl@luckie.org.nz> ade sajd on #freebsd-gnome Caelian on #freebsd-gnome mnag Yasuda Keisuke <kysd@po.harenet.ne.jp> Mark Hobden <markhobden@gmail.com> Sergey Akifyev <asa@agava.com> Andreas Kohn For more information on GNOME on FreeBSD, checkout http://www.FreeBSD.org/gnome/. The 2.12 documentation will be posted shortly.
Notes
Notes: svn path=/head/; revision=147261
Diffstat (limited to 'net/gnome-nettool')
-rw-r--r--net/gnome-nettool/Makefile9
-rw-r--r--net/gnome-nettool/distinfo4
-rw-r--r--net/gnome-nettool/files/patch-src_info.c23
-rw-r--r--net/gnome-nettool/files/patch-src_lookup.c10
-rw-r--r--net/gnome-nettool/files/patch-src_utils.c15
-rw-r--r--net/gnome-nettool/pkg-plist3
6 files changed, 44 insertions, 20 deletions
diff --git a/net/gnome-nettool/Makefile b/net/gnome-nettool/Makefile
index 354f8005f5bc..ef5791839707 100644
--- a/net/gnome-nettool/Makefile
+++ b/net/gnome-nettool/Makefile
@@ -3,14 +3,15 @@
# Whom: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/net/gnomenettool/Makefile,v 1.11 2005/10/04 03:12:16 ahze Exp $
#
PORTNAME= gnomenettool
-PORTVERSION= 1.2.0
+PORTVERSION= 1.4.1
PORTEPOCH= 1
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-nettool/1.2
+MASTER_SITE_SUBDIR= sources/gnome-nettool/1.4
DISTNAME= gnome-nettool-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -19,9 +20,9 @@ COMMENT= A GNOME utility that provides network information statistics
USE_X_PREFIX= yes
USE_BZIP2= yes
-USE_GNOME= gnomehack intlhack gnomeprefix libgnomeui
+USE_GNOME= gnomehack intlhack gnomeprefix libglade2 gconf2
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CFLAGS+= -DHAVE_SOCKADDR_SA_LEN
diff --git a/net/gnome-nettool/distinfo b/net/gnome-nettool/distinfo
index 9606b0ac5244..97d559067edb 100644
--- a/net/gnome-nettool/distinfo
+++ b/net/gnome-nettool/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gnome-nettool-1.2.0.tar.bz2) = 277338cf5d54ae9941260dd993a14f7a
-SIZE (gnome2/gnome-nettool-1.2.0.tar.bz2) = 572511
+MD5 (gnome2/gnome-nettool-1.4.1.tar.bz2) = a64f7b39f24b4d3a843d545f2dbb611d
+SIZE (gnome2/gnome-nettool-1.4.1.tar.bz2) = 477548
diff --git a/net/gnome-nettool/files/patch-src_info.c b/net/gnome-nettool/files/patch-src_info.c
index 2d95d26204ac..9b895e8fd67f 100644
--- a/net/gnome-nettool/files/patch-src_info.c
+++ b/net/gnome-nettool/files/patch-src_info.c
@@ -1,14 +1,15 @@
---- src/info.c.orig Tue Feb 1 06:05:58 2005
-+++ src/info.c Thu Mar 3 23:39:57 2005
-@@ -20,6 +20,7 @@
+--- src/info.c.orig Thu Jan 27 18:26:53 2005
++++ src/info.c Sun Jul 3 17:46:31 2005
+@@ -20,6 +20,8 @@
#include <gtk/gtk.h>
#include <glib/gi18n.h>
#include <glib/gprintf.h>
+#include <sys/types.h>
++#include <string.h>
#ifdef HAVE_CONFIG_H
# include <config.h>
-@@ -38,6 +39,11 @@
+@@ -38,6 +40,11 @@
#include <sys/ioctl.h>
#include <stdlib.h>
#include <net/if.h>
@@ -20,7 +21,7 @@
#include "info.h"
#include "utils.h"
-@@ -58,6 +64,7 @@
+@@ -58,6 +65,7 @@ static InfoInterfaceDescription info_ifa
{ N_("Ethernet Interface"), INFO_INTERFACE_ETH, "16_ethernet.xpm", "eth", NULL },
{ N_("Wireless Interface"), INFO_INTERFACE_WLAN, "wavelan-16.png", "wlan", NULL },
{ N_("Modem Interface"), INFO_INTERFACE_PPP, "16_ppp.xpm", "ppp", NULL },
@@ -28,7 +29,7 @@
{ N_("Parallel Line Interface"), INFO_INTERFACE_PLIP, "16_plip.xpm", "plip", NULL },
{ N_("Infrared Interface"), INFO_INTERFACE_IRLAN, "irda-16.png", "irlan", NULL },
{ N_("Loopback Interface"), INFO_INTERFACE_LO, "16_loopback.xpm", "lo", NULL },
-@@ -128,9 +135,42 @@
+@@ -128,9 +136,42 @@ info_get_interface_from_dev_name (const
{
gint i;
gchar *path;
@@ -73,7 +74,7 @@
(*iface) = g_strdup_printf ("%s (%s)", info_iface_desc[i].name, dev_name);
if (info_iface_desc[i].pixbuf == NULL) {
path = g_build_filename (PIXMAPS_DIR, info_iface_desc[i].icon, NULL);
-@@ -217,38 +257,87 @@
+@@ -217,38 +258,87 @@ info_nic_update_stats (gpointer data)
gchar tx[10], tx_error[10], tx_drop[10], tx_ovr[10];
*/
gchar iface[30]; /*, flags[30]; */
@@ -167,7 +168,7 @@
if (g_ascii_strcasecmp (iface, text) == 0) {
/*
-@@ -276,7 +365,9 @@
+@@ -276,7 +366,9 @@ info_nic_update_stats (gpointer data)
}
g_io_channel_unref (io);
@@ -178,7 +179,7 @@
return TRUE;
}
-@@ -405,8 +496,16 @@
+@@ -405,8 +497,16 @@ info_get_nic_information (const gchar *n
InfoIpAddr *ip;
gint flags;
mii_data_result data;
@@ -195,7 +196,7 @@
for (ifr6 = ifa0; ifr6; ifr6 = ifr6->ifa_next) {
if (strcmp (ifr6->ifa_name, nic) != 0) {
-@@ -452,7 +551,9 @@
+@@ -452,7 +552,9 @@ info_get_nic_information (const gchar *n
ifc.ifc_req = (struct ifreq *) buf;
ioctl (sockfd, SIOCGIFCONF, &ifc);
@@ -205,7 +206,7 @@
for (ptr = buf; ptr < buf + ifc.ifc_len;) {
ifr = (struct ifreq *) ptr;
-@@ -483,6 +584,45 @@
+@@ -483,6 +585,45 @@ info_get_nic_information (const gchar *n
(int) ((guchar *) &ifrcopy.ifr_hwaddr.sa_data)[3],
(int) ((guchar *) &ifrcopy.ifr_hwaddr.sa_data)[4],
(int) ((guchar *) &ifrcopy.ifr_hwaddr.sa_data)[5]);
diff --git a/net/gnome-nettool/files/patch-src_lookup.c b/net/gnome-nettool/files/patch-src_lookup.c
new file mode 100644
index 000000000000..9744c13973da
--- /dev/null
+++ b/net/gnome-nettool/files/patch-src_lookup.c
@@ -0,0 +1,10 @@
+--- src/lookup.c.orig Sun Jul 3 17:47:02 2005
++++ src/lookup.c Sun Jul 3 17:47:20 2005
+@@ -21,6 +21,7 @@
+ #include <gtk/gtk.h>
+ #include <glib/gi18n.h>
+ #include <glib/gprintf.h>
++#include <sys/types.h>
+
+ #include "lookup.h"
+ #include "utils.h"
diff --git a/net/gnome-nettool/files/patch-src_utils.c b/net/gnome-nettool/files/patch-src_utils.c
index 0c8111ade4bf..921c780498c1 100644
--- a/net/gnome-nettool/files/patch-src_utils.c
+++ b/net/gnome-nettool/files/patch-src_utils.c
@@ -1,6 +1,15 @@
---- src/utils.c.orig Sun Jul 4 20:11:49 2004
-+++ src/utils.c Sun Jul 4 20:12:14 2004
-@@ -240,7 +240,7 @@
+--- src/utils.c.orig Fri May 6 16:10:28 2005
++++ src/utils.c Sun Jul 3 17:48:12 2005
+@@ -24,6 +24,8 @@
+ on GNOME 2.0 */
+
+ #include "utils.h"
++#include <stdlib.h>
++#include <limits.h>
+ #include <string.h>
+ #include <glib/gi18n.h>
+
+@@ -240,7 +242,7 @@ util_legible_bytes (gchar *bytes)
const gchar *unit = "B";
gchar *result;
diff --git a/net/gnome-nettool/pkg-plist b/net/gnome-nettool/pkg-plist
index b1f5ab614ccf..0d3d6886cd50 100644
--- a/net/gnome-nettool/pkg-plist
+++ b/net/gnome-nettool/pkg-plist
@@ -23,6 +23,7 @@ share/locale/el/LC_MESSAGES/gnome-nettool.mo
share/locale/en_CA/LC_MESSAGES/gnome-nettool.mo
share/locale/en_GB/LC_MESSAGES/gnome-nettool.mo
share/locale/es/LC_MESSAGES/gnome-nettool.mo
+share/locale/et/LC_MESSAGES/gnome-nettool.mo
share/locale/eu/LC_MESSAGES/gnome-nettool.mo
share/locale/fa/LC_MESSAGES/gnome-nettool.mo
share/locale/fi/LC_MESSAGES/gnome-nettool.mo
@@ -52,6 +53,7 @@ share/locale/pt/LC_MESSAGES/gnome-nettool.mo
share/locale/pt_BR/LC_MESSAGES/gnome-nettool.mo
share/locale/ro/LC_MESSAGES/gnome-nettool.mo
share/locale/ru/LC_MESSAGES/gnome-nettool.mo
+share/locale/rw/LC_MESSAGES/gnome-nettool.mo
share/locale/sk/LC_MESSAGES/gnome-nettool.mo
share/locale/sq/LC_MESSAGES/gnome-nettool.mo
share/locale/sr/LC_MESSAGES/gnome-nettool.mo
@@ -63,6 +65,7 @@ share/locale/tr/LC_MESSAGES/gnome-nettool.mo
share/locale/uk/LC_MESSAGES/gnome-nettool.mo
share/locale/vi/LC_MESSAGES/gnome-nettool.mo
share/locale/wa/LC_MESSAGES/gnome-nettool.mo
+share/locale/xh/LC_MESSAGES/gnome-nettool.mo
share/locale/zh_CN/LC_MESSAGES/gnome-nettool.mo
share/locale/zh_TW/LC_MESSAGES/gnome-nettool.mo
@dirrm share/gnome/gnome-nettool/pixmaps