aboutsummaryrefslogtreecommitdiff
path: root/net/gq
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2006-05-14 16:20:53 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2006-05-14 16:20:53 +0000
commit40eca31a40d62d64a422c31032e9a528f8d37424 (patch)
tree4528d8b14717bf92e919ae79b0a6381179524c65 /net/gq
parent57c90787cf582207b9cbb647562cc796806b00aa (diff)
downloadports-40eca31a40d62d64a422c31032e9a528f8d37424.tar.gz
ports-40eca31a40d62d64a422c31032e9a528f8d37424.zip
Update to 1.0rc1.
Submitter takes maintainership. PR: ports/96035 Submitted by: Dryice Liu <dryice@dryice.name>
Notes
Notes: svn path=/head/; revision=162347
Diffstat (limited to 'net/gq')
-rw-r--r--net/gq/Makefile15
-rw-r--r--net/gq/distinfo6
-rw-r--r--net/gq/files/patch-configure11
-rw-r--r--net/gq/files/patch-icons-Makefile.in11
-rw-r--r--net/gq/files/patch-icons::Makefile.in11
-rw-r--r--net/gq/files/patch-src-xmlparse.c (renamed from net/gq/files/patch-src::xmlparse.c)6
-rw-r--r--net/gq/files/patch-src::util.c20
-rw-r--r--net/gq/pkg-plist19
8 files changed, 35 insertions, 64 deletions
diff --git a/net/gq/Makefile b/net/gq/Makefile
index f322720b857d..82d059e93a3d 100644
--- a/net/gq/Makefile
+++ b/net/gq/Makefile
@@ -6,18 +6,19 @@
#
PORTNAME= gq
-PORTVERSION= 1.0b1
-PORTREVISION= 6
+PORTVERSION= 1.0r1
CATEGORIES= net
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://dryice.name/computer/FreeBSD/distfiles/
MASTER_SITE_SUBDIR= gqclient
-DISTNAME= gq-${PORTVERSION:S/b/beta/}
+DISTNAME= gq-${PORTVERSION:S/r/rc/}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= dryice@dryice.name
COMMENT= GTK-based LDAP client
-USE_GMAKE= yes
-USE_ICONV= yes
+USE_GCC= 3.4+
+USE_GMAKE= yes
+USE_ICONV= yes
USE_GETTEXT= yes
USE_OPENLDAP= yes
USE_OPENSSL= yes
diff --git a/net/gq/distinfo b/net/gq/distinfo
index 5c3d3096fccc..f87f7498712e 100644
--- a/net/gq/distinfo
+++ b/net/gq/distinfo
@@ -1,3 +1,3 @@
-MD5 (gq-1.0beta1.tar.gz) = c904ff52f513a58516d9543f8dc3fe5b
-SHA256 (gq-1.0beta1.tar.gz) = 93fed2f77dedf4ececa475a11fab25d126720165c36c4179c8cd13b50e636552
-SIZE (gq-1.0beta1.tar.gz) = 475081
+MD5 (gq-1.0rc1.tar.gz) = c7944d681382d32440d4bf0241142697
+SHA256 (gq-1.0rc1.tar.gz) = 8f5a2c1aeb26a75c1de3232df2595a43e87cd252f2911354add4cd9c59514112
+SIZE (gq-1.0rc1.tar.gz) = 562766
diff --git a/net/gq/files/patch-configure b/net/gq/files/patch-configure
deleted file mode 100644
index ae546b9859d3..000000000000
--- a/net/gq/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Tue Feb 17 00:38:43 2004
-+++ configure Tue Feb 17 00:39:12 2004
-@@ -6702,7 +6702,7 @@
- fi;
-
- if test "x$GCC" = "xyes"; then
-- for A in -Wall -W -Wno-unused -Wmissing-declarations -Wcast-align -Wpointer-arith -Wfloat-equal
-+ for A in -Wall -W -Wno-unused -Wmissing-declarations -Wcast-align -Wpointer-arith
- do
- # The following should work as well, but might (?) be less portable
- # if ! echo "$CFLAGS" | grep -q -w -- "$A" ; then
diff --git a/net/gq/files/patch-icons-Makefile.in b/net/gq/files/patch-icons-Makefile.in
new file mode 100644
index 000000000000..a30acfb9f899
--- /dev/null
+++ b/net/gq/files/patch-icons-Makefile.in
@@ -0,0 +1,11 @@
+--- icons/Makefile.in.orig Mon Apr 10 19:22:45 2006
++++ icons/Makefile.in Wed Apr 19 10:26:21 2006
+@@ -193,7 +193,7 @@
+ warning.xpm
+
+ EXTRA_DIST = $(PIXMAPS)
+-pixmapdir = $(datadir)/pixmaps/gq
++pixmapdir = $(datadir)/gq
+ pixmap_DATA = $(PIXMAPS)
+ all: all-am
+
diff --git a/net/gq/files/patch-icons::Makefile.in b/net/gq/files/patch-icons::Makefile.in
deleted file mode 100644
index 71deccf450b1..000000000000
--- a/net/gq/files/patch-icons::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- icons/Makefile.in.orig Thu Jun 8 14:42:26 2000
-+++ icons/Makefile.in Thu Jun 8 14:42:40 2000
-@@ -70,7 +70,7 @@
-
- EXTRA_DIST = $(PIXMAPS)
-
--pixmapdir = $(datadir)/pixmaps/gq
-+pixmapdir = $(datadir)/gq
- pixmap_DATA = $(PIXMAPS)
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
- CONFIG_HEADER = ../config.h
diff --git a/net/gq/files/patch-src::xmlparse.c b/net/gq/files/patch-src-xmlparse.c
index f00dca620bd6..260ababa77bb 100644
--- a/net/gq/files/patch-src::xmlparse.c
+++ b/net/gq/files/patch-src-xmlparse.c
@@ -1,5 +1,5 @@
---- src/xmlparse.c.orig Thu Jul 29 09:46:26 2004
-+++ src/xmlparse.c Thu Jul 29 09:47:09 2004
+--- src/xmlparse.c.orig Wed Apr 5 08:53:55 2006
++++ src/xmlparse.c Wed Apr 19 10:35:15 2006
@@ -51,7 +51,7 @@
#include "xmlparse.h"
@@ -16,7 +16,7 @@
- e->attrs = calloc(i, sizeof(xmlChar *));
+ e->attrs = calloc(i+1, sizeof(xmlChar *));
for (i = 0 ; attrs[i] ; i++) {
- e->attrs[i] = strdup(attrs[i]);
+ e->attrs[i] = (guchar*)strdup((gchar*)attrs[i]);
}
+ e->attrs[i] = NULL;
}
diff --git a/net/gq/files/patch-src::util.c b/net/gq/files/patch-src::util.c
deleted file mode 100644
index d470f6ae5b8e..000000000000
--- a/net/gq/files/patch-src::util.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/util.c.orig Mon Nov 3 23:28:24 2003
-+++ src/util.c Thu Oct 14 12:46:42 2004
-@@ -1909,7 +1909,7 @@
- char **gq_ldap_explode_dn(const char *dn, int dummy)
- {
- int i, rc;
-- LDAPDN *parts;
-+ LDAPDN parts;
- char **v = 0;
-
- rc = ldap_str2dn(dn, &parts, LDAP_DN_FORMAT_LDAPV3);
-@@ -1921,7 +1921,7 @@
- v = (char **) calloc((i + 2), sizeof(char*));
-
- for( i = 0 ; parts[i] ; i++ ) {
-- ldap_rdn2str(parts[0][i], &v[i],
-+ ldap_rdn2str(parts[i], &v[i],
- LDAP_DN_FORMAT_LDAPV3 | LDAP_DN_PRETTY );
- }
- return v;
diff --git a/net/gq/pkg-plist b/net/gq/pkg-plist
index 6a7c30e3d7cb..96ef202d39df 100644
--- a/net/gq/pkg-plist
+++ b/net/gq/pkg-plist
@@ -1,10 +1,11 @@
bin/gq
-share/gnome/apps/Internet/gq.desktop
-share/gq/bomb.xpm
-share/gq/hide.xpm
-share/gq/line.xpm
-share/gq/logo.xpm
-share/gq/new.xpm
-share/gq/textarea.xpm
-share/gq/warning.xpm
-@dirrm share/gq
+share/applications/gq.desktop
+%%DATADIR%%/bomb.xpm
+%%DATADIR%%/hide.xpm
+%%DATADIR%%/line.xpm
+%%DATADIR%%/logo.xpm
+%%DATADIR%%/new.xpm
+%%DATADIR%%/textarea.xpm
+%%DATADIR%%/warning.xpm
+@dirrm %%DATADIR%%
+@dirrmtry share/applications