aboutsummaryrefslogtreecommitdiff
path: root/net/gq
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
commit7887c684adab042fed1bfcba2e91589ecd17c4a8 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /net/gq
parent85544f2c01be814e0af1ebee1076012e7ed60bb0 (diff)
downloadports-7887c684adab042fed1bfcba2e91589ecd17c4a8.tar.gz
ports-7887c684adab042fed1bfcba2e91589ecd17c4a8.zip
* Update the glib to 2.34.3 and gtk20 to 2.24.17 and gtk30 to 3.6.4 which
are the latest stable releases. * Update vala to the newest stable release 0.18.1, also update a few ports in the gtk/gnome stack. * The c++ bindings ports for glib, atk, gconf, etc, have now USE_GNOME toggles. * Remove pkg-config run depends from glib20 and freetype2. This doesn't eliminate pkg-config run dependency completely, a second phase is needed and is planned. * Support for .:run. and .:build. for USE_GNOME components was added. Currently only libxml2 and libxslt support this mechanism. * Updates of the telepathy stack and empathy. * Trim makefile headers, convert ports to new options, trim off library versions for some ports. * Fix other ports so they build with the new glib version. Thanks to miwi and crees for helping out with some exp-runs. Approved by: portmgr (miwi & bapt) Obtained from: gnome team repo
Notes
Notes: svn path=/head/; revision=313633
Diffstat (limited to 'net/gq')
-rw-r--r--net/gq/Makefile9
-rw-r--r--net/gq/files/patch-src::state.c17
2 files changed, 22 insertions, 4 deletions
diff --git a/net/gq/Makefile b/net/gq/Makefile
index 927242bc6928..360f575d88b2 100644
--- a/net/gq/Makefile
+++ b/net/gq/Makefile
@@ -39,4 +39,13 @@ CONFIGURE_ARGS+= --enable-browser-dnd
CONFIGURE_ARGS+= --enable-cache
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' \
+ ${WRKSRC}/src/syntax.h \
+ ${WRKSRC}/src/glib-helpers.[ch] \
+ ${WRKSRC}/src/gq-hash.h \
+ ${WRKSRC}/src/gq-main-loop.h \
+ ${WRKSRC}/src/gq-stack.[ch] \
+ ${WRKSRC}/src/gq-tab.h
+
.include <bsd.port.mk>
diff --git a/net/gq/files/patch-src::state.c b/net/gq/files/patch-src::state.c
index 4e80d0bcbfd3..edc09cdb8360 100644
--- a/net/gq/files/patch-src::state.c
+++ b/net/gq/files/patch-src::state.c
@@ -1,6 +1,15 @@
---- src/state.c.orig Thu Jul 29 09:44:27 2004
-+++ src/state.c Thu Jul 29 09:44:51 2004
-@@ -754,7 +754,7 @@
+--- src/state.c.orig 2008-01-09 16:35:12.000000000 +0000
++++ src/state.c 2013-03-06 13:32:20.000000000 +0000
+@@ -36,7 +36,7 @@
+ #include <errno.h>
+
+ #include <glib/gi18n.h>
+-#include <glib/gmessages.h>
++#include <glib.h>
+ #include <gtk/gtk.h>
+
+ #include "configfile.h"
+@@ -806,7 +806,7 @@
}
}
@@ -8,4 +17,4 @@
+ if (n != NULL && v!=NULL && v->type != 0) {
char *ep;
- assert(v);
+ g_assert(v);