aboutsummaryrefslogtreecommitdiff
path: root/net/gq
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-10-04 10:00:38 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-10-04 10:00:38 +0000
commit8da9eeea9bc847ec985612266eb2cbb0a5c9a0cc (patch)
treead6ce86a39fc8a59b7fcf6f2b0eacd5d669174c2 /net/gq
parent80e4958419d897d412991114941c3745209f4c3f (diff)
downloadports-8da9eeea9bc847ec985612266eb2cbb0a5c9a0cc.tar.gz
ports-8da9eeea9bc847ec985612266eb2cbb0a5c9a0cc.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=305247
Diffstat (limited to 'net/gq')
-rw-r--r--net/gq/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/net/gq/Makefile b/net/gq/Makefile
index ae38341c497c..927242bc6928 100644
--- a/net/gq/Makefile
+++ b/net/gq/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gq
-# Date Created: 8 Jun 2000
-# Whom: Roman Shterenzon <roman@xpert.com>
-#
+# Created by: Roman Shterenzon <roman@xpert.com>
# $FreeBSD$
-#
PORTNAME= gq
PORTVERSION= 1.3.4
@@ -17,8 +13,10 @@ COMMENT= GTK-based LDAP client
LIB_DEPENDS= gnome-keyring:${PORTSDIR}/security/gnome-keyring
-OPTIONS= DND "Enable Drag and drop support in browse mode" On \
- CACHE "Support the OpenLDAP experimental client cache" On
+OPTIONS_DEFINE= DND CACHE
+OPTIONS_DEFAULT= DND CACHE
+DND_DESC= Enable Drag and drop support in browse mode
+CACHE_DESC= Support the OpenLDAP experimental client cache
USE_GNOME= libglade2 gnomedocutils
USE_OPENSSL= yes
@@ -31,14 +29,14 @@ CONFIGURE_ARGS= --with-ldap-prefix=${LOCALBASE}
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_DND)
+.if ${PORT_OPTIONS:MDND}
CONFIGURE_ARGS+= --enable-browser-dnd
.endif
-.if !defined(WITHOUT_CACHE)
+.if ${PORT_OPTIONS:MCACHE}
CONFIGURE_ARGS+= --enable-cache
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>