aboutsummaryrefslogtreecommitdiff
path: root/net/gq
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2020-01-27 19:40:17 +0000
committerRene Ladan <rene@FreeBSD.org>2020-01-27 19:40:17 +0000
commitb0eec09651960d8c9d8a0981beab512bfb3c21f7 (patch)
tree94e26138c8267621b1b647591febb9f4c2bee2eb /net/gq
parent56b735e2588de9f5ab64b0122de9f731ea768c0c (diff)
Notes
Diffstat (limited to 'net/gq')
-rw-r--r--net/gq/Makefile4
-rw-r--r--net/gq/files/patch-Makefile.in10
-rw-r--r--net/gq/files/patch-configure55
-rw-r--r--net/gq/files/patch-src__state.c6
-rw-r--r--net/gq/files/patch-src_gq-server.c4
-rw-r--r--net/gq/files/patch-src_gq-tab-schema.c4
-rw-r--r--net/gq/pkg-plist6
7 files changed, 73 insertions, 16 deletions
diff --git a/net/gq/Makefile b/net/gq/Makefile
index d632d5809d3f..8c76a93290bd 100644
--- a/net/gq/Makefile
+++ b/net/gq/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gq
PORTVERSION= 1.3.4
-PORTREVISION= 13
+PORTREVISION= 14
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}client/GQ%20Unstable/${PORTVERSION}
@@ -17,7 +17,7 @@ LICENSE_FILE_GPLv2+ = ${WRKSRC}/COPYING
LIB_DEPENDS= libgnome-keyring.so:security/libgnome-keyring
-USE_GNOME= intltool libglade2 gnomedocutils
+USE_GNOME= intltool libglade2
USE_OPENLDAP= yes
USES= desktop-file-utils gettext gmake gnome pkgconfig \
shared-mime-info ssl
diff --git a/net/gq/files/patch-Makefile.in b/net/gq/files/patch-Makefile.in
new file mode 100644
index 000000000000..5da3502e20cb
--- /dev/null
+++ b/net/gq/files/patch-Makefile.in
@@ -0,0 +1,10 @@
+--- Makefile.in.orig 2008-02-13 21:14:39 UTC
++++ Makefile.in
+@@ -240,7 +240,6 @@ SUBDIRS = \
+ src \
+ test \
+ po \
+- help \
+ $(NULL)
+
+ intltool = \
diff --git a/net/gq/files/patch-configure b/net/gq/files/patch-configure
new file mode 100644
index 000000000000..d8475403dbb8
--- /dev/null
+++ b/net/gq/files/patch-configure
@@ -0,0 +1,55 @@
+--- configure.orig 2008-02-13 21:14:37 UTC
++++ configure
+@@ -4804,29 +4804,9 @@ GLIB_GENMARSHAL=`pkg-config --variable=glib_genmarshal
+ echo "${ECHO_T}$GLIB_GENMARSHAL" >&6; }
+
+
+-gdu_cv_version_required=0.3.2
+
+-if test -n "$PKG_CONFIG" && \
+- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"gnome-doc-utils >= \$gdu_cv_version_required\"") >&5
+- ($PKG_CONFIG --exists --print-errors "gnome-doc-utils >= $gdu_cv_version_required") 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; then
+- gdu_cv_have_gdu=yes
+-else
+- gdu_cv_have_gdu=no
+-fi
+
+-if test "$gdu_cv_have_gdu" = "yes"; then
+- :
+-else
+- { { echo "$as_me:$LINENO: error: gnome-doc-utils >= $gdu_cv_version_required not found" >&5
+-echo "$as_me: error: gnome-doc-utils >= $gdu_cv_version_required not found" >&2;}
+- { (exit 1); exit 1; }; }
+-fi
+
+-
+-
+ # Check whether --with-help-dir was given.
+ if test "${with_help_dir+set}" = set; then
+ withval=$with_help_dir;
+@@ -4866,22 +4846,12 @@ else
+ enable_scrollkeeper=yes
+ fi
+
+- if test "$gdu_cv_have_gdu" = "yes" -a "$enable_scrollkeeper" = "yes"; then
+- ENABLE_SK_TRUE=
+- ENABLE_SK_FALSE='#'
+-else
+ ENABLE_SK_TRUE='#'
+ ENABLE_SK_FALSE=
+-fi
+
+
+- if test "$gdu_cv_have_gdu" = "yes"; then
+- HAVE_GNOME_DOC_UTILS_TRUE=
+- HAVE_GNOME_DOC_UTILS_FALSE='#'
+-else
+ HAVE_GNOME_DOC_UTILS_TRUE='#'
+ HAVE_GNOME_DOC_UTILS_FALSE=
+-fi
+
+
+
diff --git a/net/gq/files/patch-src__state.c b/net/gq/files/patch-src__state.c
index edc09cdb8360..3f0c6d549281 100644
--- a/net/gq/files/patch-src__state.c
+++ b/net/gq/files/patch-src__state.c
@@ -1,5 +1,5 @@
---- src/state.c.orig 2008-01-09 16:35:12.000000000 +0000
-+++ src/state.c 2013-03-06 13:32:20.000000000 +0000
+--- src/state.c.orig 2008-01-09 16:35:12 UTC
++++ src/state.c
@@ -36,7 +36,7 @@
#include <errno.h>
@@ -9,7 +9,7 @@
#include <gtk/gtk.h>
#include "configfile.h"
-@@ -806,7 +806,7 @@
+@@ -806,7 +806,7 @@ static void state_valueE(struct parser_context *ctx,
}
}
diff --git a/net/gq/files/patch-src_gq-server.c b/net/gq/files/patch-src_gq-server.c
index 51aab59ac05b..36af6083b9a9 100644
--- a/net/gq/files/patch-src_gq-server.c
+++ b/net/gq/files/patch-src_gq-server.c
@@ -1,5 +1,5 @@
---- src/gq-server.c.orig 2008-04-30 04:15:42.000000000 +0000
-+++ src/gq-server.c 2008-04-30 04:15:11.000000000 +0000
+--- src/gq-server.c.orig 2008-01-09 16:35:12 UTC
++++ src/gq-server.c
@@ -25,6 +25,7 @@
#include "gq-server.h"
diff --git a/net/gq/files/patch-src_gq-tab-schema.c b/net/gq/files/patch-src_gq-tab-schema.c
index aa6d6dbce6ec..339701d769b6 100644
--- a/net/gq/files/patch-src_gq-tab-schema.c
+++ b/net/gq/files/patch-src_gq-tab-schema.c
@@ -1,6 +1,4 @@
-diff --git src/gq-tab-schema.c src/gq-tab-schema.c
-index b0f16e6..29219c0 100644
---- src/gq-tab-schema.c
+--- src/gq-tab-schema.c.orig 2008-01-09 16:35:12 UTC
+++ src/gq-tab-schema.c
@@ -1902,7 +1902,6 @@ gq_tab_schema_init(GqTabSchema* self)
diff --git a/net/gq/pkg-plist b/net/gq/pkg-plist
index d92bd74f944d..4e7311022544 100644
--- a/net/gq/pkg-plist
+++ b/net/gq/pkg-plist
@@ -9,10 +9,6 @@ share/pixmaps/gq/hide.xpm
share/pixmaps/gq/new.xpm
share/pixmaps/gq/textview.png
share/pixmaps/gq/warning.xpm
-share/gnome/help/gq-manual/C/gq-manual.xml
-share/gnome/help/gq-manual/C/legal.xml
-share/gnome/help/gq-manual/de/gq-manual.xml
-share/gnome/help/gq-manual/de/legal.xml
share/icons/hicolor/16x16/apps/ldap-group.png
share/icons/hicolor/16x16/apps/ldap-organization.png
share/icons/hicolor/16x16/apps/ldap-person.png
@@ -20,5 +16,3 @@ share/locale/cs/LC_MESSAGES/gq.mo
share/locale/de/LC_MESSAGES/gq.mo
share/locale/ja/LC_MESSAGES/gq.mo
share/locale/zh_CN/LC_MESSAGES/gq.mo
-share/omf/gq-manual/gq-manual-C.omf
-share/omf/gq-manual/gq-manual-de.omf