aboutsummaryrefslogtreecommitdiff
path: root/net/grilo-plugins/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /net/grilo-plugins/Makefile
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
downloadports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.tar.gz
ports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.zip
Notes
Diffstat (limited to 'net/grilo-plugins/Makefile')
-rw-r--r--net/grilo-plugins/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/net/grilo-plugins/Makefile b/net/grilo-plugins/Makefile
new file mode 100644
index 000000000000..683c5c03481f
--- /dev/null
+++ b/net/grilo-plugins/Makefile
@@ -0,0 +1,43 @@
+# Created by: Gustau Perez i Querol <gustau.perez@gmail.com>
+# $FreeBSD$
+# $MCom: ports/trunk/net/grilo-plugins/Makefile 20031 2014-11-02 21:47:55Z kwm $
+
+PORTNAME= grilo-plugins
+PORTVERSION= 0.2.13
+CATEGORIES= net
+MASTER_SITES= GNOME
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Plugins for net/grilo
+
+BUILD_DEPENDS= itstool:${PORTSDIR}/textproc/itstool
+LIB_DEPENDS= libgrilo-0.2.so:${PORTSDIR}/net/grilo \
+ libavahi-gobject.so:${PORTSDIR}/net/avahi-app \
+ libgdata.so:${PORTSDIR}/devel/libgdata
+
+USES= gmake libtool pathfix pkgconfig tar:xz
+USE_LDCONFIG= yes
+USE_GNOME= glib20 intlhack libxml2
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-youtube \
+ --enable-vimeo \
+ --enable-freebox \
+ --enable-tmdb
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/grilo-0.2/
+LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
+
+OPTIONS_SUB= yes
+OPTIONS_DEFINE= TRACKER DLEYNA DMAP
+OPTIONS_DEFAULT= TRACKER
+TRACKER_DESC= Tracker support for grilo (used by gnome-music and possibly others)
+TRACKER_CONFIGURE_ENABLE= tracker
+TRACKER_LIB_DEPENDS= libtracker-sparql-1.0.so:${PORTSDIR}/sysutils/tracker
+DMAP_DESC= DMAP (DAAP, DPAP & DACP) support with libdmapsharing
+DMAP_CONFIGURE_ENABLE= dmap
+DMAP_LIB_DEPENDS= libdmapsharing-3.0.so:${PORTSDIR}/net/libdmapsharing
+DLEYNA_DESC= DLNA support for grilo
+DLEYNA_CONFIGURE_ENABLE= dleyna
+DLEYNA_LIB_DEPENDS= libsoup-2.4.so:${PORTSDIR}/devel/libsoup
+
+.include <bsd.port.mk>