aboutsummaryrefslogtreecommitdiff
path: root/net/grpcox
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-11-30 02:22:17 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-11-30 02:22:17 +0000
commit58e39485387d0232eac747edc739b41c741591ee (patch)
treeed6f57983c0f1db1508ecd514f1472119f27d8fb /net/grpcox
parente2348a4125bdfdfcb89f4b32451e3591ae728dda (diff)
downloadports-58e39485387d0232eac747edc739b41c741591ee.tar.gz
ports-58e39485387d0232eac747edc739b41c741591ee.zip
New port: net/grpcox: Web based GUI client for gRPC
Notes
Notes: svn path=/head/; revision=518696
Diffstat (limited to 'net/grpcox')
-rw-r--r--net/grpcox/Makefile31
-rw-r--r--net/grpcox/distinfo21
-rw-r--r--net/grpcox/pkg-descr10
3 files changed, 62 insertions, 0 deletions
diff --git a/net/grpcox/Makefile b/net/grpcox/Makefile
new file mode 100644
index 000000000000..b4e892e8da48
--- /dev/null
+++ b/net/grpcox/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= grpcox
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.0
+CATEGORIES= net www
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Web based GUI client for gRPC
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+USE_GITHUB= yes
+GH_ACCOUNT= gusaul
+GH_SUBDIR= src/github.com/gusaul/grpcox
+GH_TUPLE= \
+ fullstorydev:grpcurl:v1.3.2:fullstorydev_grpcurl/vendor/github.com/fullstorydev/grpcurl \
+ golang:net:d8887717615a:golang_net/vendor/golang.org/x/net \
+ golang:protobuf:v1.3.1:golang_protobuf/vendor/github.com/golang/protobuf \
+ golang:sys:d0b11bdaac8a:golang_sys/vendor/golang.org/x/sys \
+ golang:text:v0.3.0:golang_text/vendor/golang.org/x/text \
+ google:go-genproto:c66870c02cf8:google_go_genproto/vendor/google.golang.org/genproto \
+ gorilla:mux:v1.7.0:gorilla_mux/vendor/github.com/gorilla/mux \
+ grpc:grpc-go:v1.21.0:grpc_grpc_go/vendor/google.golang.org/grpc \
+ jhump:protoreflect:v1.5.0:jhump_protoreflect/vendor/github.com/jhump/protoreflect
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/net/grpcox/distinfo b/net/grpcox/distinfo
new file mode 100644
index 000000000000..7120bca96302
--- /dev/null
+++ b/net/grpcox/distinfo
@@ -0,0 +1,21 @@
+TIMESTAMP = 1575079414
+SHA256 (gusaul-grpcox-v1.0.0_GH0.tar.gz) = 9b6a0713353e4aed4a82a53ae585cb5fd76180290b8d859be2de1e838dde945a
+SIZE (gusaul-grpcox-v1.0.0_GH0.tar.gz) = 4149396
+SHA256 (fullstorydev-grpcurl-v1.3.2_GH0.tar.gz) = 3b0b9efc187d86658d241642325fa0dbc3e408ec33ff375d6bd4adf373fa1a9a
+SIZE (fullstorydev-grpcurl-v1.3.2_GH0.tar.gz) = 93326
+SHA256 (golang-net-d8887717615a_GH0.tar.gz) = 275e6ecfc70b51e05127339c58d0ded3db9b74bf8be869d32c4e731b154af71d
+SIZE (golang-net-d8887717615a_GH0.tar.gz) = 974014
+SHA256 (golang-protobuf-v1.3.1_GH0.tar.gz) = 3f3a6123054a9847093c119895f1660612f301fe95358f3a6a1a33fd0933e6cf
+SIZE (golang-protobuf-v1.3.1_GH0.tar.gz) = 310884
+SHA256 (golang-sys-d0b11bdaac8a_GH0.tar.gz) = e7e3f36dd307e908e59dbda3864ff74f9a5d7f0fdd4d88af630e092beb7d270c
+SIZE (golang-sys-d0b11bdaac8a_GH0.tar.gz) = 1243049
+SHA256 (golang-text-v0.3.0_GH0.tar.gz) = 8f4c9a048345befc7beccd09267737ee1f55c7b35e5ff80f344ec9e0aa90febb
+SIZE (golang-text-v0.3.0_GH0.tar.gz) = 6102619
+SHA256 (google-go-genproto-c66870c02cf8_GH0.tar.gz) = 156e7cd1f95947c3f3293e18baa7af04e0da58eeeb3475f15bcc308ff491f31a
+SIZE (google-go-genproto-c66870c02cf8_GH0.tar.gz) = 2191164
+SHA256 (gorilla-mux-v1.7.0_GH0.tar.gz) = 5aca5bfa16325506b23b66ce34e2b9336a3a341b8c51ba7b0faf7d0daade0116
+SIZE (gorilla-mux-v1.7.0_GH0.tar.gz) = 40777
+SHA256 (grpc-grpc-go-v1.21.0_GH0.tar.gz) = 2c695d1cd4690c80c006116934ba98f2b41dd1d34dbee35c4f094e38db6d5e82
+SIZE (grpc-grpc-go-v1.21.0_GH0.tar.gz) = 731305
+SHA256 (jhump-protoreflect-v1.5.0_GH0.tar.gz) = 7d434465ca33bf0750f2516867c6d3960136d7b999dde1d3af6a24d50cf821af
+SIZE (jhump-protoreflect-v1.5.0_GH0.tar.gz) = 498102
diff --git a/net/grpcox/pkg-descr b/net/grpcox/pkg-descr
new file mode 100644
index 000000000000..2fe7d95df7fc
--- /dev/null
+++ b/net/grpcox/pkg-descr
@@ -0,0 +1,10 @@
+Turn PCurl into web based UI, extremely easy to use.
+
+Features:
+* Recognize and provide list of services and methods inside it as an options.
+* Automatically recognize schema input and compose it into JSON based.
+ (ensure your gRPC server supports server reflection).
+* Save established connection, and reuse it for next invoke/request (also can
+ close/restart connection).
+
+WWW: https://github.com/gusaul/grpcox