aboutsummaryrefslogtreecommitdiff
path: root/net/gscloud
diff options
context:
space:
mode:
authorVinícius Zavam <egypcio@FreeBSD.org>2020-05-21 20:26:36 +0000
committerVinícius Zavam <egypcio@FreeBSD.org>2020-05-21 20:26:36 +0000
commitcdf4f0f7180fbc02458c168064b82a80c43d22ba (patch)
treea42ef350d621a5c069c5e6a540b763a1c2d490e4 /net/gscloud
parentf9444ecef8b0dc9db0c63ef042412d226c481826 (diff)
downloadports-cdf4f0f7180fbc02458c168064b82a80c43d22ba.tar.gz
ports-cdf4f0f7180fbc02458c168064b82a80c43d22ba.zip
[NEW] net/gscloud: Official CLI to use gridscale's API, written in Go
* Currently supports controlling Kubernetes (k8s) services WWW: https://github.com/gridscale/gscloud
Notes
Notes: svn path=/head/; revision=536149
Diffstat (limited to 'net/gscloud')
-rw-r--r--net/gscloud/Makefile24
-rw-r--r--net/gscloud/distinfo3
-rw-r--r--net/gscloud/pkg-descr4
3 files changed, 31 insertions, 0 deletions
diff --git a/net/gscloud/Makefile b/net/gscloud/Makefile
new file mode 100644
index 000000000000..7ed2e1eb3184
--- /dev/null
+++ b/net/gscloud/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= gscloud
+DISTVERSION= g20200504
+CATEGORIES= net devel
+
+MAINTAINER= egypcio@FreeBSD.org
+COMMENT= Official command-line interface for gridscale's API written in Go
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+
+USE_GITHUB= yes
+GH_ACCOUNT= gridscale
+GH_TAGNAME= 3705cba
+
+GO_PKGNAME= github.com/gridscale/gscloud/cmd
+GO_TARGET= .
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/net/gscloud/distinfo b/net/gscloud/distinfo
new file mode 100644
index 000000000000..c5c6e89811f4
--- /dev/null
+++ b/net/gscloud/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1590004573
+SHA256 (gridscale-gscloud-g20200504-3705cba_GH0.tar.gz) = b95a30a367b5a3e5026f2201b1996df1e2f0ba25db805a2a71f732302cf48a31
+SIZE (gridscale-gscloud-g20200504-3705cba_GH0.tar.gz) = 2948241
diff --git a/net/gscloud/pkg-descr b/net/gscloud/pkg-descr
new file mode 100644
index 000000000000..cf55c218ef1f
--- /dev/null
+++ b/net/gscloud/pkg-descr
@@ -0,0 +1,4 @@
+The official command-line interface for the gridscale API. Currently it has
+support to control Kubernetes (k8s) services.
+
+WWW: https://github.com/gridscale/gscloud