aboutsummaryrefslogtreecommitdiff
path: root/net/guacamole-server
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2016-10-03 15:50:29 +0000
committerThomas Zander <riggs@FreeBSD.org>2016-10-03 15:50:29 +0000
commit84e08b2d1518685e88b3ca4cf3447321777fea1b (patch)
treec16ffc82c04396875c154f1a16170bbaef0783e0 /net/guacamole-server
parent157c019a2a1baebf579ea78d924840dcf580e40a (diff)
downloadports-84e08b2d1518685e88b3ca4cf3447321777fea1b.tar.gz
ports-84e08b2d1518685e88b3ca4cf3447321777fea1b.zip
New OPTIONs, general cleanup
Detailed log - New option WEBP - Add WEBP to OPTIONS_DEFAULT - Added ssl to USES - USE_GNOME for dependencies on gnome components - Bump PORTREVISION PR: 213158 Submitted by: Ultima1252@gmail.com (maintainer) Reviewed by: riggs Approved by: Ultima1252@gmail.com (maintainer)
Notes
Notes: svn path=/head/; revision=423202
Diffstat (limited to 'net/guacamole-server')
-rw-r--r--net/guacamole-server/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/net/guacamole-server/Makefile b/net/guacamole-server/Makefile
index 78893d8c3632..eacc493a15aa 100644
--- a/net/guacamole-server/Makefile
+++ b/net/guacamole-server/Makefile
@@ -3,7 +3,7 @@
PORTNAME= guacamole-server
PORTVERSION= 0.9.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MAINTAINER= ultima1252@gmail.com
@@ -14,7 +14,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libossp-uuid.so:misc/ossp-uuid \
libpng.so:graphics/png \
- libcairo.so:graphics/cairo \
libjpeg.so:graphics/jpeg-turbo
CONFLICTS_BUILD=pulseaudio-*+jack_* ffmpeg-*+jack_*
@@ -22,7 +21,8 @@ CONFLICTS_BUILD=pulseaudio-*+jack_* ffmpeg-*+jack_*
USE_GITHUB= yes
GH_ACCOUNT= glyptodon
-USES= autoreconf libtool localbase pkgconfig shebangfix
+USES= autoreconf libtool localbase pkgconfig shebangfix ssl
+USE_GNOME= cairo
SHEBANG_FILES= ${WRKSRC}/src/protocols/rdp/keymaps/generate.pl
GNU_CONFIGURE= yes
@@ -36,20 +36,23 @@ USE_RC_SUBR= guacd
SUB_LIST+= GUACD_USER=${USERS} \
GUACD_GROUP=${GROUPS}
-OPTIONS_DEFINE= RDP SSH VNC VORBIS PULSEAUDIO
-OPTIONS_DEFAULT= SSH
+OPTIONS_DEFINE= RDP SSH VNC VORBIS PULSEAUDIO WEBP
+OPTIONS_DEFAULT= RDP SSH VNC VORBIS PULSEAUDIO WEBP
OPTIONS_SUB= yes
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
PULSEAUDIO_DESC?= VNC audio support (Experimental)
RDP_LIB_DEPENDS= libfreerdp.so:net/freerdp
RDP_DESC?= RDP Protocal Support
-SSH_LIB_DEPENDS= libpango-1.0.so:x11-toolkits/pango \
- libssh2.so:security/libssh2
+SSH_LIB_DEPENDS= libssh2.so:security/libssh2
+SSH_USE= GNOME=pango
SSH_DESC?= SSH Support
VNC_LIB_DEPENDS= libvncserver.so:net/libvncserver
VNC_DESC?= VNC Protocol Support
-VORBIS_LIB_DEPENDS= libvorbis.so:audio/libvorbis
+VORBIS_LIB_DEPENDS= libvorbis.so:audio/libvorbis \
+ libogg.so:audio/libogg
VORBIS_DESC?= Ogg Vorbis for compression
+WEBP_LIB_DEPENDS= libwebp.so:graphics/webp
+WEBP_DESC?= WebP support
.include <bsd.port.pre.mk>