aboutsummaryrefslogtreecommitdiff
path: root/net/haproxy-devel
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2014-05-31 10:48:30 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2014-05-31 10:48:30 +0000
commit6d001adfaad34cc305412a8c30897c46a4bd2c6e (patch)
tree89820580eb7038094122d765b2c169d267d7a86b /net/haproxy-devel
parent3dd4f73f86547c5480df37a3bfb897afb357bddb (diff)
downloadports-6d001adfaad34cc305412a8c30897c46a4bd2c6e.tar.gz
ports-6d001adfaad34cc305412a8c30897c46a4bd2c6e.zip
Notes
Diffstat (limited to 'net/haproxy-devel')
-rw-r--r--net/haproxy-devel/Makefile2
-rw-r--r--net/haproxy-devel/distinfo4
-rw-r--r--net/haproxy-devel/files/patch-fix-uint66
3 files changed, 69 insertions, 3 deletions
diff --git a/net/haproxy-devel/Makefile b/net/haproxy-devel/Makefile
index c86088e0217a..4fc4e3ba87ad 100644
--- a/net/haproxy-devel/Makefile
+++ b/net/haproxy-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= haproxy
-DISTVERSION= 1.5-dev25
+DISTVERSION= 1.5-dev26
CATEGORIES= net
MASTER_SITES= http://haproxy.1wt.eu/download/1.5/src/devel/
PKGNAMESUFFIX= -devel
diff --git a/net/haproxy-devel/distinfo b/net/haproxy-devel/distinfo
index 7ddbf5c498c0..d24d53c501f4 100644
--- a/net/haproxy-devel/distinfo
+++ b/net/haproxy-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (haproxy-1.5-dev25.tar.gz) = c98d6ae13233815f1c26acfd2df50e85fedf0673f01f149b3211da17d6309c4b
-SIZE (haproxy-1.5-dev25.tar.gz) = 1296917
+SHA256 (haproxy-1.5-dev26.tar.gz) = fb1557bebb5843c572f81f69d8f8e4ec952963982b2c945989caa471e5b036ae
+SIZE (haproxy-1.5-dev26.tar.gz) = 1308611
diff --git a/net/haproxy-devel/files/patch-fix-uint b/net/haproxy-devel/files/patch-fix-uint
new file mode 100644
index 000000000000..ff5930e19eba
--- /dev/null
+++ b/net/haproxy-devel/files/patch-fix-uint
@@ -0,0 +1,66 @@
+From: Willy Tarreau <w@1wt.eu>
+Date: Wed, 28 May 2014 21:05:07 +0000 (+0200)
+Subject: BUILD: don't use type "uint" which is not portable
+X-Git-Url: http://haproxy.1wt.eu:81/git?p=haproxy.git;a=commitdiff_plain;h=c874653bb45b101f50ea710576c7b47766874d1c;hp=2e85840266f056d7a51e885b03b50963209d7111
+
+BUILD: don't use type "uint" which is not portable
+
+Dmitry Sivachenko reported that "uint" doesn't build on FreeBSD 10.
+On Linux it's defined in sys/types.h and indicated as "old". Just
+get rid of the very few occurrences.
+---
+
+diff --git a/contrib/halog/halog.c b/contrib/halog/halog.c
+index c686de1..fc927bd 100644
+--- contrib/halog/halog.c
++++ contrib/halog/halog.c
+@@ -694,7 +694,7 @@ int main(int argc, char **argv)
+ struct eb32_node *n;
+ struct url_stat *ustat = NULL;
+ int val, test;
+- uint uval;
++ unsigned int uval;
+ int filter_acc_delay = 0, filter_acc_count = 0;
+ int filter_time_resp = 0;
+ int filt_http_status_low = 0, filt_http_status_high = 0;
+diff --git a/include/common/regex.h b/include/common/regex.h
+index 63689af..2e26b67 100644
+--- include/common/regex.h
++++ include/common/regex.h
+@@ -79,7 +79,7 @@ extern regmatch_t pmatch[MAX_MATCH];
+ * The function return 1 is succes case, else return 0 and err is filled.
+ */
+ int regex_comp(const char *str, struct my_regex *regex, int cs, int cap, char **err);
+-int exp_replace(char *dst, uint dst_size, char *src, const char *str, const regmatch_t *matches);
++int exp_replace(char *dst, unsigned int dst_size, char *src, const char *str, const regmatch_t *matches);
+ const char *check_replace_string(const char *str);
+ const char *chain_regex(struct hdr_exp **head, const regex_t *preg,
+ int action, const char *replace, void *cond);
+diff --git a/src/regex.c b/src/regex.c
+index b081477..a31bcda 100644
+--- src/regex.c
++++ src/regex.c
+@@ -22,7 +22,7 @@
+ /* regex trash buffer used by various regex tests */
+ regmatch_t pmatch[MAX_MATCH]; /* rm_so, rm_eo for regular expressions */
+
+-int exp_replace(char *dst, uint dst_size, char *src, const char *str, const regmatch_t *matches)
++int exp_replace(char *dst, unsigned int dst_size, char *src, const char *str, const regmatch_t *matches)
+ {
+ char *old_dst = dst;
+ char* dst_end = dst + dst_size;
+diff --git a/src/standard.c b/src/standard.c
+index 9cec295..06176d7 100644
+--- src/standard.c
++++ src/standard.c
+@@ -2416,8 +2416,8 @@ char *env_expand(char *in)
+ const char *strnistr(const char *str1, int len_str1, const char *str2, int len_str2)
+ {
+ char *pptr, *sptr, *start;
+- uint slen, plen;
+- uint tmp1, tmp2;
++ unsigned int slen, plen;
++ unsigned int tmp1, tmp2;
+
+ if (str1 == NULL || len_str1 == 0) // search pattern into an empty string => search is not found
+ return NULL;