aboutsummaryrefslogtreecommitdiff
path: root/net/haproxy20
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2020-07-31 13:23:54 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2020-07-31 13:23:54 +0000
commit88026263553c7e00b11f2c5a4adb9e9bb489ab98 (patch)
treee00add4dac9633bfbe0936e51f62c5d3cfdbc416 /net/haproxy20
parent13522e0f934b870a4dcec78c0cd1007632312784 (diff)
downloadports-88026263553c7e00b11f2c5a4adb9e9bb489ab98.tar.gz
ports-88026263553c7e00b11f2c5a4adb9e9bb489ab98.zip
Update to version 2.0.17.
Notes
Notes: svn path=/head/; revision=543862
Diffstat (limited to 'net/haproxy20')
-rw-r--r--net/haproxy20/Makefile2
-rw-r--r--net/haproxy20/distinfo6
-rw-r--r--net/haproxy20/files/patch-add-parenthesis50
-rw-r--r--net/haproxy20/files/patch-ebtree-ebtree.c35
4 files changed, 4 insertions, 89 deletions
diff --git a/net/haproxy20/Makefile b/net/haproxy20/Makefile
index 6018e2ed5f5e..96b1b6173634 100644
--- a/net/haproxy20/Makefile
+++ b/net/haproxy20/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= haproxy
-DISTVERSION= 2.0.16
+DISTVERSION= 2.0.17
CATEGORIES= net www
PKGNAMESUFFIX= 20
MASTER_SITES= http://www.haproxy.org/download/2.0/src/
diff --git a/net/haproxy20/distinfo b/net/haproxy20/distinfo
index 887a7b72b2ad..113c0d70c961 100644
--- a/net/haproxy20/distinfo
+++ b/net/haproxy20/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1595752587
-SHA256 (haproxy-2.0.16.tar.gz) = 8eda217f3bf82f7ad6353bfd0c2005c4ac2da6cdca0398cf98de0016cdb97385
-SIZE (haproxy-2.0.16.tar.gz) = 2675207
+TIMESTAMP = 1596201751
+SHA256 (haproxy-2.0.17.tar.gz) = e7e2d14a75cbe65f1ab8f7dad092b1ffae36a82436c55accd27530258fe4b194
+SIZE (haproxy-2.0.17.tar.gz) = 2676783
diff --git a/net/haproxy20/files/patch-add-parenthesis b/net/haproxy20/files/patch-add-parenthesis
deleted file mode 100644
index 4c1d997ed6e4..000000000000
--- a/net/haproxy20/files/patch-add-parenthesis
+++ /dev/null
@@ -1,50 +0,0 @@
-X-Git-Url: http://git.haproxy.org/?p=haproxy-2.0.git;a=blobdiff_plain;f=include%2Fcommon%2Fhathreads.h;h=7b94ba18b6909fc2d6b1e363aec4b306c6eb6dcb;hp=6d8716b870b37508cda74072216ea84c36105528;hb=7ef9a3a4cff7b630de2aea16be4a066726a2ee5d;hpb=d3a82110a0835b361a8ebf147e8400271ea165da
-
-diff --git a/include/common/hathreads.h b/include/common/hathreads.h
-index 6d8716b..7b94ba1 100644
---- include/common/hathreads.h
-+++ include/common/hathreads.h
-@@ -626,7 +626,7 @@ extern struct lock_stat lock_stats[LOCK_LABELS];
- #define __SPIN_INIT(l) ({ (*l) = 0; })
- #define __SPIN_DESTROY(l) ({ (*l) = 0; })
- #define __SPIN_LOCK(l) pl_take_s(l)
--#define __SPIN_TRYLOCK(l) !pl_try_s(l)
-+#define __SPIN_TRYLOCK(l) (!pl_try_s(l))
- #define __SPIN_UNLOCK(l) pl_drop_s(l)
-
- #define __HA_RWLOCK_T unsigned long
-@@ -634,10 +634,10 @@ extern struct lock_stat lock_stats[LOCK_LABELS];
- #define __RWLOCK_INIT(l) ({ (*l) = 0; })
- #define __RWLOCK_DESTROY(l) ({ (*l) = 0; })
- #define __RWLOCK_WRLOCK(l) pl_take_w(l)
--#define __RWLOCK_TRYWRLOCK(l) !pl_try_w(l)
-+#define __RWLOCK_TRYWRLOCK(l) (!pl_try_w(l))
- #define __RWLOCK_WRUNLOCK(l) pl_drop_w(l)
- #define __RWLOCK_RDLOCK(l) pl_take_r(l)
--#define __RWLOCK_TRYRDLOCK(l) !pl_try_r(l)
-+#define __RWLOCK_TRYRDLOCK(l) (!pl_try_r(l))
- #define __RWLOCK_RDUNLOCK(l) pl_drop_r(l)
-
- #define HA_SPINLOCK_T struct ha_spinlock
-@@ -1023,7 +1023,7 @@ static inline void __spin_unlock(enum lock_label lbl, struct ha_spinlock *l,
- #define HA_SPIN_INIT(l) ({ (*l) = 0; })
- #define HA_SPIN_DESTROY(l) ({ (*l) = 0; })
- #define HA_SPIN_LOCK(lbl, l) pl_take_s(l)
--#define HA_SPIN_TRYLOCK(lbl, l) !pl_try_s(l)
-+#define HA_SPIN_TRYLOCK(lbl, l) (!pl_try_s(l))
- #define HA_SPIN_UNLOCK(lbl, l) pl_drop_s(l)
-
- #define HA_RWLOCK_T unsigned long
-@@ -1031,10 +1031,10 @@ static inline void __spin_unlock(enum lock_label lbl, struct ha_spinlock *l,
- #define HA_RWLOCK_INIT(l) ({ (*l) = 0; })
- #define HA_RWLOCK_DESTROY(l) ({ (*l) = 0; })
- #define HA_RWLOCK_WRLOCK(lbl,l) pl_take_w(l)
--#define HA_RWLOCK_TRYWRLOCK(lbl,l) !pl_try_w(l)
-+#define HA_RWLOCK_TRYWRLOCK(lbl,l) (!pl_try_w(l))
- #define HA_RWLOCK_WRUNLOCK(lbl,l) pl_drop_w(l)
- #define HA_RWLOCK_RDLOCK(lbl,l) pl_take_r(l)
--#define HA_RWLOCK_TRYRDLOCK(lbl,l) !pl_try_r(l)
-+#define HA_RWLOCK_TRYRDLOCK(lbl,l) (!pl_try_r(l))
- #define HA_RWLOCK_RDUNLOCK(lbl,l) pl_drop_r(l)
-
- #endif /* DEBUG_THREAD */
diff --git a/net/haproxy20/files/patch-ebtree-ebtree.c b/net/haproxy20/files/patch-ebtree-ebtree.c
deleted file mode 100644
index e78c5aa8a41c..000000000000
--- a/net/haproxy20/files/patch-ebtree-ebtree.c
+++ /dev/null
@@ -1,35 +0,0 @@
-From: Willy Tarreau <w@1wt.eu>
-Date: Mon, 20 Jul 2020 19:40:14 +0000 (+0200)
-Subject: BUILD: ebtree: fix build on libmusl after recent introduction of eb_memcmp()
-X-Git-Url: http://git.haproxy.org/?p=haproxy-2.0.git;a=commitdiff_plain;h=5df32b51bb0c3c89b503d04cd7d31bdd77932370;hp=8e020e77ed8b30dad6dc0d0be2d287737823d856
-
-BUILD: ebtree: fix build on libmusl after recent introduction of eb_memcmp()
-
-In order to address a corner case with memory compares, commit 853926a
-("BUG/MEDIUM: ebtree: use a byte-per-byte memcmp() to compare memory
-blocks") introduced a new eb_memcmp() function, which uses ssize_t for
-an offset. However this one is not known by default in ebtree for versions
-prior to 2.2, and it depends on the libs. Musl requires unistd to be included
-to have it.
-
-This patch just adds this harmless include, which was verified to address
-issue #760. There is no mainline commit ID as 2.2 and above already include
-unistd.h as part of haproxy/api.h. It must be backported to older versions
-(2.0 already has the commit above).
-
-(cherry picked from commit c926085c7e01a93e326e8081f466d23304767a36)
-Signed-off-by: Willy Tarreau <w@1wt.eu>
----
-
-diff --git a/ebtree/ebtree.c b/ebtree/ebtree.c
-index e82ed59..10cc2ff 100644
---- ebtree/ebtree.c
-+++ ebtree/ebtree.c
-@@ -18,6 +18,7 @@
- * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
- */
-
-+#include <unistd.h>
- #include "ebtree.h"
-
- void eb_delete(struct eb_node *node)