aboutsummaryrefslogtreecommitdiff
path: root/net/haproxy
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2019-09-17 10:04:43 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2019-09-17 10:04:43 +0000
commit66bfb4769bc3e2a55ad42495b146b7ce45c6daea (patch)
treeefbab12edd8780fbd83f440b876946d8e3d29ea3 /net/haproxy
parent9ac1b25248b04998d7bc5d45e07566ad32b9764d (diff)
downloadports-66bfb4769bc3e2a55ad42495b146b7ce45c6daea.tar.gz
ports-66bfb4769bc3e2a55ad42495b146b7ce45c6daea.zip
Add a patch from upstream to fix checks.
PR: 240627 Submitted by: nbari
Notes
Notes: svn path=/head/; revision=512201
Diffstat (limited to 'net/haproxy')
-rw-r--r--net/haproxy/Makefile1
-rw-r--r--net/haproxy/files/patch-src-checks.c28
2 files changed, 29 insertions, 0 deletions
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index 00e8cd8bfcc0..1db2be2d4389 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -3,6 +3,7 @@
PORTNAME= haproxy
DISTVERSION= 2.0.6
+PORTREVISION= 1
CATEGORIES= net www
MASTER_SITES= http://www.haproxy.org/download/2.0/src/
diff --git a/net/haproxy/files/patch-src-checks.c b/net/haproxy/files/patch-src-checks.c
new file mode 100644
index 000000000000..cb1a260b8a66
--- /dev/null
+++ b/net/haproxy/files/patch-src-checks.c
@@ -0,0 +1,28 @@
+--- src/checks.c.orig 2019-09-17 10:00:12.658926000 +0000
++++ src/checks.c 2019-09-17 10:02:03.978010000 +0000
+@@ -1447,12 +1447,8 @@ static int wake_srv_chk(struct conn_stream *cs)
+ ret = tcpcheck_main(check);
+ cs = check->cs;
+ conn = cs->conn;
+- } else {
+- if (!(check->wait_list.events & SUB_RETRY_SEND))
+- __event_srv_chk_w(cs);
+- if (!(check->wait_list.events & SUB_RETRY_RECV))
+- __event_srv_chk_r(cs);
+- }
++ } else if (!(check->wait_list.events & SUB_RETRY_SEND))
++ __event_srv_chk_w(cs);
+
+ if (unlikely(conn->flags & CO_FL_ERROR || cs->flags & CS_FL_ERROR)) {
+ /* We may get error reports bypassing the I/O handlers, typically
+@@ -2262,9 +2258,7 @@ static struct task *process_chk_conn(struct task *t, v
+ * sending since otherwise we won't be woken up.
+ */
+ __event_srv_chk_w(cs);
+- if (!(conn->flags & CO_FL_WAIT_L4_CONN) ||
+- !(check->wait_list.events & SUB_RETRY_SEND))
+- __event_srv_chk_r(cs);
++ __event_srv_chk_r(cs);
+ }
+
+ task_set_affinity(t, tid_bit);