aboutsummaryrefslogtreecommitdiff
path: root/net/haproxy
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2020-07-28 21:14:16 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2020-07-28 21:14:16 +0000
commita03e7112bcf030e00ca9a9e6081fee4e42928915 (patch)
tree3d6996395b99c80a8ad6fb8eb9419ded1f3762f1 /net/haproxy
parent8153d2fdb6cdb012c2880ca250e32aa5734d9e3a (diff)
downloadports-a03e7112bcf030e00ca9a9e6081fee4e42928915.tar.gz
ports-a03e7112bcf030e00ca9a9e6081fee4e42928915.zip
Try to fix i386 builds: use GCC and -march=i586
to fix undefined symbol: __atomic_fetch_add_8. PR: 248289 Reported by: Victor Sudakov <vas@sibptus.ru>
Notes
Notes: svn path=/head/; revision=543634
Diffstat (limited to 'net/haproxy')
-rw-r--r--net/haproxy/Makefile5
-rw-r--r--net/haproxy/files/patch-include-haproxy-atomic.h11
2 files changed, 5 insertions, 11 deletions
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index d8ef71dfeac3..974de9c751f4 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -44,6 +44,11 @@ LUA_MAKE_ARGS= USE_LUA=1 LUA_INC=${LUA_INCDIR} LUA_LIB=${LUA_LIBDIR} LUA_LIB_NA
.include <bsd.port.pre.mk>
+.if ${ARCH} == "i386"
+MAKE_ARGS+= ARCH=i586
+USE_GCC= 9+
+.endif
+
.if ${ARCH} == "amd64" || ${ARCH} == "i386"
MAKE_ARGS+= USE_REGPARM=1
.endif
diff --git a/net/haproxy/files/patch-include-haproxy-atomic.h b/net/haproxy/files/patch-include-haproxy-atomic.h
deleted file mode 100644
index d8b7c8ea15cb..000000000000
--- a/net/haproxy/files/patch-include-haproxy-atomic.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/haproxy/atomic.h.orig 2018-02-17 18:17:22.219400000 +0000
-+++ include/haproxy/atomic.h 2018-02-17 18:18:44.598422000 +0000
-@@ -104,7 +104,7 @@ extern THREAD_LOCAL unsigned long tid_bit; /* The bit
- /* TODO: thread: For now, we rely on GCC builtins but it could be a good idea to
- * have a header file regrouping all functions dealing with threads. */
-
--#if defined(__GNUC__) && (__GNUC__ < 4 || __GNUC__ == 4 && __GNUC_MINOR__ < 7) && !defined(__clang__)
-+#if (defined(__GNUC__) && (__GNUC__ < 4 || __GNUC__ == 4 && __GNUC_MINOR__ < 7) && !defined(__clang__)) || (defined(__clang__) && defined(__i386__))
- /* gcc < 4.7 */
-
- #define HA_ATOMIC_ADD(val, i) __sync_add_and_fetch(val, i)