aboutsummaryrefslogtreecommitdiff
path: root/net/hexinject
diff options
context:
space:
mode:
authorSofian Brabez <sbz@FreeBSD.org>2016-08-04 18:14:31 +0000
committerSofian Brabez <sbz@FreeBSD.org>2016-08-04 18:14:31 +0000
commit3375231cf63cd89c475f6ac494d29c89cb1c13b5 (patch)
tree59a4f8f46d55183f6cb5a2436c8dd4efb0f4f36c /net/hexinject
parent14b933b2c1cde1b39a987ac4ad3a653b9b38ac4c (diff)
downloadports-3375231cf63cd89c475f6ac494d29c89cb1c13b5.tar.gz
ports-3375231cf63cd89c475f6ac494d29c89cb1c13b5.zip
Notes
Diffstat (limited to 'net/hexinject')
-rw-r--r--net/hexinject/Makefile6
-rw-r--r--net/hexinject/distinfo1
-rw-r--r--net/hexinject/files/patch-prettypacket.h12
3 files changed, 9 insertions, 10 deletions
diff --git a/net/hexinject/Makefile b/net/hexinject/Makefile
index 403ccd53e3cb..38b041628073 100644
--- a/net/hexinject/Makefile
+++ b/net/hexinject/Makefile
@@ -3,6 +3,7 @@
PORTNAME= hexinject
PORTVERSION= 1.5
+PORTREVISION= 1
CATEGORIES= net security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -11,15 +12,12 @@ COMMENT= HexInject is a very versatile packet injector and sniffer
LICENSE= BSD2CLAUSE
-LIB_DEPENDS= libpcap.so:net/libpcap
-
PLIST_FILES= bin/${PORTNAME}
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}
post-patch:
${REINPLACE_CMD} -e 's#gcc#${CC}#g' ${WRKSRC}/Makefile
- ${REINPLACE_CMD} -e '2s#-lpcap#-L${LOCALBASE}/lib -lpcap#' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
diff --git a/net/hexinject/distinfo b/net/hexinject/distinfo
index 1fc804f2e4c1..6bb6511b66dd 100644
--- a/net/hexinject/distinfo
+++ b/net/hexinject/distinfo
@@ -1,2 +1,3 @@
+TIMESTAMP = 1470332871
SHA256 (hexinject-1.5.tar.gz) = 329f0686069988ac0dae4a00082b205ac9669bc8e202d4b112c600bcbc198ce9
SIZE (hexinject-1.5.tar.gz) = 14449
diff --git a/net/hexinject/files/patch-prettypacket.h b/net/hexinject/files/patch-prettypacket.h
index dfb3048fdec6..5f9ddbba0d5c 100644
--- a/net/hexinject/files/patch-prettypacket.h
+++ b/net/hexinject/files/patch-prettypacket.h
@@ -1,6 +1,6 @@
---- ./prettypacket.h.orig 2012-12-04 10:31:27.000000000 +0100
-+++ ./prettypacket.h 2014-03-06 14:57:20.000000000 +0100
-@@ -102,7 +102,7 @@
+--- prettypacket.h.orig 2012-12-04 09:31:27 UTC
++++ prettypacket.h
+@@ -102,7 +102,7 @@ const char *next_color() {
* @param counter protocol number offset
* @return protocol number in host format
*/
@@ -9,7 +9,7 @@
return *(packet_buffer + counter);
}
-@@ -113,7 +113,7 @@
+@@ -113,7 +113,7 @@ inline uint8_t protocol_8bit_extract(con
* @param counter protocol number offset
* @return protocol number in host format
*/
@@ -18,7 +18,7 @@
return ntohs(*((uint16_t *)(packet_buffer + counter)));
}
-@@ -123,7 +123,7 @@
+@@ -123,7 +123,7 @@ inline uint16_t protocol_16bit_extract(c
* @param counter protocol number offset
* @return protocol number in host format
*/
@@ -27,7 +27,7 @@
uint64_t value = 0;
int i;
-@@ -144,7 +144,7 @@
+@@ -144,7 +144,7 @@ inline uint64_t protocol_48bit_extract(c
* @param counter read bytes counter
* @param field_text description of the field
*/